Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

Madman666

Killer and worker Bees don't return to hives\boxes

Recommended Posts

Madman666    80

@FuzzyBunnies @PaicCitron

 

When you noticed this problem? For example, for me it was around day ~60ish in first save and 82 in my second save. (I am using steam version by the way). I think maybe it occured much earlier, but I noticed it only when I started building Bee Boxes.

Share this post


Link to post
Share on other sites
PaicCitron    1

Don't remember when it started. I noticed few days ago that I had some flying desperately on the border of the map. My fix was to kill them.

I also had some bees stuck flying idle in the middle of nowhere for days until I killed them too. Don't know if this is related.

Share this post


Link to post
Share on other sites
Madman666    80

Don't remember when it started. I noticed few days ago that I had some flying desperately on the border of the map. My fix was to kill them.

I also had some bees stuck flying idle in the middle of nowhere for days until I killed them too. Don't know if this is related.

 

Yep, its all related. My guess is something went wrong, when devs tweaked bee's AI to be aggressive in Spring or something like that. In Spring there are 2 more of them in Bee Boxes (total 6 instead of 4) and I think they following you to attack longer distances (that were somewhere in the game files). When these changes were implemented - bugs started... I originally thought that this bug only affects Killer Bees, but apparently if you anger regular bees, making them leave bee box still as workers - they'll glitch too. This one problem is rather hard to detect, until you start building bee boxes.

 

I tried making a new save, deleting old ones, deleting the game completely erasing everything and starting new - at first bees behave normally, but at some point bug returns and it does not matter if you are using any mods or not.

Share this post


Link to post
Share on other sites
Madman666    80
Witnessed a strangest event - I was starting Don't Starve as always, but for some reason before opening the game a black window popped out, telling something about some "atlasing" process and listing files with % gauge. It was on screen rather long time, I decided not to touch it and waited. When it closed itself and DS started - bees somehow reverted to their normal state, returning to hives as they should. Unfortunately after some time of playing bug returned. I searched for ways to somehow cause this "atlasing" thing to happen again and fix the problem, but did not succeed.

 

Cmon, devs, @Bryce, @Wade, @SethR would you mind confirming this bug already? I'd understood if it was problem caused by mods, or if only I'd encountered it, but there others reporting this same issue and without using any mods! Just let us know you got it under control and I'll get lost and wait for patch silently and patiently...

Share this post


Link to post
Share on other sites
BurningBalls    27

Bees are acting funny for me too. No mods, default world.

I'm holding off on building a bee farm until there is some kind of fix.

I'm doing alright as Wigfrid though, instead of eating Honey Ham and nuggets, I am going for Pierogi and Bacon and Eggs. I'm not missing Honey Ham at all, Egg-based foods seem just as good.

I wouldn't mind some Honey poultices though.

Share this post


Link to post
Share on other sites

@FuzzyBunnies @PaicCitron

 

When you noticed this problem? For example, for me it was around day ~60ish in first save and 82 in my second save. (I am using steam version by the way). I think maybe it occured much earlier, but I noticed it only when I started building Bee Boxes.

It stands out in Archipelago world the most during adventure mode, days in doesn't really seem to matter.

Share this post


Link to post
Share on other sites
scize    50

i use no mods at all. and ran through one of those killer bee colonies. when i ran back through it, there were at least 20 killer bees flying endlessly towards the ocean.

Share this post


Link to post
Share on other sites
Bryce    1,068

It's possible that these problems were caused by the changes we recently made to start/stop updating entities. I made a change that we'll push out soon that might fix the issue. It's hard to know because I'm not seeing these issues on our machines.

 

For those who are interested - the update.lua script will now preform "Stop" before "Start".

Share this post


Link to post
Share on other sites
Madman666    80

It's possible that these problems were caused by the changes we recently made to start/stop updating entities. I made a change that we'll push out soon that might fix the issue. It's hard to know because I'm not seeing these issues on our machines.

 

For those who are interested - the update.lua script will now preform "Stop" before "Start".

 

Its enough for me, that you guys know about this problem and that its occurs regardless of mod usage and you are doing something about it) I can sleep again now, heh.

 

And if the change you are talking about will fix this - I'll inform you (since it does not show up on your machines) and update this thread, so it won't distract you from other important things you are working on.

Share this post


Link to post
Share on other sites
Clwnbaby    938

I play with out mods and I too have had this issue.  Even when you are capturing honey bees and the angry bees come out when they return to the hive they just hover there and never actually go in.  And from time to time they will eventually fly endlessly in one direction.  Once again this problem occured to me and I NEVER USE MODS.

Share this post


Link to post
Share on other sites
Madman666    80

I play with out mods and I too have had this issue.  Even when you are capturing honey bees and the angry bees come out when they return to the hive they just hover there and never actually go in.  And from time to time they will eventually fly endlessly in one direction.  Once again this problem occured to me and I NEVER USE MODS.

 

Well, other players have same issue (I am too) and without mods. But don't worry as Bryce said - they know about it and will deal with it. For now just concentrate on doing something that does not invovlve bees :-)

Share this post


Link to post
Share on other sites
UnderwearApp    134

 

Witnessed a strangest event - I was starting Don't Starve as always, but for some reason before opening the game a black window popped out, telling something about some "atlasing" process and listing files with % gauge. It was on screen rather long time, I decided not to touch it and waited. When it closed itself and DS started - bees somehow reverted to their normal state, returning to hives as they should. Unfortunately after some time of playing bug returned. I searched for ways to somehow cause this "atlasing" thing to happen again and fix the problem, but did not succeed.
 
Cmon, devs, @Bryce, @Wade, @SethR would you mind confirming this bug already? I'd understood if it was problem caused by mods, or if only I'd encountered it, but there others reporting this same issue and without using any mods! Just let us know you got it under control and I'll get lost and wait for patch silently and patiently...

 

 

That black box was the mod tools autocompiler building items for the game. If you have no mods installed, it was probably building the screecher files. This can be disabled at start-up to avoid the wait if you prefer.

 

As for the bee issue, not sure. I have a Wigfrid game at ~110 days and do not have this problem, nor have I witnessed it on any other games (none past day ~30 though).

Share this post


Link to post
Share on other sites
Madman666    80

That black box was the mod tools autocompiler building items for the game. If you have no mods installed, it was probably building the screecher files. This can be disabled at start-up to avoid the wait if you prefer.

 

As for the bee issue, not sure. I have a Wigfrid game at ~110 days and do not have this problem, nor have I witnessed it on any other games (none past day ~30 though).

 

Then it must've been something else that temporarily fixed the problem. I don't know what causes it - dev's didn't manage to reproduce it on their machines, but you probably saw the video. And some other players encountered it too. I just hope that it'll fix itself with the new patch. But thanks for the info anyway)

Share this post


Link to post
Share on other sites
UnderwearApp    134

Then it must've been something else that temporarily fixed the problem. I don't know what causes it - dev's didn't manage to reproduce it on their machines, but you probably saw the video. And some other players encountered it too. I just hope that it'll fix itself with the new patch. But thanks for the info anyway)

No worries, I have seen this issue on various stream gameplay, just not to me personally.

Share this post


Link to post
Share on other sites

I have this issue and have only ever used the screecher mod.  I didn't used to have it and have noticed it in about the last two weeks being an  issue.   Steam version, RoG, don't know if that helps but there you go, is an issue as currently as this post.  

Share this post


Link to post
Share on other sites
BurningBalls    27

This isn't just bees though, it seems to be an AI problem in general. Pigs running endlessly to the left, Hounds just standing there staring into empty space, etc.

 

I suspect it won't be too hard to fix though, hopefully the next patch will clear it up.

Share this post


Link to post
Share on other sites
Tumalu    546

Hopefully the next patch will clean it up, yeah. I've seen several odd things like strange-acting hounds and merfolk standing still in the middle of nowhere. Bees are definitely the most easily apparent of the lot, though. I see often see them moving mindlessly into the distance or hovering against the ocean forever, or hugging their home.

Share this post


Link to post
Share on other sites
mwelling12    30

I, too, can add that I've noticed this same behavior, particularly with the bees. I noticed it on day 3, when I attacked a beehive. The killer bees agro'ed, but once I ran far enough away, they just hovered in place and I was able to destroy their hive uncontested. This happened twice.

 

I've also noticed on other saves hounds just standing in place; additionally, when I befriended a pig, he followed me for more than a single day, not returning home when dusk came. Merms, as well, have been acting strangely.

 

There does seem to be a larger AI issue present. A fix would be greatly appreciated, because these bugs affect the core gameplay pretty substantially. It really makes me feel like I don't want to continue playing until things are fixed...

Share this post


Link to post
Share on other sites
ZnSstr    64

My problem with red bees is a bit different.

 

After leaving me alone, they random go to margin of the map for no reason and stay there until they got attacked.

 

Hounds have a similar problem, last hound black/white is freezing and he attacking me again if I am going hit him.

 

I saw an update seconds ago, I hope fixes some issues.

Share this post


Link to post
Share on other sites
Madman666    80

My problem with red bees is a bit different.

 

After leaving me alone, they random go to margin of the map for no reason and stay there until they got attacked.

 

Hounds have a similar problem, last hound black/white is freezing and he attacking me again if I am going hit him.

 

I saw an update seconds ago, I hope fixes some issues.

 

I believe all problems concerning mobs getting stuck with one single type of behaviour (returning home, getting stuck in one place (hounds), running endlessly in one direction regardless of obstacles) have been resolved in latest patch. At least bees now returning home properly even in my older broken saves.

Share this post


Link to post
Share on other sites