This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.


(BUG) Lost a whole world to...darkness?!?

Recommended Posts

So, I was playing Reign of Giants early access. I've been playing Reign of Giants since it's early access on steam, and have been experimenting with different characters to see how they fared against the new features. I had a particularly good world as WX-78, I was in and out of the ruins by day 40! I had full upgrades and all was great...until I got to the surface. When I got to the surface, it was permanent night! Nothing I tried, like spending a day back in the caves, going into maxwell's door and suiciding worked! I ended up having to delete the world and start fresh....Needless to say, I was aggrivated with the whole experience. I think Klei is a great company, and Don't Starve is one of my favorite games I've played, but please patch these major glitches.

Share this post

Link to post
Share on other sites
dimQ    0

by rezecib

" Edit: Found a way to fix it in a bugged save:

  1. Open the console (backtick-tilde key `/~)
  2. Type: GetSeasonManager():SetSegs({day=8, dusk=4, night=4}, {day=6, dusk=5, night=5}, {day=8, dusk=4, night=4}, {day=11, dusk=3, night=2})
  3. Hit enter, remove console from screen (ctrl+L), and play!

Edit #2: accidentally had "." instead of ":" to call SetSegs (!!) "


next time watch for already existed threads before create same one.

Share this post

Link to post
Share on other sites