Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

BigDub

[Graphics] Invisible Rabbit Holes

Recommended Posts

BigDub    0

Graphics

Steam - Windows 7 x64

No mods.

I have completely reinstalled, and the problem persists, so the version number is whatever the latest version on steam is as of April 4th, 2014.

 

Invisible rabbit holes.

 

No steps required to reproduce, happens consistently each time I open the game, whether loading a save or starting a new world.

 

I am quite confused on this one. Not having an internet connection for a while and having Don't Starve installed I decided to start playing it again today. Everything was operating normally, I played a 19 day game and started up another one with my newly unlocked Woodie. After a while the game started stuttering. It was as if it was dropping half the frames, not unplayable, but definitely annoying. I thought reloading might solve the issue, so I quit to main menu but found the Wilson in the corner was stuttering as well, so I exited the entire program. I reloaded the program and the problem appeared to be gone, but upon loading the save I noticed that I could not see any rabbit holes. Rabbits ran about and disappeared into the ground where their holes were, but nothing was being rendered to indicate there was a rabbit hole there.

Thinking perhaps the texture was missing I tried having steam verify the game cache or whatever they call it. This did not solve the problem.

Next I dug into the game files and found the rabbit_hole.zip thinking perhaps this file was corrupted I deleted it and ran the verify game cache thing again. It found the missing file and redownloaded it. This still did not solve the problem.

Next I reinstalled the game. The problem persisted.

I found this little gem repeated dozens of times in the log file:

"Could not find anim [idle] in bank [rabbithole]"

I do not understand how the issue could have persisted through a reinstall though. I can't find where the saves are stored though, even when looking at the file handles opened by the process, but I think there is is something corrupted in there. I tried renaming the DoNotStarve folder in My Documents\Klei but that only seems to reset my options. I can't find where to nuke my profile information, but I am split on doing that even if I knew where it was because I do not want to clear my Morgue, levels, and saves.

 

Any idea what is going on here?

 

Share this post


Link to post
Share on other sites
ZXLegend    0

The same exact thing is happening to me. I made a post about it not realizing you had just made one :p. The only thing I can do with the holes is dig them up.

Share this post


Link to post
Share on other sites
BigDub    0

Hmm, there seems to be a third thread as well. This makes me think a bug slipped through the newest release and it is a problem in the code itself, not any local file corruption.

Share this post


Link to post
Share on other sites
BigDub    0

Huh... I can't seem to edit my previous posts... Anyhow, added information. I noticed that ZXLegend's post mentioned he was using the Lumberjack as well when the problem arose. I just wanted to add that I tried making a new world with the lumberjack, and several times with Wilson when I was testing. The problem occurs with both characters, so I do not think it is related to the character, though I can not be certain whatever caused it in the first place is not.
Also in regard to ScollenDollen's post. I have not noticed any issues with blurry graphics on my machine. I think that part of his issue may be unrelated.

Share this post


Link to post
Share on other sites
tomye52005    10

Same here. I tried to reinstall the game and it can't help. It was normal when i played yesterday but the problem appear today. I tried to open a new save but the hole still invisble. Hope someone can help us to solve this problem :c

Share this post


Link to post
Share on other sites
Delacroix    0

I am almost completely positive this development has to do with the tiny patches between now and yesterday. It's certainly nothing to do with mods as I can confirm it occurs with and without any on.

Share this post


Link to post
Share on other sites
MrObvious    0

So, I have been having the same problem, and I thought, that just mabey if I buy the new DLC (Reign of Giants) there might be a posibility that it would fix the problem. I discovered that when you run the DLC enabled, the problem was fixed and rabbit holes are now visable, but when you disable the DLC in the main menu when creating a new world and run vahnila, the problem is still there. Currently the DLC is on a 20% off sale, but its still not really a fix to the problem. Anyway I thought I should just post this as you guys might be interested. Hope that you may find this some what usefull.

Reign of Giants Reign of Giants Reign of Giants

Share this post


Link to post
Share on other sites
BigDub    0

Huh... In reign of giants is there animation added to the rabbit hole that does not exist in vanilla? I could understand some core code changes that assumed certain assets have a set animations available that the original one did not..
 

More importantly, tomye52005, how did you edit your post? XD
I can't find any buttons to do so.

Share this post


Link to post
Share on other sites
Stanima    0

This also happens to me, just saw the dlc on steam, decided to replay the game. I load one of my save and boom, all the rabbit holes near my base are gone.

Share this post


Link to post
Share on other sites
tomye52005    10

Huh... In reign of giants is there animation added to the rabbit hole that does not exist in vanilla? I could understand some core code changes that assumed certain assets have a set animations available that the original one did not..

 

More importantly, tomye52005, how did you edit your post? XD

I can't find any buttons to do so.

on the bottom right of your post you will see button Multiquote , the edit button is left next to it

Hope you know what i am saying because my English is not good

Share this post


Link to post
Share on other sites

Another one here also suffering from invisible rabbit holes. I recently bought the ROG DLC and the rabbit holes function just fine there. However when I loaded my favourite save file (day 224) with DLC the holes vanish. I had traps set on top of dozen of rabbit holes and checking them once they have been triggered still produces a rabbit but no hole beneath to examine. Rabbits still run in and out so they must be there I just can't see them any more.

Share this post


Link to post
Share on other sites
roninfrog    0

Same thing happened for me this morning. Loaded saved game on day 4 and the rabbit holes were invisible. Last night I played with a 70 day game and rabbit holes were visible. Then started this game and they were also visible. Dunno what changed overnight.

Share this post


Link to post
Share on other sites
DeadOne    0

Same thing here. Yesterday everything were ok, but in the morning it happened. Now I can't see rabbit's holes. I've tried to reinstall game and change graphic parameters.. the problem still here.. I hope that tomorrow I won't see this problem again.

Share this post


Link to post
Share on other sites
Kanakadea    0

Same problem here. Playing with Wilson.

At first I thought it was a new feature to make farming rabbits with Traps harder (way too hard).

Share this post


Link to post
Share on other sites
Coralushi    0

I got the same problem.. 

Yesterday everything was fine, but now the rabbits disappear in invisble rabbitholes.

I hope this gets fixed soon.

Share this post


Link to post
Share on other sites
LoicB    0

Hello,

Same issue for me.... cannot play without rabbit hole.

Reboot PC win7, stop all other applications (Java)... same.

REV 99231

New game : same

Existing game : same

Desperate.

HEEEEELP

Share this post


Link to post
Share on other sites
Urbstudio    12

I also have had this happen to me. Came back a week ago and then yesterday, no rabbit holes. I am sad because I though it was a corruption in my save game or something so I deleted my world and created a new one. Still no rabbit holes. Now I am a bit sad because my first world was a great start, and I can't use my rabbit trapping strategy because I can't see the rabbit holes. ;-;

Share this post


Link to post
Share on other sites

Yeah im having this same error,It caused me to lose a day 34 world :/ .Also I got the blurriness for a while too and when it became sharp again all my rabbit holes were gone.

Share this post


Link to post
Share on other sites
Darkaddion    0

Having this problem as well. Very annoying when trying to catch rabbits as a main food source. Playing on a Wilson world if it helps.

Share this post


Link to post
Share on other sites