Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

Walkoprops2

Sudden drop in graphics after getting the DLC

Recommended Posts

Walkoprops2    0

Good evening people  :joyous: 

Yesterday, I got the fantastic news that the Reign of Giants DLC had come to steam, and holy hell I was excited (still am, to be honest). I started playing it with no problems whatsoever, even managed to unlock Webber after my first 7 in-game days on RoG. :listening_headphone 

But then disaster struck. I had some mod-character installed and still had a long playthrough with one of them. I thought that I wanted to give it a go before I'd  get rid of those for good, and for some reason, the graphics in Don't Starve went down to corny representation of what the game really is :(

As you may see in the pictures I attached, it doesn't seem to have an effect on in-game characters and moving mobs, but everything else. the texts, the picture boxes, and the clock (not the menu on the left for some reason).

I tried to delete and then reinstall Don't Starve, but it didn't fix anything, so now I'm reduced to ask for assistance on this lovely forum.

 

TL;DR: Played RoG with outdated mods, now the graphics lost quality, what do?

On second though, it's only drasticly blurry in full-screen and when it's put into window mode, only small particles gets drowsed away (small pictures)

post-363474-0-42355200-1396558388_thumb.

post-363474-0-52323100-1396558391_thumb.

post-363474-0-57896000-1396558394_thumb.

post-363474-0-56790000-1396558398_thumb.

Share this post


Link to post
Share on other sites
SethR    1,229

Have you checked your resolution settings? It sounds like they got reset somehow.

Share this post


Link to post
Share on other sites
jbeetle    1,872

and if not your res settings, check your mipmap settings in your graphics card control panel.

Share this post


Link to post
Share on other sites
Walkoprops2    0
SethR
 
I've checked and double checked the settings, and there seems to be nothing out of order (Nothing out of ordinary)



jbeetle
 
There seems to be nothing out of ordinary on the graphic card settings either. Hm... I hope there's some other options some of you know of I can try before giving up?


 

 

Share this post


Link to post
Share on other sites
JanH    6,386

In addition to what Seth asked, are you running an AMD Radeon GPU?

 

If you are, you should be able to fix the blurry HUD elements in your game by going to your CCC (Catalyst Control Center) and overriding your application mipmap settings to "Quality" instead of "Performance.

 

You'll find more info about that on this forum thread. Let us know if it works for you.

Share this post


Link to post
Share on other sites
Sideview    81

Got a similar issue since my first steps in Don't Starve last year. I tried changing the resolution (both game res and screen res), enable/disable the "small textures" thing, enable/disable fullscreen mode, but nothing changed.

 

I still can't see how many components i need to craft every items (I know how many, but it's not readable in the craft menu), and when worn, tools/weapons/clothes are a bit blurry/pixelised. Gonna post some screenshots soon.

 

Edit : Screenshot added

 

435965blurry.png

 

I'm playing on 1920*1080. Check it on full size, blurry numbers on craft menu are not really visible on forum.

Share this post


Link to post
Share on other sites
Tamazacat    130

I found this happened when I had distortion enabled since my graphics card isn't great. When I turned it off, everything was fine :)

Share this post


Link to post
Share on other sites
Walkoprops2    0

SethR

Looks like there's no settings in the game directly that has this effect on the textures... Sorry for bothering you so much  :hopelessness: 


JanH

I'm not too good when it comes to the technicall parts, but I'm guessing you're talking about a graphic card series. In this case, no. I'm using GeForce 9800 GT. There are some settings corresponding to performance and quality as you mentioned I could tweak around with, but nothing changed for anything better unfortunately.  :frown: 

Sideview

It looks like you share the same problems as me there. Do you by any chance use the same graphic card series that I do? (GeForce series)


I tried to run Don't Starve on my laptop, and everything was fine and dandy. I guess there could be trouble with the files on this computer. Is there by any chance anything I can do with it? (Except for reinstaling the game, 'cause that didn't work)

Share this post


Link to post
Share on other sites
JanH    6,386

On your options > settings screen, could you check if "Netbook Mode" is enabled? If it is, disable it and see if that fixes your blurry graphics issue. 

Share this post


Link to post
Share on other sites
CityOfGloom    7

Try taking it off fullscreen, and start a completely different game with a random character and see if the graphics change for that specific save file

Share this post


Link to post
Share on other sites
xaldre    11

I have the exact same issue, for some reason since i got the DLC my game just doesn't show some resolutions how it supposed, and the graphics menu doesn't even work. I can try to put the game at 640x480 and nothing changes, you see the same everything, and the weirdest part is that when i go again to the options the resolution is again in the same 1920x1080 setting, for some reason not everything is low ress, but most of the things are. Its just awful :(.

 

Nothing of the previously mentioned helped me fixing the issue. I even reinstalled the game a couple times.

Btw: this thing happens even in the menu.

 

Screen to show:

rZ4fanm.jpg

 

EDIT: Somehow i fixed it. Let me explain what i did. I disabled everything, from the bloom, to the small textures, and disabled fullscreen also, then closed the game, and i oppened again (remember, with EVERYTHING disabled) and now the game loaded fine and i was able to turn on the fullscreen without loosing anything. 

 

Hope this works for you too.

Share this post


Link to post
Share on other sites
Sideview    81

Sideview

It looks like you share the same problems as me there. Do you by any chance use the same graphic card series that I do? (GeForce series)

 

Yes, I run with a GeForce GTX 670M, and one of my friends is getting the same issue with a GeForce 8600GT.

 

 

EDIT: Somehow i fixed it. Let me explain what i did. I disabled everything, from the bloom, to the small textures, and disabled fullscreen also, then closed the game, and i oppened again (remember, with EVERYTHING disabled) and now the game loaded fine and i was able to turn on the fullscreen without loosing anything. 

 

Hope this works for you too.

 

I will give it a try. EDIT : It somewhat worked for me :grin: I still have blurry tools/animals, etc... but I can read how much components I need. This just fix the blurry font problem for one game session, I have to make the same process every time I launch DS.

 

Here is a screen of what i'm getting with this temporary fix :

149145blurry2.png

Share this post


Link to post
Share on other sites
xaldre    11

For what i've gather, it comes back every time i try to enable something along the lines of blur, and that options, i lefted all disabled, and now works perfect every sesion.

Share this post


Link to post
Share on other sites
Walkoprops2    0

Xaldre

That thing you found out worked partially. Just like SideView's game, the main game's graphic are still blurry, but the numbers, letters and small pictures in general are back to normal, so it's a start!  :joyous: 


SideView

Looks like this is a GeForce graphic card problem then... Must've been the update that did this then  :indecisiveness:

Share this post


Link to post
Share on other sites
Walkoprops2    0

I think it's fixed!


I played around with what Xaldre mentioned fixed his game, and IT DID!
Before I turn of the game, I go to the options and turn off *all* the extra effects, and put the game in window mode, just as Xaldre did.

And when I come back, I started a new world and everything looks nice again. While in-game, I turned up the graphics again with no penalty to the quality.

Everything looks okay again :-)

So, SideView, I believe this is the only "good" way to fix the graphical bug, and let's just hope it'll get fixed on the next update ~

post-363474-0-07780900-1397139470_thumb.

Share this post


Link to post
Share on other sites
Sideview    81

I think it's fixed!

I played around with what Xaldre mentioned fixed his game, and IT DID!

Before I turn of the game, I go to the options and turn off *all* the extra effects, and put the game in window mode, just as Xaldre did.

And when I come back, I started a new world and everything looks nice again. While in-game, I turned up the graphics again with no penalty to the quality.

Everything looks okay again :-)

So, SideView, I believe this is the only "good" way to fix the graphical bug, and let's just hope it'll get fixed on the next update ~

 

Yup, Xaldre method fixed it for me and my friend. Many thanks to him :)

Share this post


Link to post
Share on other sites