Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

Jaharmer

Warning error...

Recommended Posts

Jaharmer    0

Every time I start up my game I get the error below, I keep reinstalling it, but I Still get the same error. Thanks in advance

post-329194-0-04315400-1391729609_thumb.

Share this post


Link to post
Share on other sites
Wade    309

Can you verify the integrity of your game cache to see if that helps?

 

You may want to also try disabling your Steam Cloud to see if it makes a difference.

Share this post


Link to post
Share on other sites
Wade    309

Are you using any mods?

 

When you perform the uninstall\reinstall, are you manually deleting all of the files in your game folder as well?

Share this post


Link to post
Share on other sites
Jaharmer    0

I was using the too many items mod and then i uninstalled it, eventually it stopped working. And I have tried manually deleting the files in the game folder too and I've sometimes just reinstalled it. I've tried reinstalling it serveral times.

Share this post


Link to post
Share on other sites
Wade    309

Okay, I'll have to have the programmers look at the code to try to figure out why that issue could be coming up.

 

It looks to be that your morgue file got corrupted somehow, but performing a re-install and wiping out all of your local files should be remedying it. When you delete the files in the game folder, are you also deleting all of your save files in your "documents\klei\donotstarve\" folder?

Share this post


Link to post
Share on other sites
Wade    309

Okay, after the hotfix is released tomorrow, can you post the contents of your log.txt file from your "documents\klei\donotstarve\" folder?

 

(The file will be blank until the hotfix)

Share this post


Link to post
Share on other sites
Jaharmer    0
Starting up

Don't Starve: 96948 WIN32_STEAM

Build Date: 2014-02-28_17-51-41

THREAD - started 'GAClient' (11240)

HttpClient::ClientThread::Main()

cGame::InitializeOnMainThread

WindowManager::Initialize

GLInfo

~~~~~~

GL_VENDOR: Google Inc.

GL_RENDERER: ANGLE (Intel® HD Graphics 3000)

GL_VERSION: OpenGL ES 2.0 (ANGLE 1.0.0.2249)

GL_SHADING_LANGUAGE_VERSION: OpenGL ES GLSL ES 1.00 (ANGLE 1.0.0.2249)

THREAD - started 'WindowsInputManager' (15596)

OpenGL extensions (19, 19):

GL_ANGLE_depth_texture

GL_ANGLE_framebuffer_blit

GL_ANGLE_framebuffer_multisample

GL_ANGLE_instanced_arrays

GL_ANGLE_pack_reverse_row_order

GL_ANGLE_texture_compression_dxt3

GL_ANGLE_texture_compression_dxt5

GL_ANGLE_texture_usage

GL_ANGLE_translated_shader_source

GL_EXT_read_format_bgra

GL_EXT_robustness

GL_EXT_texture_compression_dxt1

GL_EXT_texture_format_BGRA8888

GL_EXT_texture_storage

GL_OES_get_program_binary

GL_OES_packed_depth_stencil

GL_OES_rgb8_rgba8

GL_OES_standard_derivatives

GL_OES_texture_npot

GL_MAX_TEXTURE_SIZE = 8192

GL_MAX_TEXTURE_IMAGE_UNITS = 16

GL_MAX_RENDERBUFFER_SIZE = 8192

GL_MAX_VIEWPORT_DIMS = 8192, 8192

GL_MAX_VARYING_VECTORS = 10

GL_MAX_VERTEX_ATTRIBS = 16

GL_MAX_VERTEX_UNIFORM_VECTORS = 254

GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS = 4

GL_MAX_FRAGMENT_UNIFORM_VECTORS = 221

4 compressed texture formats

texture format 0x83f0

texture format 0x83f1

texture format 0x83f2

texture format 0x83f3

cDontStarveGame::DoGameSpecificInitialize()

cGame::StartPlaying

LOADING LUA

DoLuaFile scripts/main.lua

DoLuaFile loading buffer scripts/main.lua

scripts/main.lua(158,1) running main.lua

 

DoLuaFile Error: ...eamapps/common/dont_starve/data/scripts/modindex.lua:415: could not load modsettings: ../mods/modsettings.lua

LUA ERROR stack traceback:

        =[C] in function 'assert'

        C:/Program Files (x86)/Steam/steamapps/common/dont_starve/data/scripts/modindex.lua(415,1) in function 'UpdateModSettings'

        C:/Program Files (x86)/Steam/steamapps/common/dont_starve/data/scripts/modindex.lua(245,1) in function 'Load'

        scripts/main.lua(269,1) in main chunk

...eamapps/common/dont_starve/data/scripts/modindex.lua:415: could not load modsettings: ../mods/modsettings.lua

LUA ERROR stack traceback:

        =[C] in function 'assert'

        C:/Program Files (x86)/Steam/steamapps/common/dont_starve/data/scripts/modindex.lua(415,1) in function 'UpdateModSettings'

        C:/Program Files (x86)/Steam/steamapps/common/dont_starve/data/scripts/modindex.lua(245,1) in function 'Load'

        scripts/main.lua(269,1) in main chunk

Error loading main.lua

Failed mSimulation->Reset()

Error during game initialization!

Collecting garbage...

lua_gc took 0.01 seconds

~SimLuaProxy()

lua_close took 0.01 seconds

HttpClient::ClientThread::Main() complete

Shutting down

Share this post


Link to post
Share on other sites
Wade    309

Hmm, okay, the error message here looks to be mod related.

 

Can you try going into the Steam Workshop for the game and unsubscribing to all of the mods?

Share this post


Link to post
Share on other sites
Jaharmer    0

I tried that, it didn't work i thinks it's because i may have installed a mods by dragging it to that one folder, i played with the mod for a while before my game stopped working. What folder do you think i dragged it to, so i can delete it. If that's not the case, do you have any other suggestions?

Share this post


Link to post
Share on other sites
Wade    309

If you installed a mod by placing it into a folder, it would be in your "C:\Program Files (x86)\Steam\SteamApps\common\dont_starve\mods" folder.

Share this post


Link to post
Share on other sites
Wade    309

Do you have a "modsettings.lua" file in the folder?

 

The log file is showing that it is trying to find and load the file, but is unable to do so.

Share this post


Link to post
Share on other sites
Wade    309

This file should be installed when you initially install the game. Is it possible you are accidentally deleting it?

Share this post


Link to post
Share on other sites
Wade    309

Can you try re-installing the game one more time and see if it creates the file?

 

If not, you can try creating a blank text file and labelling it "modsettings.lua" and see if that will work.

Share this post


Link to post
Share on other sites
Jaharmer    0

Okay, so now i have the modsettings.lua file. And it is showing this, i don't know if its the same error, or what

post-329194-0-03119300-1395263169_thumb.

Share this post


Link to post
Share on other sites
Wade    309

Yeah, that looks to be the same error.

 

Argh, okay, I'm going to have to pass along the error to the programming team to look at, as I'm not sure what the problem could be.

 

Normally this sort of issue can be addressed by a re-install, but files are still not being set properly for some reason.

Share this post


Link to post
Share on other sites
simplex    2,608

@Jaharmer

It looks like your morgue file got corrupted (and it is not removed when uninstalling/reinstalling the game).

Have you tried deleting the file called "morgue", which is either in

Documents/klei/donotstarve/Save/morgue

or

C:/Program FIles (x86)/Steam/userdata/{Your Steam ID Number }/219740/remote/morgue

?

Share this post


Link to post
Share on other sites
Jaharmer    0

@simplex

 

No, sadly deleting the file did not work and in case you are wondering or in the case that this may help, when i open the document morgue, all it says is KLEI  

Share this post


Link to post
Share on other sites
Wade    309

Can I get you both to zip up your morgue files and post them here?

 

Our programmers would like to look at them.

Share this post


Link to post
Share on other sites