Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

Jumpmanjam

(PS4) Day 625 Ruins Crash of Death

Recommended Posts

Jumpmanjam    0

Bug Submission

Please choose a category
*Pick the option that fits the issue the most. Ideally use this in your thread title aswell*

[Graphics]

[Gameplay]

[Exploit]

[Crash]<-------------

[sound]

Platform
* Pick your platform. For instance, standalone on Mac is also possible.*

  • PS4<---------------
  • Steam
  • Chrome
  • Standalone
  • Mac
  • Linux
    Do you use mods?
     
             no
    Version Number
     

    N/A

    Issue title
     

    The game crashes upon entering the ruins, and now my day 625 file is now stuck in an error limbo. I spent so much time on this.

    Steps to reproduce
     

    I went into an already opened ruins entrance and the game crashes about a second after the black autosave screen disappears. 

    Describe your issue
     

    I've been in the ruins a total of two times prior to this. The first time I went down there, the game slowed to about a few frames a second for some reason, until Willow hit the ground. Then the game played fine. I didn't pay it that much attention, and I thought it was just a one time freak thing. I went over to the ancient guardian, and it killed me. I respawned from a meat effigy and after about 15 days I went back into the ruins and tried to kill it again. This time there was no slowdown at all, but the game spawned me right where I died, right in front of the ancient guardian. I ended up killing it and getting out of there. Those two times were in the 4 and 5 hundred days. Today I tried to go back in to craft some ancient stuff. I was on day 625. I entered the ruins entrance with a fairly full inventory, with the Krampus bag. I had Chester with me and a lantern equipped. Just after the loading screen you can see chester already on the ground. The game freezes about a half second after it loads and gives me an error code. The error code is Ce-34878-0, I don't know if that matters here. I'm assuming that it's doing the slowdown that it did the first time I went down there, but it can't handle it anymore. The file is still there and every single time I try to load it up it freezes after a half second. During that half second I can push options and mess with the pause menu or I can push the r2 button and access my inventory. As soon as I leave those menus though, the game will give me an error. I'm new to don't starve, I've never played the PC version, I got it for free on playstation plus and I've been playing it non stop for the past week and a half. I love the game a lot. I am extremely desperate. I am super invested in this world and I cannot start from scratch. Please help. If you need any more info please let me know.

 

Share this post


Link to post
Share on other sites
Jumpmanjam    0

Sorry for posting this twice, my computer froze and I didn't think the other one submitted, because I never clicked on submit. This one is the one I think you guys should look at. Sorry again for the double post, it was an accident. XD

Share this post


Link to post
Share on other sites
Jumpmanjam    0

I fixed it!!!!!!!!!!!!

 

After trying it like 50 times, I decided to use the split second it gave me to pause the game to go to save and quit. I was nervous to try that because I thought it might freeze while saving. I tried it and now it works!!!! Sorry for posting this before I tried absolutely everything. I kinda panicked after not getting it to work for a few hours. There went my night, I'm so relieved though!!!

Share this post


Link to post
Share on other sites
Jumpmanjam    0

This bug should maybe be looked at though, if it happened to someone not as crafty as I, they might not be able to get out of the situation. I am also a victim to the map bug, and the no more pengulls bug. I love the game despite those few flaws, but this crashing just about gave me a heart attack. XD

Share this post


Link to post
Share on other sites
Greig91    4

I'd back that save data up if I was you, either to a USB flash drive or the PS+ cloud (if it doesn't just give you an error code lol). Just hit the Playstation button and go to Settings, then Application Save Data Management. At least then if anything happens you wont lose as much data.

Share this post


Link to post
Share on other sites
Wade    309

Hmm, after that many days of playing, I'm glad you were able to save your game file.

 

I'm not sure what could be causing this bug, but I'll see if I'm able to reproduce it though. Unfortunately, we have no way of knowing if it is an issue with the game, or caused by the PS4 itself.

Share this post


Link to post
Share on other sites
Jumpmanjam    0

Well, I screwed up, really badly. I was on track to become the first person to get to day 1000 on the ps4 (as far as I know). I was on day 849 and I decided to go back to the ruins. I have gone back a few times since this crashing glitch has happened with very few problems.  It happened one other time and I just did what I had done the first time to fix it. I used the half second the game gave me to pause it and go to save and quit and everything was fine. I even went to the other ruins and it did slow down, but it didn't crash. This time however, it happened again, but with no half second to pause the game at all. The game crashes and gives me an error just after I click on my file. I was going to live stream myself making it to 1000 in a couple of days and now that's probably not going to happen. I backed up my file a long time ago onto a usb, but I really, really don't want to have to go through hundreds of extra days to get to my goal. I just spent all day playing today as well, and of course, just before I went to bed this happened. My file is still there, it says cave 2-849. If I click on it I get a black screen for a few seconds and then it goes to the blue playstation, error screen. I don't even get to see chester on the ground, or the rope, or the ruins or anything at all, even for a split second like I did the other times that it happened. I thought, for sure that it was fine to go down there. I should have just stayed in the overworld...please help. XD

Share this post


Link to post
Share on other sites
Greig91    4

I just tried copying it to my friends ps4 and loading it up and it did the same thing. So it is definitely not the ps4.

 

Nah it is the PS4, it has probably corrupted your save file. I've had that exact same error code on like four other games now. Everything is fine and then bam blue screen. I've had it happen on this a few times now, but it's also happened on Killzone, AC4, DCUO and Warframe.

 

Google the error code there's tons of stuff about it. Sounds pretty serious, but of course Sony haven't said a thing other than the usual "Have you tried turning it off and on again?" crap. Could be a while before this gets sorted out.

Share this post


Link to post
Share on other sites
Jumpmanjam    0

Just found out that my backup save that I thought I saved to a usb, is no where to be found. I made the back up on day 625, just after the first time this happened to me. It would have set me back 224 days, which is like 40 hours of gameplay. Now I am left with no other choice but to hope for a miracle or start from scratch, which I can't bring myself to do. I guess I should have been more careful and made several back ups. I do not think that anyone on the planet, understands how I feel right now after spending the last two weeks playing and having this happen. My only hope is for the next patch to somehow fix the loading of the ruins. I know that the file is not corrupt, because it is doing the same thing that it did on day 625 when I went into the ruins. The game would crash after a half second, unless I paused it, or pressed r2. I could browse the options or look at my inventory for as long as I wanted, until I unpaused it and the game would instantly crashed. The way I fixed it was, I paused it and went to save and quit, the next time I loaded it up, it played fine. This situation is the exact same, except I am not getting any time to pause the game. I know that if I got a split second to pause it I could fix it like I did in the past, then I would get out of the ruins and never go back. (At least not before I make several backups) But the last 50 times I've tried it, it has done the same thing. I was on day 849, that's roughly 113 hours of gameplay, give or take a little, that I crammed into the last 2 weeks. Is there anything, anything at all that I can do to save this file. If there is anything, thank you in advance!

Share this post


Link to post
Share on other sites
Wade    309

Unfortunately, as mentioned, the crash message you are getting is one that is happening for several different games right now. Some people have mentioned in the Sony forums that turning Off auto-update for their PS4 system and disconnecting it from the internet has helped prevent the issue from occurring in other games.

 

Also, If you can copy your save file to a USB stick, and then zip up the file and post it here, I can maybe see if one of the programmers is able to load the save file and see if they can see a problem.

Share this post


Link to post
Share on other sites
Jumpmanjam    0

Unfortunately, as mentioned, the crash message you are getting is one that is happening for several different games right now. Some people have mentioned in the Sony forums that turning Off auto-update for their PS4 system and disconnecting it from the internet has helped prevent the issue from occurring in other games.

 

Also, If you can copy your save file to a USB stick, and then zip up the file and post it here, I can maybe see if one of the programmers is able to load the save file and see if they can see a problem.

Thank you soooo much, however, I copied the file to a usb and zipped it up but every time I try to attach it to the post it gives me an error, it says Upload Skipped (Error 413). It says the file is too large, but the max file size is like 128 mb, and the zip file is less than 25 mb. I tried the basic uploader with no luck as well. I hat to be a pain, but could somebody please explain to me how to attach my file?

Share this post


Link to post
Share on other sites
Wade    309

No, we managed to get the file and are currently looking into it.

 

Thanks!

Share this post


Link to post
Share on other sites
Jumpmanjam    0

I was wondering if you guys had any progress with figuring out what was wrong with the file. Thanks again for taking the time out to help me and for making this great game!  :lemo:

Share this post


Link to post
Share on other sites
Wade    309

Yes, looking at the file, there appears to be a buffer overflow issue as a result of the extreme amount of days played in the world, and the amount of objects being spawned upon load.

 

We're currently looking into how to address the issue and whether it is something we can patch.

Share this post


Link to post
Share on other sites
Jumpmanjam    0

I see, that's really cool that you guys figured out what it is!

 

When it happened the first time, on day 625, it wouldn't crash until like a second after the game loaded. It allowed me to access my inventory or pause it and the game would not crash unless I unpaused. For some reason saving and quitting caused it to load fine the next time. 

 

I got stuck in the crashing loop again on day 7 hundred something, but I was able to do the save and quit trick to fix it. I went into the other ruins for the first time on like day 790 and I could walk around fine for a little while and then it would go frame by frame for a couple of seconds. I've only seen it do that stuff in the ruins. 

 

I don't know if this matters, but I've been down to the ruins a total of about 5 times. I generally had a pretty full inventory, because I over prepared, each time that I went down there. So, I usually didn't pick up anything that wasn't rare. I wouldn't pick up anything that fell from earthquakes, I wouldn't pick up monster meat from depth worms or silk from spiders etc. I don't know if all of the stuff built up enough for it to crash. It crashed on day 625, which was one of the first times that I went down there. I went down there on a later day with no slow down or crash at all.

 

I do remember the animation of willow falling from above going in slow motion, like a couple frames per second, the first time I ever went into the ruins. I also died the first time I ever went down there, and when I came back, I spawned right where I died instead of at the rope. (which was really bad because I spawned in front of the ancient guardian!) That only happened once though. The slow motion thing happened a few times. Sometimes it would be fine, sometimes it would go in slow motion and sometimes, it would crash.

 

I know I posted some of that before, just wanted to refresh your memory. I don't know if any of that will help at all, I just want to contribute as much information as I can. 

 

:wilson_dorky:

Share this post


Link to post
Share on other sites
Jumpmanjam    0

I downloaded the patch and loaded up the save file. I know the patch wasn't directed toward my specific problem but I still had hope that it would cause my file to start working but it didn't. XD

Share this post


Link to post
Share on other sites
Jumpmanjam    0

Just wondering if there was anything being done about this issue, I haven't played don't starve in over a month and I'm pretty much over losing my file. It would be awesome if this were to be fixed though so I could still get to 1000 days. Just grasping at straws here. XD

Share this post


Link to post
Share on other sites

I have the pleasure of habing this same issue upon entering the depths within the cave.. day 380 and I had spent the previous game days gathering wood and rocky turf to expand my outpost closest to my current cave of choice. I had gathered about 15 stacks of wood the same with turf jist dumped on the floor awaiting the disappearance of the snow. I think this may habe pished my item count over the 'limit' as I was already getting slowdown at my expansive main camp during weather effects mostly but also I the height of summer when I was in my grass farm which was around 100 plants.

So please tell me should I hold out for a patch or is it time for me to give up on this? Its frustraring as I had got to grps with the game now and had already sucked it up and startied ahain loads of times the most comical of which was when I fell asleep playing at day 250 and the previosly manahed to leave it unpased for a number of minutes, enough tine for the houds to take me down while I was standing next to my meat effigy... lol

You need to advise people to not expand bases to much and not leve too mich on the floor, I sould have made chests with my 15 stacks of wood but there you go....

Share this post


Link to post
Share on other sites
Wade    309

We will be addressing this issue as part of our next patch, but unfortunately the patch will also need to have the fixes to possibly enable DLC support, so it will still be several weeks off.

Share this post


Link to post
Share on other sites