Cheerio

How To: Install a Mod from the Klei Downloads Page

Recommended Posts

brazilfunk    0

Ok, I'm trying to install mods on mac, I did the "show package contents" thing, looked in the contents folder, and there is no mods folder there. Is there anything I can do?

Share this post


Link to post
Share on other sites
TheDanaAddams    574

Ok, I'm trying to install mods on mac, I did the "show package contents" thing, looked in the contents folder, and there is no mods folder there. Is there anything I can do?

Your Don't Starve installation may be incomplete or partially corrupted... try reinstalling, I suppose - if you view the package contents, and open the contents folder, the mods folder should be right there.

Share this post


Link to post
Share on other sites
jbeetle    1,873

Help me its just stucked like that 

OZuaa32.png

So far I've seen this three times on the forums. Each time it ended up being that the person pirated the game.

Share this post


Link to post
Share on other sites
ubica00    0

Im not a pirate,today i played the screecher,when i returned back to don't strave than it started to hapen.

Share this post


Link to post
Share on other sites
TheDanaAddams    574

I have only seen that error on pirated copies, and there's thankfully no way to fix it.

(Seriously, the game's a whopping 5 bucks on the Humble Store, right now. Just buy the damn thing, people!)

 

However, if it's happening on a legit copy, I would suggest verifying file integrity.

 

post-267484-0-84006300-1388701312_thumb.

post-267484-0-53563300-1388701320_thumb.

Share this post


Link to post
Share on other sites
ubica00    0

I have only seen that error on pirated copies, and there's thankfully no way to fix it.

(Seriously, the game's a whopping 5 bucks on the Humble Store, right now. Just buy the damn thing, people!)

 

However, if it's happening on a legit copy, I would suggest verifying file integrity.

 

attachicon.gifScreen Shot 2014-01-03 at 9.17.28 AM.png

attachicon.gifScreen Shot 2014-01-03 at 9.18.25 AM.png

Thx it worked

Share this post


Link to post
Share on other sites
Charaid    0

I can not find the mods folder.  Mac OSX 10.9 Can someone point me in the right direction? It's not at HD/Applications/Don't Starve/Contents/*  I've searched through all the folders.  It's also not at Documents/Klei/* I've search through those too.


I did redownload and reinstall too. 

Share this post


Link to post
Share on other sites

i have the same problem....

Hello . I just don't understund . I downloaded few mods from Klei page then put them in my MODS folder and launch game > go to mods , enable them . But when i start game everything is same . When i go to main menu and look at mods , it says ,, crashed at the start , automat.. disabled when crashed''. I can't fix it. :(

Share this post


Link to post
Share on other sites
XirmiX    754

Standalone/Windows: C:\Program Files\dontstarve\mods

This one's the one I have and did. Guess what: didn't work!

Share this post


Link to post
Share on other sites
JulMul    0

I have the same problem. Don't Starve was automatically installed in Users/Documents/Klei/Don't Starve. The mod folder is in the UpdaterCache, but I can't use mods. I tried to change the path like written above but it is not working. It is a standalone, non steam version of Don't Starve. Can someone help me please???

Share this post


Link to post
Share on other sites
TheDanaAddams    574

INSTALLING MODS ON MAC

 

I've answered this before... but you guys apparently missed it. So here is everything you will ever need to know to find the mods folder using Mac OSX, with pictures to make sure you don't have to think too hard. Giant, bold heading so nobody can miss it again, even if they're just skimming the pages.

 

STEAM USERS

Locate Don't Starve in your Steam Library, and right-click it. From the right-click menu, choose PROPERTIES.
post-267484-0-95301500-1391160598_thumb.

 

In the window that opens, navigate to the LOCAL FILES tab, and click BROWSE LOCAL FILES.

post-267484-0-88992900-1391160603_thumb.

 

This will take you to the folder that Don't Starve is installed, no matter where it is. Right-click the app, and choose SHOW PACKAGE CONTENTS.

post-267484-0-82577400-1391160605_thumb.

 

You will find the mods folder here. Place the full, uncompressed folder for your desired mod in this folder.

post-267484-0-79905900-1391160607_thumb.

 

STANDALONE USERS
Launch the game as you normally would, to make it appear on the dock. Right-click the game from the dock, and choose OPTIONS > SHOW IN FINDER.

post-267484-0-34919100-1391160612_thumb.

 

This will take you to the folder that Don't Starve is installed, no matter where it is. Right-click the app, and choose SHOW PACKAGE CONTENTS.

post-267484-0-82577400-1391160605_thumb.

 

You will find the mods folder here. Place the full, uncompressed folder for your desired mod in this folder.

post-267484-0-79905900-1391160607_thumb.

 

If the mods folder isn't there, after following these steps correctly, your installation is probably screwy.

Edited by TheDanaAddams
  • Like 3

Share this post


Link to post
Share on other sites
kostasa7    0

I have the same problem. Don't Starve was automatically installed in Users/Documents/Klei/Don't Starve. The mod folder is in the UpdaterCache, but I can't use mods. I tried to change the path like written above but it is not working. It is a standalone, non steam version of Don't Starve. Can someone help me please???

 

I have the same problem too!!! I downloaded 4 mods. The house with light, the armor/amulet/backback, status always on and one more which i dont remember now. However the only mode which is working is the status always on. The other mods get automaticaly disabled and i get the "mod crashed at start its automaticaly disables blah bla bla" message. I have a standalone version of the game (non steam), And yes ofcourse i bought the game (from amazon). Its not a pirate copy...

Can anyone help me? I am using Windows 7. Those "tricks" with the folders etc did not help since the mods are in the right folder... and like i said one of them works.

Share this post


Link to post
Share on other sites
lewis715    0

Could you please try enabling your mods, logging into game, shutting the game down and then uploading your 'log.txt' file for me to look at? 

Could you also try posting your log file for me to take a look?

 

Here's some info on where to find your log:

 

http://forums.kleientertainment.com/topic/24881-logs-and-useful-info-for-bug-reports/

 

I'm having this problem too. This is the text I copied from log: scripts/modindex.lua(206,1) Error loading mod: Haunted House!

 api_version for Haunted House is in the future, please set to the current version. (api_version is version 5, game is version 4.)

Share this post


Link to post
Share on other sites
TheDanaAddams    574

 

I'm having this problem too. This is the text I copied from log: scripts/modindex.lua(206,1) Error loading mod: Haunted House!

 api_version for Haunted House is in the future, please set to the current version. (api_version is version 5, game is version 4.)

 

Your game is out of date.

Update your game.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now