Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

Gadelat

[Sound] Sound stopped working

Recommended Posts

Gadelat    0

Category:[sound]

Platform: Linux

Mods:  No

Version Number: 88307

Issue title: No sound

Steps to reproduce: Start game = no music

Issue:

All sound entries in settings are set to 0 and when I change it and then I go back to settings, they are set to 0 again. Result is no sound in game. I don't know what happened since it worked fine before. I use steam version but I downloaded standalone version to test if it works there and it works fine there, hovewer it's older version. Maybe last update broke it somehow?
 

standalone-log.txt

steam-log.txt

Share this post


Link to post
Share on other sites
aredshroom    238

Huh, your steam log file looks weird. There's a lot of these:

FMOD Error: Can't play event dontstarve/music/music_FE

I don't know if this might help, but could you locate your settings.ini file? It should be the same location where you found your log files. Copy and paste this under the [graphics] section. If it doesn't work, your best bet is to "verify your game cache" in Steam.

[audio]volume_ambient = 5volume_sfx = 5volume_music = 5

Verify game cache instructions:

  1. Go to your Steam Library
  2. Right click on "Don't Starve"
  3. Select "Properties"
  4. Select the "Local Files" tab
  5. Click the "Verify Integrity Of Game Cache..." button.
  6. When the process is complete, launch Don't Starve

Share this post


Link to post
Share on other sites
Gadelat    0

Yeah of course it can't play any sound, game visibly can't load sound system, question is why:

FMOD Error: Error initializing output device. SoundSystem::Initialize failed

Yeah I tried to verify game cache, it didn't help. Also, I tried to uninstall game, steam, delete .local/share/Steam folder, install steam and game again - same behaviour.

 

Sorry but it's a bit silly to post this under graphics section, this is clearly only sound problem. What now bothers me even more is that I successfully updated standalone game to latest version (88307) and there sound works fine, so this problem is only in steam version. I'm worried devs will now blame this on Steam.

Share this post


Link to post
Share on other sites
aredshroom    238

Huh, that is absurd...This might be concurrent with some of the other Linux issues. Wait for the devs then, sorry the info couldn't help. :/

 

It's not silly, it's still a bug to be reported. ^^

Share this post


Link to post
Share on other sites
simplex    2,608

Yeah of course it can't play any sound, game visibly can't load sound system, question is why:

FMOD Error: Error initializing output device. SoundSystem::Initialize failed
Yeah I tried to verify game cache, it didn't help. Also, I tried to uninstall game, steam, delete .local/share/Steam folder, install steam and game again - same behaviour.

 

Sorry but it's a bit silly to post this under graphics section, this is clearly only sound problem. What now bothers me even more is that I successfully updated standalone game to latest version (88307) and there sound works fine, so this problem is only in steam version. I'm worried devs will now blame this on Steam.

Weird. Which distro are you using? And do you know what's your sound backend? (ALSA, PulseAudio or OSS?)

Share this post


Link to post
Share on other sites
Gadelat    0

It's ArchLinux with gnome-shell 3.10 so yeah PulseAudio. But like I said, it worked fine before and in standalone version it still does, I don't know what changed.

Share this post


Link to post
Share on other sites
Wade    309

Do you have PulseAudio running?

 

We had a User several months ago report a similar issue, and he figured out it was because his PulseAudio wasn't enabled.

Share this post


Link to post
Share on other sites
simplex    2,608

It's ArchLinux with gnome-shell 3.10 so yeah PulseAudio. But like I said, it worked fine before and in standalone version it still does, I don't know what changed.

Since I use Arch Linux and PulseAudio myself, I don't know why you're having issues. Try opening Don't Starve and then pavucontrol (grab it from [extra] if you haven't already) to see if, like Wade said, the Don't Starve output is really enabled:

BYp7tz2.png

Share this post


Link to post
Share on other sites
simplex    2,608

It's missing there http://i.imm.io/1juZU.png

Well, so as previously indicated by the "FMOD Error: Error initializing output device." error message Don't Starve really is unable to connect to the pulseaudio server, for some reason. So much for hoping for a simple solution. :razz:

Do you have the pulseaudio-alsa package (also from [extra])?. If you do, or if installing it doesn't solve the problem, could you try running steam using the two following methods to see if it works?

SDL_AUDIODRIVER=pulse steam
SDL_AUDIODRIVER=alsa steam

Share this post


Link to post
Share on other sites
simplex    2,608

Yes I do have pulseaudio-alsa package installed.

Niether of those commands made any difference.

So I think I'm out of ways to help from the outside, sorry. At least the simpler causes have been ruled out, so that the bug report can be tackled more effectively by the devs.

Share this post


Link to post
Share on other sites
simplex    2,608

I have noticed similar issue with some of the Steam games and after some investigation have figured out that Arch Linux steam package does not install `lib32-libpulse` and `lib32-alsa-plugins` as dependencies by default which will cause issues for some games (depending on sound system used) on 64-bit Arch Linux installs. Most likely unrelated to OP issue but leaving comment here in case someone will also find this page via Google ;)

Share this post


Link to post
Share on other sites
malah    0

Hello, i have the same issue with steam on Arch Linux 64bit.

 

I have the 2 dependencies lib32-libpulse and lib32-alsa-plugins installed, that not this :'(

 

I have test to install the HumbleBundle version of dont starve and the sound work on both x32 and x64 versions (after install curl v7.23.1 on dontstarve/bin/lib32/ or dontstarve/bin/lib64/ because of the libs of Arch Linux are not compatible), dont know why that dont work on steam.

 

If you need, you can try this http://forums.kleientertainment.com/topic/29249-curl-error-in-last-humble-bundle-version-update/?p=357857

 

or this, with the source :

mkdir tmpcd tmpwget http://curl.haxx.se/download/curl-7.23.1.tar.gztar -xzvf curl-7.23.1.tar.gzcd curl-7.23.1./configuremakecp -r lib/.libs/libcurl.so* ~/dontstarve/bin/lib*/cd ../..rm -r tmp

Share this post


Link to post
Share on other sites
malah    0
Hello, i have found a real solution for my error, i just have to change the lib of libpulse which are on the steam folder (libpulse.so.0) :

 



ln -is /usr/lib/libpulse.so.0 ~/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/


And now the sound work for me :) that the curl lib which oriented me to that solution, steam have his own curl lib.

Share this post


Link to post
Share on other sites
Gadelat    0

Ok I tried it today again after long time so I don't know if update fixed it or something else, but anyway i entered your command, then run game and after setting music to more than 0 value, it was clear it works again. Thanks.

Share this post


Link to post
Share on other sites
malah    0

Hello, have found a better solution for this error.

 

Right click on Don't Starve on your game list, click on Properties, click on SET LAUNCH OPTIONS, then add this: 

LD_LIBRARY_PATH="/usr/lib:$LD_LIBRARY_PATH" %command%

That work to many other steam games as Hammerwatch, KSP ...

Share this post


Link to post
Share on other sites
Wade    309

Thanks for the tip.

 

I'll be sure to pass it along to others experiencing this issue in the future.

Share this post


Link to post
Share on other sites
vbd    0

Hi, I just ran into a similar error on archlinux x64 but with a "don't starve" via humble bundle (no steam): I also had all these FMOD Error: Can't play event dontstarve/...

 

I use alsa without pulseaudio on my laptop and here is (a relevant part of) the logs I got:

 

 

ALSA lib dlmisc.c:252:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/alsa-lib/libasound_module_rate_samplerate_medium.so
ALSA lib pcm_rate.c:1403:(snd_pcm_rate_open) Cannot find rate converter
FMOD Error: Error initializing output device.
SoundSystem::Initialize failed

 

If you run into something similar, just install alsa-plugins where is the needed lib and it will works.

Share this post


Link to post
Share on other sites
Wade    309

Erm, i'm having the exact problem, but it's not on a Linux, but windows 10?

 

Can I get you to post your log.txt file from your "documents\klei\donotstarve\" folder?

Share this post


Link to post
Share on other sites