Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

Malacath

[Tutorial] Adding Custom Sound To Your Custom Character

Recommended Posts

StormyRange    9

Uh... Sorry to ask for something again, but I've been trying to change music tracks for one of my characters using the same method (that now works still for both my characters thanks) but I can't seem to get a solid location tree and specific names of the songs so I may do a replacement... Maybe it works differently, I did read the tutorial in your first post (read it before this one in fact) but it only deals with in-game SFX getting switched around which doesn't touch upon anything I need. Again sorry to bother again, don't worry if you can't help, I'd like to be able to do it if it's possible, it isn't required.

EDIT:

I found and tried:

RemapSoundEvent( "dontstarve/music/music/work", "batter/music/work" )
 

(Batter is the character name for this one) but it doesn't change the WorkToBeDone track =o

Share this post


Link to post
Share on other sites
Kevin    500

Hey guys,

 

Music is handled like any other sound, but there is a special component that manages starting and stopping it in response to game events. Take a look in dynamicmusic.lua to see the details. In the case of the work music, it may be playing "dontstarve/music/music_work_cave" or "dontstarve/music/music_work" depending upon where you are.

Share this post


Link to post
Share on other sites
StormyRange    9

Oh wow I had it as music/music/work and I changed it to what you said and it worked! Awesome thanks! I'll certainly check that dynamicmusic.lua and have a look around, thanks a lot =3

Share this post


Link to post
Share on other sites
Malacath    121

If you are a bit patient then I will update a new version of the tutorial which should be super eas to follow. But in general it is not helpful to just post "something doesn't work". It is usually appreciated to post some kind of error message which you usually find in the log.txt
That said I'm quite sure you were simply not consisten with your nomenclature.

 

Edit: @Bruhmis first post is updated, good luck!

Share this post


Link to post
Share on other sites
Bruhmis    11

If you are a bit patient then I will update a new version of the tutorial which should be super eas to follow. But in general it is not helpful to just post "something doesn't work". It is usually appreciated to post some kind of error message which you usually find in the log.txt

That said I'm quite sure you were simply not consisten with your nomenclature.

 

Edit: @Bruhmis first post is updated, good luck!

 

well I looked at it but I didn't have trouble following any of that the first time. however, I downloaded the fixed version of ''weavile'' you made to see if I was missing anything and there's a bunch of files inside it with origins completely unknown to me.

Orphaned unnamed resource. This resource must have used Add( resource ) to insert itself into the manager. 

this appears multiple times in my log.

Share this post


Link to post
Share on other sites
Malacath    121

well I looked at it but I didn't have trouble following any of that the first time. however, I downloaded the fixed version of ''weavile'' you made to see if I was missing anything and there's a bunch of files inside it with origins completely unknown to me.

Orphaned unnamed resource. This resource must have used Add( resource ) to insert itself into the manager. 

this appears multiple times in my log.

Please try recreating your work with the help of the new tutorial first, it's super fast. Troubleshooting what you currently have is super annoying and we would both be better off if you do it the easy way. And if there were files that didn't resemble anything you had then you have probably forgotten something in the process.

Share this post


Link to post
Share on other sites
Bruhmis    11

Please try recreating your work with the help of the new tutorial first, it's super fast. Troubleshooting what you currently have is super annoying and we would both be better off if you do it the easy way. And if there were files that didn't resemble anything you had then you have probably forgotten something in the process.

I haven't forgotten anything, I did everything that was written in your tutorial and klei's basic sound tutorial. recreating it wouldn't really do anything, everything was already done correctly. the original tutorial wasn't even confusing. I guess I'll just wait until there's more resources on these forums.

Share this post


Link to post
Share on other sites
Malacath    121

I haven't forgotten anything, I did everything that was written in your tutorial and klei's basic sound tutorial. recreating it wouldn't really do anything, everything was already done correctly. the original tutorial wasn't even confusing. I guess I'll just wait until there's more resources on these forums.

I'm curious what the problem should be in that case since other people could make it work with my tutorial... If you feel like it you can upload your mod including the fdp-file and I'll take a look tomorrow, I can almost garantuee you something's wrong since logically it would work if everything would be right...

Share this post


Link to post
Share on other sites
Bruhmis    11

I'm curious what the problem should be in that case since other people could make it work with my tutorial... If you feel like it you can upload your mod including the fdp-file and I'll take a look tomorrow, I can almost garantuee you something's wrong since logically it would work if everything would be right...

 

edit: noticed a couple of mistakes I made but correcting them didn't get the sound to work. updated version:

https://mega.co.nz/#!UtdWBaRD!NthHbkMQj3e7jSoWR7JSfjKsqRozXPSd3fJXv26hDN0

Share this post


Link to post
Share on other sites
Malacath    121

 

edit: noticed a couple of mistakes I made but correcting them didn't get the sound to work. updated version:

https://mega.co.nz/#!UtdWBaRD!NthHbkMQj3e7jSoWR7JSfjKsqRozXPSd3fJXv26hDN0

 

I told you take another look at the first post, if you did it then you didn't take a sharp enough look.

RemapSoundEvent( "dontstarve/characters/basil/Hurt", "basil_bank00/basil/hurt" ),RemapSoundEvent( "dontstarve/characters/basil/Talk_LP", "basil_bank00/basil/talk_LP" ),

Those two lines are in the wrong place (not wrong file) and the folder structures are wrong, lua is a case sensitive language. Try fixing that yourself and if it doesn't work:

Assets = {    	Asset( "IMAGE", "images/saveslot_portraits/bas.tex" ),    	Asset( "IMAGE", "images/selectscreen_portraits/bas.tex" ),    	Asset( "IMAGE", "images/selectscreen_portraits/bas_silho.tex" ),    	Asset( "IMAGE", "bigportraits/bas.tex" ),	Asset( "ATLAS", "images/saveslot_portraits/bas.xml" ),    	Asset( "ATLAS", "images/selectscreen_portraits/bas.xml" ),    	Asset( "ATLAS", "images/selectscreen_portraits/bas_silho.xml" ),   	 Asset( "ATLAS", "bigportraits/bas.xml" ),	Asset( "SOUNDPACKAGE", "sound/basil.fev" ),	Asset( "SOUND", "sound/basil_bank00.fsb"),}RemapSoundEvent( "dontstarve/characters/basil/hurt", "basil/characters/basil/hurt" )RemapSoundEvent( "dontstarve/characters/basil/talk_LP", "basil/characters/basil/talk_LP" )

 

A plea to everyone who says it doesn't work: Check if you really did what the tutorial says, I can't check everyones mod just because she/he likes to to do things different and thus wrong.

 

That said the last two people who had problems should have showed everyone what kind of mistakes you coudl make, so keep an eyey ot to those.

Share this post


Link to post
Share on other sites
Bruhmis    11
Asset( "SOUNDPACKAGE", "sound/basil.fev" ),Asset( "SOUND", "sound/basil_bank00.fsb"),}RemapSoundEvent( "dontstarve/characters/basil/Hurt", "basil_bank00/characters/basil/hurt" )RemapSoundEvent( "dontstarve/characters/basil/Talk_LP", "basil_bank00/characters/basil/talk_LP" )

I tried it both this way and the way you did it with ''basil'' instead of the bank file name and the sounds were still silent.

Share this post


Link to post
Share on other sites
Malacath    121

[...] lua is a case sensitive language [...]

You need to train that sharp look of yours and correct your code according to my suggestion I put in the spoilers.

Share this post


Link to post
Share on other sites
Bruhmis    11

You need to train that sharp look of yours and correct your code according to my suggestion I put in the spoilers.

RemapSoundEvent( "dontstarve/characters/basil/hurt", "basil_bank00/characters/basil/hurt" )RemapSoundEvent( "dontstarve/characters/basil/talk_LP", "basil_bank00/characters/basil/talk_LP" )

this is what I have now and everything is still silent.

Share this post


Link to post
Share on other sites
Malacath    121
[...] still silent.

That's what I meant with beeing annoying. Last thing I will say to this since I had a stressful week and not a lot patience left, sorry: Read the spoiler in my post further up!

Share this post


Link to post
Share on other sites
Bruhmis    11

That's what I meant with beeing annoying. Last thing I will say to this since I had a stressful week and not a lot patience left, sorry: Read the spoiler in my post further up!

I made everything identical to the code in your spoiler and also tried it with the full bank name, I really don't see how that's ''being annoying'' but thanks for trying to help anyway.

Share this post


Link to post
Share on other sites
Sukoushi    192

I'm going to guess what he's trying to spell out for you, besides the case-sensitivity, is that "basil_bank00" should changed to be "basil/characters".

 

I told you take another look at the first post, if you did it then you didn't take a sharp enough look.

RemapSoundEvent( "dontstarve/characters/basil/Hurt", "basil_bank00/basil/hurt" ),RemapSoundEvent( "dontstarve/characters/basil/Talk_LP", "basil_bank00/basil/talk_LP" ),

Those two lines are in the wrong place (not wrong file) and the folder structures are wrong, lua is a case sensitive language. Try fixing that yourself and if it doesn't work:

[...]RemapSoundEvent( "dontstarve/characters/basil/hurt", "basil/characters/basil/hurt" )RemapSoundEvent( "dontstarve/characters/basil/talk_LP", "basil/characters/basil/talk_LP" )

Share this post


Link to post
Share on other sites
Malacath    121

I made everything identical to the code in your spoiler and also tried it with the full bank name, I really don't see how that's ''being annoying'' but thanks for trying to help anyway.

I didn't mean you were annoying, I meant the fixing of your stuff. Sukoushi said what needs to be said, I did that and only that with your uploaded mod and it worked. Thanks Sukoushi

Share this post


Link to post
Share on other sites
Bruhmis    11

well I tried it both ways the first time but I guess the other things I changed were making it silent as well. thanks.

Share this post


Link to post
Share on other sites
MikeyTheFox    2

I found the fix to your guys problems. See, its the FMOD-Designer project template.

 

The template's path which is shown in the screenshots in the first page is "sound_mod_tutorial"  If you don't resave your file when building it. It will stay as "sound_mod_tutorial" So the path for the coding would be

RemapSoundEvent( "dontstarve/characters/CHARACTER/hurt", "sound_mod_tutorial/characters/CHARACTER/hurt" )

and not

RemapSoundEvent( "dontstarve/characters/CHARACTER/hurt", "CHARACTER/characters/CHARACTER/hurt" )

It's a silly mistake that I think everyone here was overlooking. once you resave the fdp as save as "<Character Name>"

(Without the < >)

 

Then everything should be fine like so: I open up the fdp, add the sounds and rename "winnifred" to "wod" for example. And then click Save As and save it as wod.fdp

 

When I open it again the file path on top should be "wod/characters/wod/hurt" and not "sound_mod_tutorial/characters/wod/hurt"

Share this post


Link to post
Share on other sites
Malacath    121
[...all that stuff you wrote...]

You show that you understood what you were doing and I like that ^^

Also thanks for the suggestion but in the case of Bruhmis mod it wasn't the problem, I have the mod on my harddrive and already inspected it and what I wrote earlier were the problems that were present.

I have to agree though that this screenshot is misleading, sorry for that. I'll at least fix that in the text. Thanks again ^^

Share this post


Link to post
Share on other sites
Lawrence    15

It happens a strange thing: I added some custom sounds to my two mods (baldric and goio), and they are working.

But when published and downloaded the mods they won't appear in the mod list (currently I restored the old sounds and that fixed the thing).

 

I followed the tutorial but maybe I missed some lines (probably). I'll paste the log.

 

WriteModFile [../mods/workshop-175951956/sound/baldric.fev] 2926 bytes
WriteModFile [../mods/workshop-175951956/sound/baldric.fsb] 263808 bytes
WriteModFile [../mods/workshop-175951956/sound/basic3dsound.fdt] 5133 bytes
EnsurePathExists [../mods/workshop-175951956] [sound/.fsbcache/] has invalid component [.fsbcache]
Could not create folders for file [../mods/workshop-175951956] [sound/.fsbcache/baldric_dead_44B953FE28783761.fobj]

Share this post


Link to post
Share on other sites
Malacath    121

It happens a strange thing: I added some custom sounds to my two mods (baldric and goio), and they are working.

But when published and downloaded the mods they won't appear in the mod list (currently I restored the old sounds and that fixed the thing).

 

I followed the tutorial but maybe I missed some lines (probably). I'll paste the log.

 

WriteModFile [../mods/workshop-175951956/sound/baldric.fev] 2926 bytes

WriteModFile [../mods/workshop-175951956/sound/baldric.fsb] 263808 bytes

WriteModFile [../mods/workshop-175951956/sound/basic3dsound.fdt] 5133 bytes

EnsurePathExists [../mods/workshop-175951956] [sound/.fsbcache/] has invalid component [.fsbcache]

Could not create folders for file [../mods/workshop-175951956] [sound/.fsbcache/baldric_dead_44B953FE28783761.fobj]

I have never uploaded a mod to Steam so I'm not sure, but it seems there's some problem with a few files he doesn't like. Whe uploading the mod I would suggest you create a duplicate of your mod where you delete all development stuff that isn't needed for the player. In the case of sounds that means delete everything that's not *.fsb or *.fev

Hope that works

Share this post


Link to post
Share on other sites
Cheerio    2,528

I have never uploaded a mod to Steam so I'm not sure, but it seems there's some problem with a few files he doesn't like. Whe uploading the mod I would suggest you create a duplicate of your mod where you delete all development stuff that isn't needed for the player. In the case of sounds that means delete everything that's not *.fsb or *.fev

Hope that works

Yeah it looks like fmod creates a temporary folder called .fsbcache which the uploader doesn't like.  You'll have to manually delete it for now till I find a better way of handling it.  Sorry for the trouble.

Share this post


Link to post
Share on other sites
Lawrence    15

Yeah it looks like fmod creates a temporary folder called .fsbcache which the uploader doesn't like.  You'll have to manually delete it for now till I find a better way of handling it.  Sorry for the trouble.

 

 

I have never uploaded a mod to Steam so I'm not sure, but it seems there's some problem with a few files he doesn't like. Whe uploading the mod I would suggest you create a duplicate of your mod where you delete all development stuff that isn't needed for the player. In the case of sounds that means delete everything that's not *.fsb or *.fev

Hope that works

 

 

 

I fixed it, now custom speech sounds of Baldric and Goio works perfectly ^^ you was right I put by mistake (you can say a big super stupid lord of mistakes) too much files in the folder... ^^"

 

Share this post


Link to post
Share on other sites