Sign in to follow this  

[Graphics] Unplayable since I can't see

Recommended Posts

Risne    10

Bug Submission

Please choose a category



  • Steam

Version Number


Issue title

Unplayable since I can't see

Steps to reproduce

First time ever starting the game so no idéa.

Describe your issue

Take a look at this screenshot --->

It's is happening all the time so the game is more or less unplayable. I'm running this on my windows 7 64 bit with intel i5 3570k

using PowerColor HD7950 3GB. Drivers are up to date so no idéa what's causing the problem.

Share this post

Link to post
Share on other sites
TheThorny    25

Have you tried changing the resolution settings? I had that glitch right after the latest update, but changing settings and then changing them back fixed it for me.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this