Sign in to follow this  
Raged_kishin

[Crash] Doesn't start after update

Recommended Posts

Raged_kishin    10

Bug Submission

Please choose a category

[Crash]

Platform

  • Steam

Version Number

-

Issue title

Doesn't start after update

Steps to reproduce

Only thing i did was update the game

Describe your issue

I was able to play it before it updated yesterday, but right after i updated to the latest version today it seem to not want to start at all

when i start the game it says preparing to launch the game and then nothing pops up afterwards

Share this post


Link to post
Share on other sites
JoeW    26,477

Hi there,

We are checking into this issue. Can you please provide your system specs?

Share this post


Link to post
Share on other sites
Raged_kishin    10

------------------

System Information

------------------

Time of this report: 11/27/2012, 16:58:23

Machine name: JAY

Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 3 (2600.xpsp_sp3_gdr.120821-1629)

Language: English (Regional Setting: English)

System Manufacturer: Dell Inc.

System Model: Vostro 200

BIOS: Phoenix - AwardBIOS v6.00PG

Processor: Intel® Core2 Duo CPU E4500 @ 2.20GHz (2 CPUs)

Memory: 3326MB RAM

Page File: 1121MB used, 5097MB available

Windows Dir: C:\WINDOWS

DirectX Version: DirectX 9.0c (4.09.0000.0904)

DX Setup Parameters: Not found

DxDiag Version: 5.03.2600.5512 32bit Unicode

------------

DxDiag Notes

------------

DirectX Files Tab: No problems found.

Display Tab 1: No problems found.

Sound Tab 1: No problems found.

Sound Tab 2: No problems found.

Music Tab: No problems found.

Input Tab: No problems found.

Network Tab: No problems found.

--------------------

DirectX Debug Levels

--------------------

Direct3D: 0/4 (n/a)

DirectDraw: 0/4 (retail)

DirectInput: 0/5 (n/a)

DirectMusic: 0/5 (n/a)

DirectPlay: 0/9 (retail)

DirectSound: 0/5 (retail)

DirectShow: 0/6 (retail)

---------------

Display Devices

---------------

Card name: AMD Radeon HD 6450

Manufacturer: Advanced Micro Devices, Inc.

Chip type: AMD Radeon Graphics Processor (0x6779)

DAC type: Internal DAC(400MHz)

Device Key: Enum\PCI\VEN_1002&DEV_6779&SUBSYS_E164174B&REV_00

Display Memory: 1024.0 MB

Current Mode: 1440 x 900 (32 bit) (75Hz)

Monitor: ViewSonic VX1935wm

Monitor Max Res: 1440,900

Driver Name: ati2dvag.dll

Driver Version: 6.14.0010.7261 (English)

DDI Version: 9 (or higher)

Driver Attributes: Final Retail

Driver Date/Size: 4/5/2012 22:20:02, 305664 bytes

WHQL Logo'd: Yes

WHQL Date Stamp: n/a

VDD: n/a

Mini VDD: ati2mtag.sys

Mini VDD Date: 4/6/2012 00:16:18, 7746048 bytes

Device Identifier: {D7B71EE2-2439-11CF-A668-6EC1A1C2CB35}

Vendor ID: 0x1002

Device ID: 0x6779

SubSys ID: 0xE164174B

Revision ID: 0x0000

Revision ID: 0x0000

Video Accel: ModeMPEG2_C ModeMPEG2_D

Deinterlace Caps: {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch

{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(UYVY,UYVY) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch

{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch

Registry: OK

DDraw Status: Enabled

D3D Status: Enabled

AGP Status: Enabled

DDraw Test Result: Not run

D3D7 Test Result: Not run

D3D8 Test Result: Not run

D3D9 Test Result: Not run

-------------

Sound Devices

-------------

Description: USB PnP Sound Device

Default Sound Playback: Yes

Default Voice Playback: Yes

Hardware ID: USB\Vid_0d8c&Pid_0139&Rev_0100&MI_00

Manufacturer ID: 65535

Product ID: 65535

Type: WDM

Driver Name: usbaudio.sys

Driver Version: 5.01.2600.5512 (English)

Driver Attributes: Final Retail

WHQL Logo'd: Yes

Date and Size: 4/13/2008 12:45:12, 60032 bytes

Other Files:

Driver Provider: Microsoft

HW Accel Level: Full

Cap Flags: 0xF5F

Min/Max Sample Rate: 100, 200000

Static/Strm HW Mix Bufs: 0, 0

Static/Strm HW 3D Bufs: 0, 0

HW Memory: 0

Voice Management: No

EAX 2.0 Listen/Src: No, No

I3DL2 Listen/Src: No, No

Sensaura ZoomFX: No

Registry: OK

Sound Test Result: Not run

Description: Realtek HD Audio output

Default Sound Playback: No

Default Voice Playback: No

Hardware ID: HDAUDIO\FUNC_01&VEN_10EC&DEV_0888&SUBSYS_10280238&REV_1000

Manufacturer ID: 1

Product ID: 100

Type: WDM

Driver Name: RtkHDAud.sys

Driver Version: 5.10.0000.6278 (English)

Driver Attributes: Final Retail

WHQL Logo'd: Yes

Date and Size: 12/31/1999 19:00:00, 6290024 bytes

Other Files:

Driver Provider: Realtek Semiconductor Corp.

HW Accel Level: Basic

Cap Flags: 0xF5F

Min/Max Sample Rate: 8000, 192000

Static/Strm HW Mix Bufs: 0, 0

Static/Strm HW 3D Bufs: 0, 0

HW Memory: 0

Voice Management: No

EAX 2.0 Listen/Src: No, No

I3DL2 Listen/Src: No, No

Sensaura ZoomFX: No

Registry: OK

Sound Test Result: Not run

---------------------

Sound Capture Devices

---------------------

Description: USB PnP Sound Device

Default Sound Capture: Yes

Default Voice Capture: Yes

Driver Name: usbaudio.sys

Driver Version: 5.01.2600.5512 (English)

Driver Attributes: Final Retail

Date and Size: 4/13/2008 12:45:12, 60032 bytes

Cap Flags: 0x41

Format Flags: 0x440

Description: Realtek HD Audio Input

Default Sound Capture: No

Default Voice Capture: No

Driver Name: RtkHDAud.sys

Driver Version: 5.10.0000.6278 (English)

Driver Attributes: Final Retail

Date and Size: 12/31/1999 19:00:00, 6290024 bytes

Cap Flags: 0x41

Format Flags: 0xFFF

Edited by Raged_kishin

Share this post


Link to post
Share on other sites
ik3noob    10

Bug Submission

Please choose a category

[Crash]

Platform

  • Steam

Version Number

-

Issue title

Game not starting after todays update

Steps to reproduce

Immediately getting "dontstarve_steam.exe has stopped working" when starting the game.

Describe your issue

Uninstalling and downloading again hasn't helped, neither has disabling the steam cloud sync and deleting the game files. Game has always worked prior to update. My system is Win7 Home Premium, 64Bit, Core i5, Radeom 7750.

Content of log file (file time mateches time of the crash) C:\Program Files (x86)\Steam\steamapps\common\dont_starve\bin\log.txt:

Starting up

THREAD - started 'GAClient' (4912)

HttpClient::ClientThread::Main()

cGame::InitializeOnMainThread

cDontStarveGame::DoGameSpecificInitialize()

cGame::StartPlaying

LOADING LUA

DoLuaFile data/scripts/main.lua

DoLuaFile loading buffer data/scripts/main.lua

c:\jenkins\workspace\jobs\DontStarve_Release_Make_Steam_Package\workspace\data\scripts\main.lua(101,1) running main.lua


LOADING LUA SUCCESS

c:\jenkins\workspace\jobs\DontStarve_Release_Make_Steam_Package\workspace\data\scripts\mixer.lua(76,1) Set set_sfx 1

c:\jenkins\workspace\jobs\DontStarve_Release_Make_Steam_Package\workspace\data\scripts\mixer.lua(76,1) Set set_ambience 1

c:\jenkins\workspace\jobs\DontStarve_Release_Make_Steam_Package\workspace\data\scripts\mixer.lua(76,1) Set set_music 1

Reset() returning

Error creating shader

Error creating shader

Shader(c:\users\jkwan~1.kle\appdata\local\temp\tmpypeevl\font.vs.tmp), Param(MatrixP) Idx(0)

Assert failure 'array_data.mGLIndex != 0xFFFFFFFF' at ..\source\renderlib\OpenGL\HWEffect.cpp(358): Trace follows...

Edited by ik3noob

Share this post


Link to post
Share on other sites
Raged_kishin    10

from C:\Program Files\Steam\steamapps\common\dont_starve\bin

if i start up dontstarve_steam.exe

it says "This application has failed to start because dwmapi.dll was not found Re-installing the application may fix this problem.

but reinstalling doesn't solve it

Share this post


Link to post
Share on other sites
Imm3diacy    10

I, too have this problem.

This is the log.txt:

Starting up

THREAD - started 'GAClient' (9512)

HttpClient::ClientThread::Main()

cGame::InitializeOnMainThread

cDontStarveGame::DoGameSpecificInitialize()

cGame::StartPlaying

LOADING LUA

DoLuaFile data/scripts/main.lua

DoLuaFile loading buffer data/scripts/main.lua

c:\jenkins\workspace\jobs\DontStarve_Release_Make_Steam_Package\workspace\data\scripts\main.lua(101,1) running main.lua

LOADING LUA SUCCESS

c:\jenkins\workspace\jobs\DontStarve_Release_Make_Steam_Package\workspace\data\scripts\mixer.lua(76,1) Set set_sfx 0.1

c:\jenkins\workspace\jobs\DontStarve_Release_Make_Steam_Package\workspace\data\scripts\mixer.lua(76,1) Set set_ambience 0.1

c:\jenkins\workspace\jobs\DontStarve_Release_Make_Steam_Package\workspace\data\scripts\mixer.lua(76,1) Set set_music 0.1

Reset() returning

Error creating shader

Error creating shader

Shader(c:\users\jkwan~1.kle\appdata\local\temp\tmpypeevl\font.vs.tmp), Param(MatrixP) Idx(0)

Assert failure 'array_data.mGLIndex != 0xFFFFFFFF' at ..\source\renderlib\OpenGL\HWEffect.cpp(358): Trace follows...

Edit: Also, I may note that re-installing and restarting my computer several times had no effect.

Edited by Imm3diacy

Share this post


Link to post
Share on other sites
BenDunno    10

My game is also refusing to open since the update, and the hotfix hasn't changed anything. Doesn't even reach the menu before it crashes, no sound or anything. Log.txt shows no errors; in fact it doesn't seem to have been modified since I played this morning pre-update. Not sure what to do at this point.

Share this post


Link to post
Share on other sites
Marak    27

Yep. Game doesn't even attempt to load. "Preparing to launch Don't Starve" pops for roughly half a second, and then nothing. It just acts like I never clicked "Play" at all.

Attempting to run the game manually from the install folder (W:\Program Files\Steam\steamapps\common\dont_starve\bin, dontstarve_steam icon) gives me the following message:

"This application has failed to start because dwmapi.dll was not found. Re-installing the application may fix this problem."

Of course, re-installing does absolutely nothing. Neither does validating the game files from within Steam.

Steam version running on Windows XP service pack 3, 32-bit.

Share this post


Link to post
Share on other sites
pioter    10

Hi, I would just like to ask is this issue being worked on? Is there an ETA?

The issue I am refering to is the one posted directly above by Marak

Share this post


Link to post
Share on other sites
ItchyFlea    10

I believe I've found out why this is happening. I've got the same problem, so I tried starting the game manually. It gives the error that it can't start because dwmapi.dll is missing. As far as I can tell, that file belongs to Windows Vista or better. I have Windows XP.

I'm guessing the update has changed the system requirements so that now Windows Vista or greater is required to play the game.

Share this post


Link to post
Share on other sites
pioter    10
I believe I've found out why this is happening. I've got the same problem, so I tried starting the game manually. It gives the error that it can't start because dwmapi.dll is missing. As far as I can tell, that file belongs to Windows Vista or better. I have Windows XP.

I'm guessing the update has changed the system requirements so that now Windows Vista or greater is required to play the game.

Do you think that you can add only that file? Does it have other dependancies?

Share this post


Link to post
Share on other sites
ItchyFlea    10
Do you think that you can add only that file? Does it have other dependancies?

Being a file specific to Windows Vista or newer, it would probably be a very bad idea to manually install it on Windows XP. I've got multiple computers, so I will give it a go to test it anyway.

I'll edit this post with the outcome.

Long story short, it can't be done. Even with that file installed, other critical Windows files need to be replaced.

Edited by ItchyFlea

Share this post


Link to post
Share on other sites
Sarioya    10

Adding the .dll doesn't seem to work. It just gives an error (on my machine at least) that reads, "The Procedure entry point IsThreadDesktopComposited could not be located in the dynamic link library USER32.dll."

Share this post


Link to post
Share on other sites
pioter    10
Adding the .dll doesn't seem to work. It just gives an error (on my machine at least) that reads, "The Procedure entry point IsThreadDesktopComposited could not be located in the dynamic link library USER32.dll."

Haha, well the solution is to add that dll, and then the next and next.

I guess we just need to wait until tomorrow for the fix.

Share this post


Link to post
Share on other sites
Obscurum    10

Same problem on my Windows 7 install, log as follows.

Starting up

Don't Starve: 69735

Build Date: 2012-11-27_14-48-03

THREAD - started 'GAClient' (6060)

HttpClient::ClientThread::Main()

cGame::InitializeOnMainThread

cDontStarveGame::DoGameSpecificInitialize()

cGame::StartPlaying

LOADING LUA

DoLuaFile data/scripts/main.lua

DoLuaFile loading buffer data/scripts/main.lua

c:\jenkins\workspace\jobs\DontStarve_Release_Make_Steam_Package\workspace\data\scripts\main.lua(101,1) running main.lua

LOADING LUA SUCCESS

c:\jenkins\workspace\jobs\DontStarve_Release_Make_Steam_Package\workspace\data\scripts\mixer.lua(76,1) Set set_sfx 0.1

c:\jenkins\workspace\jobs\DontStarve_Release_Make_Steam_Package\workspace\data\scripts\mixer.lua(76,1) Set set_ambience 0.1

c:\jenkins\workspace\jobs\DontStarve_Release_Make_Steam_Package\workspace\data\scripts\mixer.lua(76,1) Set set_music 0.1

Reset() returning

Error creating shader

Error creating shader

Shader(c:\users\jkwan~1.kle\appdata\local\temp\tmpypeevl\font.vs.tmp), Param(MatrixP) Idx(0)

Assert failure 'array_data.mGLIndex != 0xFFFFFFFF' at ..\source\renderlib\OpenGL\HWEffect.cpp(358): Trace follows...

Share this post


Link to post
Share on other sites
Sarioya    10
Haha, well the solution is to add that dll, and then the next and next.

That'd be nice, but I doubt it'd work. XP already has a USER32.dll file, and who knows what Microsoft added and removed from it when they went to Vista and 7. :-P

Edited by Sarioya
Mandrake is tasty.

Share this post


Link to post
Share on other sites
doctrine303    10

Same issue - worked until the update today, after which it plays one or two notes of the opening music and then I get the dialog box with the message: "dontstarve_steam.exe has stopped working" I tried updating my graphics card drives, but still get the same error.

System configuration:

OS:

Windows 7 Professional 64bit

Motherboard:

ASUS P7H55-M Pro

CPU:

Intel Core i5-650

Memory:

Kingston Hyper X DDR3 1600 CL9 240pin DIMM 2x2GB

Video Card:

EVGA GeForce GTX 465

1GB DDR5

PCI Express 2.0

HDD1: Western Digital Caviar Black 1TB 7200rpm SATA

HDD2: Seagate Barracuda 500GB 7200rpm SATA

Share this post


Link to post
Share on other sites
GenHavok    10

I have the exact same problem of the game not launching. Here is a log of from the game http://pastebin.com/QQEvt8sT. My friends who are using Win 7 machines have had no problems launching.I must also note that when I launched the game it went through the process of trying to install some Microsoft item then failed to do so.I tried launching again and it did the same thing. So I tried starting steam and this time it did not even bother to try to download the Microsoft item but still would not launch.Verified Integrity of files and such and still same problem.

My System Config:

OS:

Win XP SP3 32bit

Motherboard:

Intel P945PVM

Memory:

3gb DDR2

Video Card:

ATI 4550 HD

512mb DDR5

PCI Express 2.0

HDD: Western Digital Caviar Blue 80gb/7200rpm IDE

Note:The solution posted did not work for me.

Edited by GenHavok

Share this post


Link to post
Share on other sites
Kevin    1,056

Pioter - if that didn't work for you then you have a more obscure issue than we've seen so far. Please send your log.txt, a dxdiag, and any mdmp files from your /bin directory to dontstarve.debug@kleientertainment.com

GenHavok - that log is from a previous run of the game, as it actually shows you playing through a couple of days. The MS stuff that failed to install was the directx redist, which is required for the grame to run. Try following the directions that I liked to in my last post, and tell us what happens.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this