Sign in to follow this  
Raged_kishin

[Crash] Doesn't start after update

Recommended Posts

BenDunno    10

Since the new revision, my game now launches, but the screen is 100% black. There's sound & music, and I can click the buttons from memory, but I can't see anything. I'm running XP, log shows no errors.

EDIT: After changing my settings file manually, the game worked properly when set to windowed mode. Changing the settings back to fullscreen turned everything back to black, so I'm guessing that's where the issue is.

Edited by BenDunno

Share this post


Link to post
Share on other sites
JLK    50

BenDunno: Can you run dxdiag and post the results here? Another thing to try would also be to go into the options screen and turn off bloom and see if that helps you as it requires creating several additional rendertargets that eat up video memory.

Share this post


Link to post
Share on other sites
JLK    50

Bavienco: I think there is a problem where sometimes the DirectX Redistributable doesn't run. If you can try running that (instructions here), there's a good chance that'll fix your issue.

Share this post


Link to post
Share on other sites
JLK    50

BenDunno: Just to clarify, are you turning off the bloom and staying in windowed mode when the crash occurs or turning off bloom, then going to fullscreen before crashing?

My best guess given the information is that you're actually running out of video memory. The game needs to do more error checking in this case, but if you want to run full screen you might have better luck if you pick a lower screen resolution. I'll see what I can do about it not crashing at least :)

Share this post


Link to post
Share on other sites
BenDunno    10

I've tried turning off bloom in both windowed mode and turning it off and turning on fullscreen. Windowed results in the tornup screen, fullscreen just goes back to black.

Thank you for the responses. I'll do my best with windowed for now. Hope you can get this stuff cleaned up for everyone!

Share this post


Link to post
Share on other sites
GenHavok    10
The main Windows XP crash should be fixed in revision 69781 which has just been pushed live.

Thank you guys for resolving this issue so quickly. I know in these days its odd that people might still use a 10 year old OS like I do XD. However if there is no real need to upgrade many will no. I still love XP however I will go with Win7 pro (not win8) when I build a new rig. Just never needed to build a new rig for my pc computing needs.These days though even websites are using a good amount of resources from browsers making a need to have more then 3gb of ram. Cheers to you guys, I am loving your dev group as much as others like Runic,Gaslamp Games,Introvision,Data Realms,Puppygames,and the grand daddy of them all Valve.

Share this post


Link to post
Share on other sites
GenHavok    10

Game played for me thanks to revision patch but now something else occurs. I tried to turn off bloom while just in the main menu in windowed mode and the game screen completely goes to pixels.Trying to change any of the options does this as well.

OS:

WinXP SP3 32bit

Processor:

Intel P4 3.0ghz 630

RAM:

3gb DDR2

Graphic Card:

ATI 4550 HD 512mb GDDR5 vram

HDD:

Western Digital Cavier 80gb 7200rpm IDE

Edited by GenHavok

Share this post


Link to post
Share on other sites
Jee    10

[steam version] Jup... same problem.. "revision 69781" fixed the problem that it didn't start at all, but now, when I launch it in full screen, there is only sound and the screen is black. I can push on menu buttons, cause I managed to exit the game by clicking in upper right corner and pushing [enter] afterwards. When I change fullscreen to window manually by editing settings file, I can play it [the game play is choppy probably 'cause of my old pc]. When I go into options to turn off "bloom" [not switching to fullscreen], game crashes...

log file after crash: http://pastebin.com/wh80c8dW

PC: WinXP SP3, P4 3GHz, Ram 1GB, Nvidia Gforce 6200 [latest drivers].

Edit: Also, before nov. 27 update I was able to play in full screen just fine]

Edited by Jee
forgot to include OS

Share this post


Link to post
Share on other sites
GuessWhoo    10

Please choose a category

[Crash]

Platform

Steam

Version Number

-

Issue title

After dwmapi.dll fix it still doesn't work for me

Steps to reproduce

When i start it(fullscreen) it shows me just a black screen then crashes

Describe your issue

log.txt

Starting up
Don't Starve: 69781
Build Date: 2012-11-28_12-10-53
THREAD - started 'GAClient' (2784)
HttpClient::ClientThread::Main()
cGame::InitializeOnMainThread
cDontStarveGame::DoGameSpecificInitialize()
cGame::StartPlaying
LOADING LUA
DoLuaFile data/scripts/main.lua
DoLuaFile loading buffer data/scripts/main.lua
c:\jenkins\workspace\jobs\DontStarve_Release_Make_Steam_Package\workspace\data\scripts\main.lua(101,1) running main.lua

LOADING LUA SUCCESS
c:\jenkins\workspace\jobs\DontStarve_Release_Make_Steam_Package\workspace\data\scripts\mixer.lua(76,1) Set set_sfx 0.7
c:\jenkins\workspace\jobs\DontStarve_Release_Make_Steam_Package\workspace\data\scripts\mixer.lua(76,1) Set set_ambience 0.7
c:\jenkins\workspace\jobs\DontStarve_Release_Make_Steam_Package\workspace\data\scripts\mixer.lua(76,1) Set set_music 0.7
Reset() returning
Error creating shader
Error creating shader
Shader(c:\users\jkwan~1.kle\appdata\local\temp\tmpypeevl\font.vs.tmp), Param(MatrixP) Idx(0)
Assert failure 'array_data.mGLIndex != 0xFFFFFFFF' at ..\source\renderlib\OpenGL\HWEffect.cpp(358): Trace follows...

Share this post


Link to post
Share on other sites
Kevin    1,013

You need to manually install the directx redistributable. It's included in the Don't Starve steam distribution.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this