Sign in to follow this  
Demodude123

[Graphics] OpenGL 2.1 Error When Starting Game

Recommended Posts

Demodude123    10

Bug Submission

Please choose a category

[Graphics]

Platform

  • Steam

Version Number

-

Issue title

OpenGL 2.1 Error When Starting Game

Steps to reproduce

I pressed to play it and it in steam like any other game.

Describe your issue

I pressed play game in my steam library and it came up as a hollow window. I minimized it and got an opengl error saying I didn't meet the opengl 2.1 requirements. I checked my graphics card, and I had opengl 2.0. The real issue is that I could play the web version perfectly fine. If I can run it fine under google chrome, then why is it asking for more of my computer for the steam version? Here are my specs from Speccy:

Graphics

Monitor:

Name Default Monitor on Mobile Intel 965 Express Chipset Family

Current Resolution 1024x768 pixels

Work Resolution 1024x708 pixels

State enabled, primary, output devices support

Monitor Width 1024

Monitor Height 768

Monitor BPP 32 bits per pixel

Monitor Frequency 60 Hz

Device \\.\DISPLAY1\Monitor0

Mobile Intel® 965 Express Chipset Family

Memory 384 MB

Memory type 2

Driver version 6.14.10.5218

Mobile Intel® 965 Express Chipset Family

Memory 384 MB

Memory type 2

Driver version 6.14.10.5218

OpenGL

Version 2.0.0 - Build 7.15.10.5218

Vendor Intel

Renderer Intel 965/963 Graphics Media Accelerator

GLU Version 1.2.2.0 Microsoft Corporation

Values

GL_MAX_LIGHTS 16

GL_MAX_TEXTURE_SIZE 2048

GL_MAX_TEXTURE_STACK_DEPTH 10

GL Extensions

GL_EXT_blend_minmax

GL_EXT_blend_subtract

GL_EXT_blend_color

GL_EXT_abgr

GL_EXT_texture3D

GL_EXT_clip_volume_hint

GL_EXT_compiled_vertex_array

GL_SGIS_texture_edge_clamp

GL_SGIS_generate_mipmap

GL_EXT_draw_range_elements

GL_SGIS_texture_lod

GL_EXT_rescale_normal

GL_EXT_packed_pixels

GL_EXT_separate_specular_color

GL_ARB_multitexture

GL_EXT_texture_env_combine

GL_EXT_bgra

GL_EXT_blend_func_separate

GL_EXT_secondary_color

GL_EXT_fog_coord

GL_EXT_texture_env_add

GL_ARB_texture_cube_map

GL_ARB_transpose_matrix

GL_ARB_texture_env_add

GL_IBM_texture_mirrored_repeat

GL_EXT_multi_draw_arrays

GL_NV_blend_square

GL_ARB_texture_compression

GL_3DFX_texture_compression_FXT1

GL_EXT_texture_filter_anisotropic

GL_ARB_texture_border_clamp

GL_ARB_point_parameters

GL_ARB_texture_env_combine

GL_ARB_texture_env_dot3

GL_ARB_texture_env_crossbar

GL_EXT_texture_compression_s3tc

GL_ARB_shadow

GL_ARB_window_pos

GL_EXT_shadow_funcs

GL_EXT_stencil_wrap

GL_ARB_vertex_program

GL_EXT_texture_rectangle

GL_ARB_fragment_program

GL_EXT_stencil_two_side

GL_ATI_separate_stencil

GL_ARB_vertex_buffer_object

GL_EXT_texture_lod_bias

GL_ARB_occlusion_query

GL_ARB_fragment_shader

GL_ARB_shader_objects

GL_ARB_shading_language_100

GL_ARB_texture_non_power_of_two

GL_ARB_vertex_shader

GL_NV_texgen_reflection

GL_ARB_point_sprite

GL_EXT_blend_equation_separate

GL_ARB_depth_texture

GL_ARB_texture_rectangle

GL_ARB_draw_buffers

GL_ARB_pixel_buffer_object

GL_WIN_swap_hint

GL_EXT_framebuffer_object

GL_EXT_bgra

Edited by Demodude123
Fixing up the formatting

Share this post


Link to post
Share on other sites

Hello there!

A lot of people are experiencing the same issue and the devs are already working on it.

Please take a look at this and this thread. Oh, and would be nice to search the forum for problems alike in future bug reports.

I hope everything goes well.

Share this post


Link to post
Share on other sites
Demodude123    10
Hello there!

A lot of people are experiencing the same issue and the devs are already working on it.

Please take a look at this and this thread. Oh, and would be nice to search the forum for problems alike in future bug reports.

I hope everything goes well.

Thanks. Will now try and report my result with the beta option.

Share this post


Link to post
Share on other sites
Demodude123    10
Nice! Remember to post any feedback concerning the possible "fix" here.

Best luck for you!

I tried it and it turns out that it just appears and then disappears right after.

Share this post


Link to post
Share on other sites
Sign in to follow this