Sign in to follow this  
Lord Cafe

60 FPS but game looks like 15fps

Recommended Posts

Lord Cafe    125

Hi, i've been playing don't starve together for years and for some reason some months ago my game started to realy lag, my fps keeps on 60-57 but it looks like i'm playing on 15fps, i tried without any mods(cleared the mods on  steam folder) and i'm still lagging, sometimes i lag on main menu.

It's the ony game that i've thoose problems, played like Horizon Zero Dawn, Re7, re8 and even unoptimized games and they still run fine , i already tried to format my pc and reinstall all graphic drivers and nothing seems to solve the problem, it's only this game... i found some people with the same problem but all topics had zero solutions so does anybody has a solution for this? 

Here are some things i already tried

Chaging resolution - No matter  which resolution i play, the lag and fps it's the same
Graphics -  no diference
No mods
Beta - On beta versions i don't have this problem but sometimes i do.

Cheers.
 

  • Like 1

Share this post


Link to post
Share on other sites
Gashzer    444

Is your world 5000days or more? With lots of junk items lying about?

  • If it isnt a save or world issue then backup your save folder in documents.
  • Uninstall dst, check steam folder for any undeleted folders an delete em
  • Reinstall
  • Check back with us lol
  • Like 1

Share this post


Link to post
Share on other sites
Lord Cafe    125
4 hours ago, Gashzer said:

Is your world 5000days or more? With lots of junk items lying about?

  • If it isnt a save or world issue then backup your save folder in documents.
  • Uninstall dst, check steam folder for any undeleted folders an delete em
  • Reinstall
  • Check back with us lol

Any word, any size, day one or day 5000 with or without caves...

Never had this problem even on my mega bases servers with a lot of people... it's started some updates ago... i think after Wanda and persist until today.

Edited by Lord Cafe

Share this post


Link to post
Share on other sites
Cliffford W.    647

You could try what Jesse mentioned above or verifying game cache or in Documents/Klei/DoNotStarveTogether/yourid 

there is file called client.ini which stores the Refresh Rate try to check if the refresh_rate is set to your monitors

  • Like 1

Share this post


Link to post
Share on other sites
Lord Cafe    125
50 minutes ago, JesseB_Klei said:

Here

client_log.txt DxDiag.txt

44 minutes ago, Cliffford W. said:

You could try what Jesse mentioned above or verifying game cache or in Documents/Klei/DoNotStarveTogether/yourid 

there is file called client.ini which stores the Refresh Rate try to check if the refresh_rate is set to your monitors

Yes, it's 60 but sometimes for no reason game start to lag even with the same fps and i don't think it's an problem with pc not able to handle since i can spawn a lot of enemies and still keep my fps... i hope thoose logs help to solve the problem, thanks everyone for the help. 

Edited by Lord Cafe

Share this post


Link to post
Share on other sites
JesseB_Klei    2101
29 minutes ago, Lord Cafe said:

Yes, it's 60 but sometimes for no reason game start to lag even with the same fps and i don't think it's problem with pc not able to handle since i can spawn a lot of enemies and still keep my fps... i hope thoose logs help to solve the problem, thanks everyone for the help. 

Thank you. For a preliminary test could you try to turn off AMD optimizations for Don't Starve Together? There have been other issues with the game and their optimizations in the past. If this does not work and you are still having an issue I would like for you to submit a bug report to the tracker with these text files so that the rest of the team can also have the chance to take a look when they can. https://www.amd.com/en/support/kb/faq/dh-012

  • Like 1
  • Thanks 2

Share this post


Link to post
Share on other sites
Lord Cafe    125
11 minutes ago, JesseB_Klei said:

Thank you. For a preliminary test could you try to turn off AMD optimizations for Don't Starve Together? There have been other issues with the game and their optimizations in the past. If this does not work and you are still having an issue I would like for you to submit a bug report to the tracker with these text files so that the rest of the team can also have the chance to take a look when they can. https://www.amd.com/en/support/kb/faq/dh-012

I tried turning everything off on amd optimizations i think everything was off already but the problem persist... i'll send a report to the tracker later then, ty for the help.

  • Thanks 1

Share this post


Link to post
Share on other sites
Gashzer    444
12 hours ago, Lord Cafe said:

I tried turning everything off on amd optimizations i think everything was off already but the problem persist... i'll send a report to the tracker later then, ty for the help.

My last idea would be to make backup of the dst fils in my documents then delete the whole dst folder then try load up dst again. Sorry i couldn't help more

  • Like 1

Share this post


Link to post
Share on other sites
Lord Cafe    125
3 hours ago, Gashzer said:

My last idea would be to make backup of the dst fils in my documents then delete the whole dst folder then try load up dst again. Sorry i couldn't help more

I did that, to be fair i deleted everything unsubscribed from all mods and started dst vanilla and at first i thought it solved but after 30s i got some lags even with my fps telling me that the game was running at 60.

But anyways thanks for the reply :).

Share this post


Link to post
Share on other sites
Lord Cafe    125
17 hours ago, Karitha said:

Can you change screen size with windowed instead of fullscreen?

Yup, no matter the resolution the fps stays the same and then while playing i get thoose weird lags even with 60... 

I forgot to say that i already put new hardware on my pc, new GPU and SSD and new RAM, my CPU doesn't bottleneck with my GPU so it' can be stuttering from that... know ideia how to solve this. 

  • Sanity 1

Share this post


Link to post
Share on other sites
PuffinBy    436

Have you tried disabling your anti-virus software. Before, I used to lag a-lot after 1 hour or some gameplay when it starts scanning.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this