Bleplep

[RESOLVED] DST crashes on launch from Steam

Recommended Posts

Bleplep    1

Please choose a category
[Crash]

Platform
Steam
Do you use mods?
 no
Version Number

498875 (I think; it's the latest one at the time of this post)

Issue title
Hit Play on Don't Starve Together (Steam), black DS/DST window opens for 5 seconds before closing.

Steps to reproduce
Press Play on Steam for DS and DST

Describe your issue

Pressing "Play" on Don't Starve and Don't Starve Together on Steam results in a black window opening for a short moment before closing/crashing. The game is considered "launched" by Steam and "closed" when the window goes away. It is worth noting that this error has never occurred in all my years of playing, until the past few days. I have attempted dozens of fixes, including all tips on this page: Game Is Crashing / Game Won't Start (PC/Mac/Linux) – Klei Entertainment

I have:

  • verified my specs to be sufficient for playing the game
  • verified integrity of game files (multiple times)
  • did my best to ensure other programs are not interfering (deleted my browser, had minimal software running, no discord, etc.)
  • ensured my graphics card driver is up to date
  • ensured Windows 10 is up to date
  • unsubscribed from all workshop mods and deleted all traces of workshop files for DS/DST
  • disabled all firewall and ensured DS/DST were allowed to run
  • checked to ensure that RivaTuner and MSI Afterburner were not interfering (they were never installed)
  • launched Steam as admin (after/before restart) and did same with DS/DST
  • re-run my game's VCRedist and DXSetup installers
  • used Catalyst Control Center (downloaded just to try this) to enable anisotropic filtering
  • attempted various graphical settings in AMD Software: Adrenalin Edition
  • deleted all Klei files under documents on multiple occasions
  • restarted my PC at least 25 times in the course of all troubleshooting
  • tried probably a few other fixes that I don't even remember anymore

It may be worth noting that, right before this problem emerged, I downloaded Radeonpro and messed around in it before uninstalling it.

By now, I expected to solve this issue myself but I am at my wit's end. Please assist me in any way you can, and thank you for taking the time. Do note: I do not normally have Don't Starve installed and do not have log files for it, as I only really care for DST (though this issue occurs for both). Attached are additional files which may be of use for troubleshooting; I will upload more if requested. I do not have an MDMP file in my documents folder and I have already gone ahead and deleted all save files related to DST under the folder "remote" in folder "219740".

 

DxDiag.txt client_log.txt

Share this post


Link to post
Share on other sites
JanH    8609

Sorry to hear about this. Based on your description, it sounds like something that was changed with RadeonPro affected your GPU's ability to render the game properly. You could try re-installing RadeonPro and re-setting any changed options that were changed previously.

Also, you could try going into your AMD Radeon settings, and disable all of AMD graphics optimization features for Don't Starve Together to see if that makes a difference when your GPU tries to launch or render the game. It may be that some of the built-in Radeon graphics optimization features on the AMD graphics settings is conflicts with the game's processes. More info on Radeon Settings screen/options: https://www.amd.com/en/support/kb/faq/dh-012

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
Bleplep    1

Apologies for delayed response, I've attempted some tweaks to my AMD settings and also re-installed RadeonPro (buggy software for me), and I keep attempting old fixes too, but there is no progress. I will eventually try something drastic such as resetting my entire PC to factory.

No good news yet, but thank you for the suggestions. If I ever fix this, I'll report here.

Fixed! I finally found the "Factory Reset" option under AMD Software not 15 minutes after my last post. I somehow failed to notice it all these times before, and upon clicking it DST instantly started working; I'm at the main menu listening to that lovely music.

I've got a lot of free dailies to catch up on. Thank you again for your suggestion, as it was spot-on. Too bad I'll never know what setting was buggered, but that's okay!

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now