Jump to content

[Gameplay] Mouse scrolling on linux (PC) won't work


Recommended Posts

Category: Gameplay, GUI, Input

Platform: Linux, Steam

Spoiler

The device I'm using is lenovo laptop with nvidia optimus. Run through steam without additional launch option.

OS: Manjaro Linux x86_64
Host: X456UQ 1.0
Kernel: 5.10.42-1-MANJARO
CPU: Intel i5-6200U (4) @ 2.800GHz
GPU: Intel Skylake GT2 [HD Graphics 520]
GPU: NVIDIA GeForce 940MX

Do you use mod?: Tried with and without mod, still not working.

 

Steps to reproduce:

Open the game, start the session.

Try scrolling, it won't zoom.

Go to crafting menu, select category and try scroll on the list. It won't scroll.

Go to control settings, try to assign one control with mouse wheel. It won't be assigned. Not recognized at all.

 

Describe your issue

Mouse wheel input won't work. For zooming it's not a big deal but for crafting menu it's very inconvenient.

To scroll through crafting menu, the only available method is rapidly clicking arrow menu on the top and bottom of the list.

I saw people on youtube able to scroll fast while not clicking the arrow button, I assume they scroll using mouse wheel? But mine can't do that.

However if I tried to scrooooooooooooooll by rotating that wheel endlessly while moving the mouse around the crafting list. Sometimes, it will actually scroll once, made little scrolling noise similar to clicking the up and down button.

I thought there are a little spot that will make scrolling works but I cannot found it.

 

 

Additional note:

Left (button1), right (button2) and middle mouse (button3) is still recognized.

 

 

Below is what's updated on log.txt when I was testing out the scrolling. Does not look very helpful thought.

Spoiler

[00:15:34]: focus gained
[00:15:40]: cSoundEmitterComponent::PlaySound() already playing sound named [flyin]
[00:15:41]: cSoundEmitterComponent::PlaySound() already playing sound named [flyin]
[00:15:41]: cSoundEmitterComponent::PlaySound() already playing sound named [flyin]
[00:15:41]: cSoundEmitterComponent::PlaySound() already playing sound named [flyin]
[00:15:46]: cSoundEmitterComponent::PlaySound() already playing sound named [flyin]
[00:15:46]: cSoundEmitterComponent::PlaySound() already playing sound named [flyin]
[00:15:46]: cSoundEmitterComponent::PlaySound() already playing sound named [flyin]
[00:15:46]: cSoundEmitterComponent::PlaySound() already playing sound named [flyin]
[00:15:52]: cSoundEmitterComponent::PlaySound() already playing sound named [flyin]
[00:15:52]: cSoundEmitterComponent::PlaySound() already playing sound named [flyin]
[00:15:52]: cSoundEmitterComponent::PlaySound() already playing sound named [flyin]
[00:16:04]: focus lost
[00:16:05]: cSoundEmitterComponent::PlaySound() already playing sound named [flyin]
[00:16:05]: cSoundEmitterComponent::PlaySound() already playing sound named [flyin]
[00:16:05]: cSoundEmitterComponent::PlaySound() already playing sound named [flyin]
[00:16:05]: cSoundEmitterComponent::PlaySound() already playing sound named [flyin]
[00:16:08]: focus gained
[00:16:10]: focus lost

 

 

If there is any other information that I'm supposed to provide but missed. Feel free to ask.

Thank you for your attention

Link to comment
Share on other sites

Ooops, found the issue. My problem is caused by imwheel. It's a program that increase scroll speed on certain apps. I used it to speed up scroll on electron apps such as Discord since they are super slow.

Spoiler

```

".$"
    None, Up, Button4, 1
    None, Down, Button5, 1
    Shift_L,   Up,   Shift_L|Button4, 1
    Shift_L,   Down, Shift_L|Button5, 1
    Control_L, Up,   Control_L|Button4, 1
    Control_L, Down, Control_L|Button5, 1

```

Scroll up are Button4, and scroll down are Button5

 

 

Hmm, it's still supposed to send mouse wheel up and down to the game since it still works for other games I have such as native Terraria and Stardew Valley and various other windows game running with wine. :?

Now I'm not sure if it's bug or not. What do you think? Perhaps it's just unique implementation.

But I must say, I like your input system.

Spoiler

I'm using non qwerty layout, and being able to play the game directly without altering the control settings is amazing. My F button is T, but it's still recognized as F for attack while still recognized as T when typing. Usually only some apps do this, and Don't Starve is the first game I played that works this way ever since I switched keyboard layout. Well done!

 

So I guess feel free to ignore this, probably not many people are playing on linux let alone using imwheel along with that. :cold:

Sorry if I waste your time reading this issue. I wanted to delete it but I was not able to, so instead I'll post a solution!

 

 

Solution for the imwheel

Spoiler

 

If you do play on linux and using imwheel,

Use this version of imwheel instead of official one here: https://github.com/ajh3/imwheel-exclude-patched

Compile them yourself or if you trust me, you can use the binary file I attached.

And then you can exclude don't starve to your ~/.imwheelrc


"Don't Starve$"
@Exclude

 

 

 

imwheel

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...