marsnz

Fixes to automation to make it functional for water & gas

Recommended Posts

marsnz    11

At the moment i have a maze of pipes going everywhere in my bases. In order to detect what sort of liquids etc i have (using automation) results in issues where the liquid will just pass directly past the liquid shutoff i want to activate so i have resorted to using filters. But this has created its own set of problems. I cannot detect the level of the tanks so when a tank/reservoir gets full there is no way to redirect the liquid/gases elsewhere. If i use AND filters the whole chain becomes unusable. If i add automation to a gas or liquid tank/reservoir, the reservoir essentially doesn't return a false [ie. its input not output], but i can't pass that feedback to the next automation chain to switch on say a liquid vent to drop that liquid somewhere to be resorted later). This results in the entire piping system becoming full and nothing can move anywhere.

Unless i'm completely oblivious to something, the OR gate won't work unless its getting signal but since i can only pass input there's no way to signal the next branch to kick in.

 

Scope of the problem
image.thumb.png.fe43cc72985036443f9062896fd8b045.png

Automation Layout

image.thumb.png.2804d0edc84631f43480b8372c47ddaf.png

Edited by marsnz

Share this post


Link to post
Share on other sites
marsnz    11
11 minutes ago, sakura_sk said:

Am I the only one who doesn't understand what the problem actually is..?

reservoirs don't have an output for automation as per the explanation and the images showing how i am attempting to attach it.

11 minutes ago, sakura_sk said:

Am I the only one who doesn't understand what the problem actually is..?

Have you not used the liquid teleporters yet ? you can't send liquids through if they aren't filtered to prevent it going through and getting wrong element errors and blocking the entire line, same with gas pipes.

Edited by marsnz

Share this post


Link to post
Share on other sites
sakura_sk    806
11 minutes ago, marsnz said:

reservoirs don't have an output for automation

That's what I don't understand maybe... Reservoirs only have output signal (and changes like in batteries). What they are missing is input signal or a shut off if full.

12 minutes ago, marsnz said:

Have you not used the liquid teleporters yet ?

I did but only for "in" water - "out" petroleum, so no problems there :P

Share this post


Link to post
Share on other sites
marsnz    11
51 minutes ago, sakura_sk said:

That's what I don't understand maybe... Reservoirs only have output signal (and changes like in batteries). What they are missing is input signal or a shut off if full.

I did but only for "in" water - "out" petroleum, so no problems there :P

For me it doesn't have an out. the second i attach the automation wire it just doesn't accept any liquid input

Share this post


Link to post
Share on other sites
sakura_sk    806
12 minutes ago, marsnz said:

For me it doesn't have an out. the second i attach the automation wire it just doesn't accept any liquid input

I still have no idea what you are talking about... Are we talking about reservoirs? 

Because reservoirs work like this:

Spoiler

Liquid runs through a reservoir unobstructed. If you connect in and out it will always run (if the out pipe isn't blocked). That is why reservoirs are put as buffers in many builds (e.g. cooling loops using an aquatuner)

Automation in reservoirs works like in smart batteries. Reservoir will output true(green) if it is below its high threshold limit until it reaches it. Then it outputs false(red) until it reaches the low threshold limit.

Below, I connected to reservoir's output automation a liquid shut off valve that will disconnect liquid "in" when reservoir reaches high threshold (in this case 20 = 5000kg:20=1000kg ) and the liquid vent will open when high threshold is reached (pictures below) and not close until the low threshold limit is reached. Just like a smart battery would activate a generator. Only difference is "out" liquid from reservoir, always tries to flow.

1466889715_reservoiroutput_.thumb.jpg.f10391eb954f85b06ed7185ac70d0aad.jpg

reservoir_.thumb.jpg.93a70d5b3d57c417a71ba139d124615f.jpg

Are we talking about supply teleporters?

Yeah... That thing has no automation whatsoever. Probably too many inputs-outputs to put one that would work..?

Share this post


Link to post
Share on other sites
marsnz    11
21 minutes ago, sakura_sk said:

I still have no idea what you are talking about... Are we talking about reservoirs? 

Because reservoirs work like this:

  Reveal hidden contents

Liquid runs through a reservoir unobstructed. If you connect in and out it will always run (if the out pipe isn't blocked). That is why reservoirs are put as buffers in many builds (e.g. cooling loops using an aquatuner)

Automation in reservoirs works like in smart batteries. Reservoir will output true(green) if it is below its high threshold limit until it reaches it. Then it outputs false(red) until it reaches the low threshold limit.

Below, I connected to reservoir's output automation a liquid shut off valve that will disconnect liquid "in" when reservoir reaches high threshold (in this case 20 = 5000kg:20=1000kg ) and the liquid vent will open when high threshold is reached (pictures below) and not close until the low threshold limit is reached. Just like a smart battery would activate a generator. Only difference is "out" liquid from reservoir, always tries to flow.

1466889715_reservoiroutput_.thumb.jpg.f10391eb954f85b06ed7185ac70d0aad.jpg

reservoir_.thumb.jpg.93a70d5b3d57c417a71ba139d124615f.jpg

Are we talking about supply teleporters?

Yeah... That thing has no automation whatsoever. Probably too many inputs-outputs to put one that would work..?

Yeah which is why i am asking to have an output for automation on the reservoirs so i can keep the gas and liquid flowing correctly without backing up everything else. I had two games now where i had water stop because the water flow from the geyser to the supply teleporter was backed up; and i need water on the starting biome to goto the swamp cluster planetoid to be cooled by the Anti Entropy Thermo-Nullifier to be returned to use on the electrolyzers to supply cooled oxygen for the atmosuits.

Trying not to use the local water sources for the other planetoid because ... lets face it they are so irregular at erupting that it makes more sense to do it this way.

As per the first set of pictures, we're going from a pump, to a liquid filter, at which point it needs to split into clean water and polluted water, when that reservoir is full it needs to then go into the pipe up to a reservoir next to the supply teleporter and then the reverse coming back from the return.

Doing as you have pictured, the cutoff is an INPUT to the reservoir, if i do it in reverse where the reservoir needs to be filled first this doesn't work. I need hot water locally to supply all the other equipment; i only need the left over water to goto the supply teleporter

Cooling gases is the same problem.

Edited by marsnz

Share this post


Link to post
Share on other sites
sakura_sk    806
3 minutes ago, marsnz said:

Yeah which is why i am asking to have an output for automation on the reservoirs

Well.. as I was saying.. There is an "output for automation on the reservoirs"... :lol:

Do you mean you need automation on reservoir to work like a switch? Green: accept liquid (passing unobstructed through the in-out liquid ports), Red: shut off  reservoir (no in, no out liquid).

Currently you can control liquid reservoir "shut-off" by putting an open mechanized airlock below the reservoir

Spoiler

Same setup as before, but mechanized airlock is open and reservoir doesn't let any water out.

image.png.b66aa5542759f87a31dd429e9c2c8878.png

Usually this setup is used for disinfection (letting liquid sit in a reservoir surrounded by chlorine to kill any germs)

 

Share this post


Link to post
Share on other sites
marsnz    11
5 minutes ago, sakura_sk said:

Well.. as I was saying.. There is an "output for automation on the reservoirs"... :lol:

Do you mean you need automation on reservoir to work like a switch? Green: accept liquid (passing unobstructed through the in-out liquid ports), Red: shut off  reservoir (no in, no out liquid).

Currently you can control liquid reservoir "shut-off" by putting an open mechanized airlock below the reservoir

  Hide contents

Same setup as before, but mechanized airlock is open and reservoir doesn't let any water out.

image.png.b66aa5542759f87a31dd429e9c2c8878.png

Usually this setup is used for disinfection (letting liquid sit in a reservoir surrounded by chlorine to kill any germs)

 

you're still not detecting when the tank is full.
this is a situation where i don't know how much liquid is coming back through the return supply teleporter, and if i have to manually manage the flow that defeats the automation part of the entire discussion.

Edited by marsnz

Share this post


Link to post
Share on other sites
sakura_sk    806
2 minutes ago, marsnz said:

you're still not detecting when the tank is full.

If it is full, every pipe is blocked anyway... That's why you need automation before that point

 

Share this post


Link to post
Share on other sites
marsnz    11
15 minutes ago, sakura_sk said:

If it is full, every pipe is blocked anyway... That's why you need automation before that point

 

you're still thinking like i'm dealing with just one water flow, i need to manage the input supply teleporter and the output supply teleporter and move the fluids around. Not on one world but two. IF i have to manage that manually i will only be doing that the entire game.

I have to deal with the world that i'm currently working on, while the emulation is still going on, on the other world. while still having that worlds water flow moving around. The local one i can use the method you suggested. But the automation for the Anti Entropy Thermo-Nullifier will need to be fully automated, filling a hot tank on world 1 (used for keeping the heat up in the rocket airlock areas, hot tubs etc.) as well as pumping water to world 2 (with a reservoir to manage the flow through the supply teleporter to world 2) and a hot water tank on world two that goes to the Anti Entropy Thermo-Nullifier, a return cooled water tank on world 2. world 2 requires hot water for regulating the sleet wheat farm, hot tub etc.), and a cooled tank from the Anti Entropy Thermo-Nullifier on world 1 (that came via the supply teleporter) and world 2 with its own water system. thats a LOT of manual switching. Sorry thats just stupid. A simple solution is an output on the reservoir that fixes all those problems by allowing us to detect when the tank is full so we can redirect water elsewhere.

if the gases are the same it fixes so many problems, we can then push excess gases into space etc.

your solution adds an additional 8 pumps, 12 filters, and an extra 2000 refined gold to my problem. the power requirements are then the next problem, considering i have to have the cooling on world 2 BEFORE i can get to the oil to get plastic. and the cramped world size means theres not enough space to do anything else with the space restriction.

Edited by marsnz

Share this post


Link to post
Share on other sites
sakura_sk    806
2 minutes ago, marsnz said:

i need to manage the input supply teleporter and the output supply teleporter

So we are not talking about reservoir automation... Teleporters are the problem :lol:

There was a liquid/gas filtering system from one mixed-everything pipe to every element separate outputs but I don't remember where I saw it in the forum :???:

Share this post


Link to post
Share on other sites
marsnz    11
21 minutes ago, sakura_sk said:

So we are not talking about reservoir automation... Teleporters are the problem :lol:

There was a liquid/gas filtering system from one mixed-everything pipe to every element separate outputs but I don't remember where I saw it in the forum :???:

image.thumb.png.deba55121c6686c148c5457e4868cd43.png

 

image.thumb.png.6e8235fb5317d6781a979ff4079f4166.png

Share this post


Link to post
Share on other sites
RomainL    26
22 minutes ago, sakura_sk said:

So we are not talking about reservoir automation... Teleporters are the problem :lol:

There was a liquid/gas filtering system from one mixed-everything pipe to every element separate outputs but I don't remember where I saw it in the forum :???:

Are you referring to that thread :

 

 

Share this post


Link to post
Share on other sites
marsnz    11
2 minutes ago, RomainL said:

Are you referring to that thread :

 

 

are you pulling my leg. The supply teleporter has a liquid, a gas and a solids transport on it. You can send all three types of supplies through the teleporter. We're in the Spaced Out DLC forum here.

Edited by marsnz

Share this post


Link to post
Share on other sites
sakura_sk    806
20 minutes ago, RomainL said:

Are you referring to that thread

No. I remember multiple colors in pipes gif. Probably gas shorting  distribution sorting

Edited by sakura_sk

Share this post


Link to post
Share on other sites
marsnz    11

green is gas, blue is liquids, brown/orange is solids.

my solution applies to managing gases and liquids going through the teleporter.
but it applies to filtering water etc. all the same. the reservoirs need an output to simplify automation.

Edited by marsnz

Share this post


Link to post
Share on other sites
sakura_sk    806

@marsnz I don't try to touch what you are trying to do (cooling water using a nullifier), because I don't think it is a viable option. You can efficiently cool gas using liquid but not the other way around. Using an aquatuner is the only efficient way to cool liquids (as far as I've seen/played so far). Using cool water in electrolizers is even more inefficient. Electolizer outputs 70 C oxygen either way. It is more efficient to cool a 90 C oxygen output than 90 C water input. Either way I don't think automation in reservoir would solve your problem... (Although... if you don't have any other gas passing though teleporter.. Problem solved! :-D )

Share this post


Link to post
Share on other sites
The Plum Gate    716
2 hours ago, marsnz said:

For me it doesn't have an out. the second i attach the automation wire it just doesn't accept any liquid input

Bugged. Disable mods?

My favorite setup is a not gated gas or liquid shutoff on mixed element reservoir cachés.

I can fill this up and then turn the sources off with the bare signal,  the not gate shuts the line off at the exit until the tank fills. Output is alternating, So it would be possible to automate sorting and get nice big packets out of the system.

Not sure why your reservoirs are disallowing input when automation is attached. You can send fluids and gasses to disabled reservoirs and it will go in the tank and not come out. 

Otherwise you have a bugged reservoir and maybe need to reconstruct it. Check and make sure you haven't flipped a bridge somewhere.

 

Share this post


Link to post
Share on other sites
marsnz    11
15 minutes ago, sakura_sk said:

@marsnz I don't try to touch what you are trying to do (cooling water using a nullifier), because I don't think it is a viable option. You can efficiently cool gas using liquid but not the other way around. Using an aquatuner is the only efficient way to cool liquids (as far as I've seen/played so far). Using cool water in electrolizers is even more inefficient. Electolizer outputs 70 C oxygen either way. It is more efficient to cool a 90 C oxygen output than 90 C water input. Either way I don't think automation in reservoir would solve your problem... (Although... if you don't have any other gas passing though teleporter.. Problem solved! :-D )

you can't use aquatuners when all water sources on Terra are all 300f/100c and theres no cooling systems on Terra, the heat from the aquatuners have to go somewhere, and you can only use worts, and they are  only on Swamp. I'd have to vent air through to space, which means i lose everything and i need atmosuits .. which need cool air since the temp on the cool steam vents is 300f/100c when it goes through the electrolyzer it comes up at 95f/40c and cooling a base and for atmosuits with that is impossible, can't grow crops etc. I HAVE to use the Anti Entropy Thermo-Nullifier for keeping the temps down

5 minutes ago, The Plum Gate said:

Bugged. Disable mods?

My favorite setup is a not gated gas or liquid shutoff on mixed element reservoir cachés.

I can fill this up and then turn the sources off with the bare signal,  the not gate shuts the line off at the exit until the tank fills. Output is alternating, So it would be possible to automate sorting and get nice big packets out of the system.

Not sure why your reservoirs are disallowing input when automation is attached. You can send fluids and gasses to disabled reservoirs and it will go in the tank and not come out. 

Otherwise you have a bugged reservoir and maybe need to reconstruct it. Check and make sure you haven't flipped a bridge somewhere.

 

i've played at least 20 games, the same problem over and over. With or without mods, same problem.

Edited by marsnz

Share this post


Link to post
Share on other sites
yoakenashi    661

@marsnz To achieve what you desire, you do not even need automation. The following example will take water from the pipe to fill up the reservoir first.

image.thumb.png.0c1a3f86bf3e0b00e89130259f396781.png
 

Share this post


Link to post
Share on other sites
marsnz    11
4 minutes ago, yoakenashi said:

@marsnz To achieve what you desire, you do not even need automation. The following example will take water from the pipe to fill up the reservoir first.

image.thumb.png.0c1a3f86bf3e0b00e89130259f396781.png
 

the other thing as i pointed out on my images, is that when the hot water tank is full i want to pipe that to other devices, which will require the tank to output automation to open up cutoff valves elsewhere; again this only solves the movement of water, not the automation part of the puzzle.I do NOT want to dump out hot liquid into the base or its surroundings, i want to pass the liquid straight to the desired locations.

The cooling link is one part of a bigger picture, but its not the complete automation system. I need to have the cooling happening, while also only triggering the hot water flow up to the cold crops on world 2 once all the tanks are full, and also on the flipside on world 1 to only use the hotwater to heat the upper part of the base were the rocket airlock is once the base is supplied with water, i've completely fulled up tanks to supply the supply teleporter and also fed the loop on the cooled water side to not allow the water to be used to cool the metal refinery etc. until after the reservoirs for the base and for cooling the airlock areas is full.

Edited by marsnz

Share this post


Link to post
Share on other sites
The Plum Gate    716
12 minutes ago, marsnz said:

i've played at least 20 games, the same problem over and over. With or without mods, same problem.

So, what's the problem again specifically with the tank?

Share this post


Link to post
Share on other sites
marsnz    11
3 minutes ago, The Plum Gate said:

So, what's the problem again specifically with the tank?

if I use an OR gate it never changes state. because the reservoirs only have input not output.
The filled state is never satisfied on the second reservoir because the first is full but the water flow can't be controlled because of other pipes causing the liquid to go elsewhere.

image.thumb.png.6573f7f3c2d4e4199816ee6421b0b22c.png

Edited by marsnz

Share this post


Link to post
Share on other sites
yoakenashi    661
2 minutes ago, marsnz said:

if I use an OR gate it never changes state. because the reservoirs only have input not output.

The logic you showed in the original post doesn't make sense. You're ORing a signal with a NOT of the same signal. The output of the OR will always be set GREEN.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now