Sign in to follow this  
Corey

Issue: Steam Version Not Working for You

Recommended Posts

mandude81    10

Another note is that if you use the GLCrash Beta version. When they update the game and get rid of that version you will lose all data since it is not part of the official version of Don't starve. So if that doesn't work, your not missing much in the long run.

Share this post


Link to post
Share on other sites
Mays    10

I can play without lag now. So this fix will be out Tuesday? Might as well play this until then. Don't care about my save.

Edited by Mays

Share this post


Link to post
Share on other sites
Ok, I have just confirmed that the glcrash fix will be making it's way to the next update Tuesday. We believe this will fix the vast majority of users experiencing this issue.

Those that may not be helped by this issue will be users whose graphic cards do not meet the minimum specs to play the game.

Thank you to all who helped us with the information and testing we needed to resolve this issue.

Damn good news!

Share this post


Link to post
Share on other sites
jurban    10

I used a program called DriverMax and I believe it's the #1 driver application on cnet.com. I installed the free version, which only allows you to download/install 2 drivers a day. Luckily, the Nvidia driver was the only one holding me back from playing the game.

Edited by jurban

Share this post


Link to post
Share on other sites

I know: My Laptop is not good at all.

But I would love to play Don't Starve.

Or I would have bought it, but couldn't play the game. :(

I hope you can fix it.

(Maybe do something with lowering graphics or such, maybe thats an solution?)

------------------

System Information

------------------

OS: Windows 7 Home Premium 64-bit

Fabric: Hewlett-Packard

Model: Compaq Presario CQ71 Notebook PC

Processor: Celeron® Dual-Core CPU T3000 @1.80GHz 1.79GHz

RAM: 3.00 GB

Graphicscard: Mobile Intel® 4 Series Express Chipset Family

Share this post


Link to post
Share on other sites
Drahgoon    10

http://forums.kleientertainment.com/announcement.php?f=26

This solution worked for me.

------------------

System Information

------------------

Time of this report: 11/23/2012, 12:36:08

Machine name: USER-PC

Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.120830-0333)

System Manufacturer: TOSHIBA

System Model: Satellite A505

BIOS: InsydeH2O Version 1.20

Processor: Intel® Core i3 CPU M 330 @ 2.13GHz (4 CPUs), ~2.1GHz

Memory: 4096MB RAM

Available OS Memory: 3894MB RAM

DirectX Version: DirectX 11

Share this post


Link to post
Share on other sites
Elmas    10

So did it for me. Finally enjoying the game, very addictive even is still beta and more even beta for us by the way.

Share this post


Link to post
Share on other sites
LewisShaw97    10

It hasn't worked for me. Have you guys done anything else to solve the problem?

EDIT: Never mind, missed out a step and it's updating as we speak.

Edited by LewisShaw97

Share this post


Link to post
Share on other sites
Drahgoon    10

Contemplating on whether to wait for the next update or keep playing it in the glcrash beta. I'm afraid that when they update and remove it that it'll corrupt my save somehow.

Share this post


Link to post
Share on other sites
Bdtry    10

This worked for me. Unfortunately I was unable to find this site and issue though Google for some reason. Had to follow a few different links to get here.

Share this post


Link to post
Share on other sites
Alex    10

If these fixes aren't working, try re-installing Steam. I spent hours fiddling around with updated driver software, using the beta code and such. But simply re-installing steam (by recommendation of the link below) somehow managed to do the trick! Please spread this so others can finally play the game!

Edit: By re-installing, I mean go to the control panel and uninstall Steam (Make sure you back up your files, I'm not sure if it deletes them). Then go to the steam site to re-download it.

http://forums.kleientertainment.com/showthread.php?2135-Crash-HEY-EVERYONE-STEAM-ISSUE-SOLVED-CHECK-THIS-!&p=16267

Share this post


Link to post
Share on other sites
Alex    10

Though the above fix did work for me, now my game is EXTREMELY laggy, almost as if the game is running in slow-motion. When I install the glcrash beta as many have suggested, the game again simply won't open. I've now spent over 6 hours trying to get the game to properly run, and quite frankly I'm pissed.

Share this post


Link to post
Share on other sites
Kevin    500

Everyone having problems should just wait for the Tuesday update and try again. We completely updated the graphics backend to better support more hardware options, and lower-spec machines.

The fixes are not going to work for everyone, but it should clear up most problems. Then, we can focus on whatever issues are left.

Share this post


Link to post
Share on other sites
Ryzuthefox    10

I have Intel HD Graphics (core i3) with a intel64 family 6 model 37 stepping 2 processor on my laptop, I can play the glcrash build with minor lag, but the game window closes out automatically with the standard steam game

edit: I've noticed that with the glcrash that my beehive and my speedy farm both disappear after I placed them

Edited by Ryzuthefox

Share this post


Link to post
Share on other sites

so, i am one of the ones with the steam not working issue. i went into steam, right clicked the game, went to properties -> betas, did the glcrash thang and the game runs now. its somewhat choppy but hardly noticeable.

i actually just played the game a bit earlier at a mates house and its not just like it, but pretty close. the response times seem a little slowed and its not perfeclty smooth.

other than that it runs great. its great to be able to play it finally even though its just the test.

i havent noticed any problems except 3 bee's were just chillin in a group not doing anything.. other bee's were doin their thang tho.

i've built a fire ring, planted mad trees around my research machine, havent seen any bunnies but i got a trap up near some of their holes to the kingdom of bunnies etc etc

so theres that.

thats my report.

edit: i would also like to note that i would like to have it full screen but hey, to play at all is good enough for now

Edited by onehungrydude

Share this post


Link to post
Share on other sites
Bdtry    10
so, i am one of the ones with the steam not working issue. i went into steam, right clicked the game, went to properties -> betas, did the glcrash thang and the game runs now. its somewhat choppy but hardly noticeable.

i actually just played the game a bit earlier at a mates house and its not just like it, but pretty close. the response times seem a little slowed and its not perfeclty smooth.

other than that it runs great. its great to be able to play it finally even though its just the test.

i havent noticed any problems except 3 bee's were just chillin in a group not doing anything.. other bee's were doin their thang tho.

i've built a fire ring, planted mad trees around my research machine, havent seen any bunnies but i got a trap up near some of their holes to the kingdom of bunnies etc etc

so theres that.

thats my report.

edit: i would also like to note that i would like to have it full screen but hey, to play at all is good enough for now

In the options set the full screen resolution you want then press enter when in game to make it go full screen

Share this post


Link to post
Share on other sites
Inunah    10

I'm getting the window appearing then disappearing bug as well. I'm also using an Intel chipset. glcrash fixes this, but trying to go full screen without changing the resolution crashes the game for some reason.

Here's my log:

Starting up

cGame::InitializeOnMainThread

THREAD - started 'GAClient' (6048)

HttpClient::ClientThread::Main()

cDontStarveGame::DoGameSpecificInitialize()

cGame::StartPlaying

LOADING LUA

DoLuaFile data/scripts/main.lua

DoLuaFile loading buffer data/scripts/main.lua

c:\jenkins\workspace\jobs\DontStarve_Staging_Make_Steam_Package\workspace\data\scripts\main.lua(101,1) running main.lua

LOADING LUA SUCCESS

c:\jenkins\workspace\jobs\DontStarve_Staging_Make_Steam_Package\workspace\data\scripts\mixer.lua(76,1) Set set_sfx 0.7

c:\jenkins\workspace\jobs\DontStarve_Staging_Make_Steam_Package\workspace\data\scripts\mixer.lua(76,1) Set set_ambience 0.7

c:\jenkins\workspace\jobs\DontStarve_Staging_Make_Steam_Package\workspace\data\scripts\mixer.lua(76,1) Set set_music 0.7

Reset() returning

WorldSim::SimThread::SimThread()

WorldSim::SimThread::SimThread() complete

THREAD - started 'WorldSim' (3236)

WorldSim::SimThread::Main()

DoLuaFile data/scripts/worldgen_main.lua

DoLuaFile loading buffer data/scripts/worldgen_main.lua

WorldSim::SimThread::Main() complete

SAVE SUCCESS: restart_staging

SimLuaProxy::SubmitCompletedLevel()

SubmitCompletedLevel::{}

COULD NOT DELETE FILE

SimLuaProxy::QueryServer()

/anon/new - POST/{"character":"wilson","name":"Test name","size":"small"}

c:\jenkins\workspace\jobs\DontStarve_Staging_Make_Steam_Package\workspace\data\scripts\mixer.lua(76,1) Set master 0

c:\jenkins\workspace\jobs\DontStarve_Staging_Make_Steam_Package\workspace\data\scripts\mixer.lua(76,1) Set master 1

SendProfileStats::{"stats":{"collect_cutgrass":4,"collect_twigs":1,"time_played":29700}}

SendProfileStats::{"stats":{"build_axe":1,"collect_twigs":1,"collect_axe":1,"collect_carrot":4,"collect_seeds":1,"time_played":118800,"kill_beehive":1,"collect_petals":4,"collect_flint":2,"collect_pinecone":4,"collect_log":8,"collect_berries":2,"collect_cutgrass":1}}

SendProfileStats::{"stats":{"build_axe":1,"collect_twigs":7,"collect_axe":1,"collect_seeds":1,"collect_cutgrass":6,"collect_flint":2,"collect_petals":5,"collect_pinecone":4,"time_played":118800,"collect_log":7,"collect_smallmeat":1,"kill_rabbit":1}}

SAVE SUCCESS: latest_staging

c:\jenkins\workspace\jobs\DontStarve_Staging_Make_Steam_Package\workspace\data\scripts\main.lua(501,1) Saved latest_staging nil

SendProfileStats::{"stats":{"cooked_berries":3,"collect_berries_cooked":3,"collect_cookedsmallmeat":1,"collect_seeds_cooked":3,"collect_carrot":2,"collect_seeds":1,"time_played":118800,"build_campfire":1,"collect_petals":4,"cooked_seeds":3,"collect_honey":3,"cooked_smallmeat":1,"collect_berries":1,"collect_honeycomb":1}}

c:\jenkins\workspace\jobs\DontStarve_Staging_Make_Steam_Package\workspace\data\scripts\debugtools.lua(72,1) I: cause K: bee

COULD NOT DELETE FILE

SimLuaProxy::SubmitCompletedLevel()

SubmitCompletedLevel::{"stats":{"time_played":28248,"killed_by_bee":1,"collect_petals":1,"kill_bee":5,"xp_gain":0,"xp_total":0,"deaths":1}}

SAVE SUCCESS: profile_staging

ReleaseAll

ReleaseAll Finished

cGame::StartPlaying

LOADING LUA

DoLuaFile data/scripts/main.lua

DoLuaFile loading buffer data/scripts/main.lua

c:\jenkins\workspace\jobs\DontStarve_Staging_Make_Steam_Package\workspace\data\scripts\main.lua(101,1) running main.lua

LOADING LUA SUCCESS

c:\jenkins\workspace\jobs\DontStarve_Staging_Make_Steam_Package\workspace\data\scripts\mixer.lua(76,1) Set set_sfx 0.7

c:\jenkins\workspace\jobs\DontStarve_Staging_Make_Steam_Package\workspace\data\scripts\mixer.lua(76,1) Set set_ambience 0.7

c:\jenkins\workspace\jobs\DontStarve_Staging_Make_Steam_Package\workspace\data\scripts\mixer.lua(76,1) Set set_music 0.7

Reset() returning

Shutting down

In the options set the full screen resolution you want then press enter when in game to make it go full screen

You forgot to note how you can't change the resolution until you change full screen to enabled (don't apply it until after the resolution's been changed!).

Edited by Inunah

Share this post


Link to post
Share on other sites
Mellzy    10

I tried the GLcrash thing with the Steam Version :/ I get a second of music before it closes on me. I'm using an Intel Chip Series 4 family model, it runs the demo on Chrome alright but Steam just refuses to ever open. All my drivers are up to date and I've done everything in above mentioned, nothing seems to work for me.

Share this post


Link to post
Share on other sites
Monkeys    10
http://forums.kleientertainment.com/announcement.php?f=26 told me to report here, so I did:

I have Intel 4 Series chipset family with custom Acer Aspire 7715Z drivers, up to date, but the game didn't load.

I tried the experimental "glcrash" build. It works and am currently playing.

Just a small update on this:

I'm not sure if this is limited to this build, or just in general, but here are some things that seem off:

Straw hat's graphics glitch out when walking sideways. Part of the hat floats above the character.

When you have a full inventory, a backpack equipped with at least one space open, no tool equipped, and you try to make a tool (which would automatically get equipped) it also creates a "ghost" tool in your backpack. The trying to drop the "ghost" tool drops your equipped tool, but leaves your cursus as if it's still in hand (right clicking fixes this). The "ghost" item also loses durability with the real item.

If you want me to post this in a seperate thread (and any bugs I might stumble on from here on out on this build), I will.

Just a heads up, in case you didn't know, you're making an awesome game.

Share this post


Link to post
Share on other sites
Ankou    10

Glad to see some sort of progress has been made. For the sake of testing I did try the opengl beta thing on my laptop and I thought I should share that it launches normally and seems to work. I started a new world just to make sure there were no early hangups and after a long freaking loading screen (like I said in my first post, crap laptop) a new world was created.

I haven't really tried any actual gameplay with it, since it sounds quite broken still, but it does launch.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this