Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

Lifegrow

TIL - You can run an Oil Well for free... (sort of)

Recommended Posts

Lifegrow    1710

So yeah, as title suggests - Not sure if this is well known but figured i'd share in case.

Derping around in debug and tinkering with Oil Wells : image.thumb.png.bec1b1571432efd52a7911b3ff7b8bf5.png

This particular Oil well ended up getting submerged in the oil/petroleum at the bottom...

image.thumb.png.2b36c3f1c87545609695edca528bbb2d.png

The oil is hot enough to boil the water as soon as it enters the well, releasing the water as steam. The oil well still thinks it's received the water required, and keeps producing as if nothing has gone wrong....
image.thumb.png.41bfaae68b3a8950d1d73b3542e2af60.pngimage.png

Seems pretty simple to reproduce..

image.thumb.png.bfd6ecb793938bc434e0b72191df153d.png

image.thumb.png.33866a3cddeffa16eea4f0bf8fe1cd47.png

image.thumb.png.f0319bc4616feeac9ecdd582d501621a.png

Share this post


Link to post
Share on other sites
OxCD    731

Could it be linked to this bug (and the many many examples I've linked below) ?

The oil well is buggy from a looong time.

 

Share this post


Link to post
Share on other sites
Lifegrow    1710

Christ :D 

I did do a quick forum search beforehand, but didn't find much. Thanks for that bud, clearly they're a bit wonky.

Share this post


Link to post
Share on other sites
psusi    272

Yea, I was going to say that I'm pretty sure once the water boils you don't produce any more oil, but there's a weird bug where it still produces natgas.

 

Share this post


Link to post
Share on other sites