Sign in to follow this  
Chiri

Need help on fixing the problem

Recommended Posts

Chiri    6

So I was trying to make a character mod, but it crashes the game, and the error log shows this to me:

[string "../mods/mod-bell/modmain.lua"]:1: attempt to call global 'require' (a nil value)

And this is what I have in string 1:

local MakePlayerCharacter = require ("prefabs/player_common")

Which I feel little confused, I will be very appreciated if someone can give me any suggestion to solve this problem

Share this post


Link to post
Share on other sites
Yakuzashi    133

Do you have something like this?

local require = GLOBAL.require


I bet you miss that in your mod, thus the problem.

Edited by Yakuzashi
  • Like 1

Share this post


Link to post
Share on other sites
Chiri    6
12 hours ago, Yakuzashi said:

Do you have something like this?


local require = GLOBAL.require


I bet you miss that in your mod, thus the problem.

Thanks, that solves the problem

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this