Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

Craigjw

Offscreen Conveyor Heat Exchange POLL

Offscreen Conveyor Heat Exchange  

65 members have voted

  1. 1. How much does Offscreen Conveyor Heat Exchange suck?

    • It's fine, I'm a sadist, please chop off my limbs, just for the Lols.
    • Don't care.
    • A little
    • A medium amount.
    • This is moderately annoying.
    • This is quite annoying.
    • Really annoying, please fix ASAP.
    • Yesterday I smashed my monitor against the wall because of this.
    • I stopped playing ONI because this sucked too much.


Recommended Posts

Craigjw    405

Offscreen conveyor heat exchange is broken and it's annoying.  It's been around since forever and Klei haven't done anything to fix it.

Share this post


Link to post
Share on other sites
pether    153

I am not aware of this bug. Could you please explain what is it about?

7 minutes ago, Craigjw said:

Klei haven't done anything to fix it

Issues happen, no code is free of them. I can see that KLEI addressed other issues, but it is impossible to fix everything in one day. I'm sure if the issue is reported one day they will work on this to fix it - we just need to be patient :)

Share this post


Link to post
Share on other sites
Saturnus    3549
12 minutes ago, pether said:

Issues happen, no code is free of them. I can see that KLEI addressed other issues, but it is impossible to fix everything in one day. I'm sure if the issue is reported one day they will work on this to fix it - we just need to be patient :)

This was reported first about 21 months ago as I recall. You'd think almost 2 years is enough time to fix a bug.

Share this post


Link to post
Share on other sites
pether    153

Single bug - yes. One of many - not so easy.

I agree, it would be cool if the game had no bugs and any issue found was fixed ASAP, but it is not always so easy...

Anyway - what the bug is about?

Share this post


Link to post
Share on other sites
Saturnus    3549
13 minutes ago, pether said:

I agree, it would be cool if the game had no bugs and any issue found was fixed ASAP, but it is not always so easy...

It's pretty easy when you introduced the bug in the first place. Trial and error to see which part of the update you made caused the bug.

My memory failed above. It was around April 2018 that conveyors were introduced. And this bug was first spotted after an update one year later. That means for the first year it was fine. Then they made an upgrade and it was bugged after that, and have been ever since.

I realise that at this point it's not so easy to pin-point the problem but it would have been if they'd addressed and looked into the issue when it was reported.

Share this post


Link to post
Share on other sites
Gurgel    1489

Currently, I do not care, as conveyor rails have a significant performance problem anyways. I do think that when that gets fixed, the thermal aspect should be fixed as well as this behavior is surprising and inconsistent.

Share this post


Link to post
Share on other sites
Yalp    71

The oldest report of the bug I've seen:

So it was probably in since they introduced conveyors.

A few patches ago Klei tried to streamline conveyor mechanics to work like gas/liquid pipes. Hopes were, this bug would also be fixed. They had to roll that one back though.
So they are/were probably working on it.

 

As for the poll:

I stopped playing survival for 4+ months after I encountered the bug while building a somewhat complex heat exchanger thingy for the first time! (Days of play down the drain...)

I did play in debug/sandbox for that time though. Good opportunity to learn about many of the games quirks.

Share this post


Link to post
Share on other sites
Yoma_Nosme    480

I have to stand up for KLEI....

Maybe it's you people...

Get bigger screens....nothing's off screen anymore ...problem solved

*padding my shoulder, as I'm surely the bestest bug fixer this side of the Styx 

 

Share this post


Link to post
Share on other sites
SharraShimada    681

They are working on an overhaul of the conveyor system. So its pointless trying to find a bug in the old code. Sometimes its better to start from scratch than fixing a broken system.

Share this post


Link to post
Share on other sites
Lurve    382

Posted bug reports don't fix bugs, they just get the devs' curiosity.

Abominable contraptions designed by some forum cleverboots exploiting the bug to make infinite power is what gets their attention.

Share this post


Link to post
Share on other sites
Gurgel    1489
4 hours ago, SharraShimada said:

They are working on an overhaul of the conveyor system. So its pointless trying to find a bug in the old code. Sometimes its better to start from scratch than fixing a broken system.

Indeed. Scrap the old code, but remember the lessons learned from it. After they did very well on pipes, I expect the fix fill address this issue nicely.

Share this post


Link to post
Share on other sites
Craigjw    405

The bug means that random things repeatedly overheat and break, then you spend the next 50 or so cycles fixing everything in frustration, not fully knowing what caused things to go busted in the first place, until you realise, off-screen conveyor heat exchange bug...

Exploits, I don't care about much, that's an individuals choice leverage, it's not game breaking, where as a bug like this is very much game breaking IMO and WAY more important to fix than:

a) Exploits, which are NOT game breaking.  Not really much worse than enabling sandbox and giving yourself ultimate power.

b) Introducing new content, which is bound to have bugs, taking away developer time which could be better spent fixing THIS bug instead, which is game breaking.

 

10 hours ago, Yoma_Nosme said:

I have to stand up for KLEI....

Maybe it's you people...

Get bigger screens....nothing's off screen anymore ...problem solved

*padding my shoulder, as I'm surely the bestest bug fixer this side of the Styx 

 

1,000,000p resolution!

1mil.jpg.9026999b6c7c5bc60ad1f8b57a2bad73.jpg

Share this post


Link to post
Share on other sites
yoakenashi    518
14 hours ago, Saturnus said:

This was reported first about 21 months ago as I recall. You'd think almost 2 years is enough time to fix a bug.

I see your 2 years, and raise you 3 years:

 

Share this post


Link to post
Share on other sites
SharraShimada    681
2 hours ago, SpreadsheetGamr said:

Wachunga's bug report is excellent.  Devs, please take a look at this, it's very easy to reproduce the problem as described.

So what? They know about the problem. Its not a matter of reproducing at all. Its a matter of rewriting code. 

Share this post


Link to post
Share on other sites
Craigjw    405
39 minutes ago, SharraShimada said:

So what? They know about the problem. Its not a matter of reproducing at all. Its a matter of rewriting code. 

I agree, but I have yet to see anything done to remedy this issue.  What I do see is the dev's spending their time doing other things, which aren't game breaking and important, rather than fixing this issue which is game breaking and currently will and has ruined people's enjoyment of the game.

The whole purpose of this thread is to highlight to the dev's that they are focusing on the wrong thing and should focus their time on this issue instead.

Now that they released new content in the form of automation circuit's, do you think that they will spend time fixing the newly introduced bugs or the existing bugs?

Share this post


Link to post
Share on other sites
10 hours ago, SharraShimada said:

So what? They know about the problem. Its not a matter of reproducing at all. Its a matter of rewriting code. 

All I was doing was adding my voice to the chorus of people asking for this to be addressed.

Generally speaking, having a bug report that contains a reproducible steps elevates it above the sea of junk reports.  Neither of the reports linked in this thread have any kind of developer response.  That said, I'm not such an avid follower of Klei to know how they 'manage' forum bug reports, if at all.

Have they acknowledge the bug?  It sounds like you've read something I haven't, which is entirely possible.  Could you link me to where they say they acknowledge the bug or are proposing the re-write?  I'd love to take a look.  I'm surprised such drastic action is being considered.

Share this post


Link to post
Share on other sites
Craigjw    405

this is a big tl-dr, but you might get the jist of it.

I've read the bug reports that are listed above and that's about it.  I don't fully understand the mechanics of how heat exchange currently works.  But, throughout various play-throughs, I've experienced the bug and it has led to a massive amount of frustration.

Normally what happens is that I get to late game and start creating heat harvesting machines for meteor debris or magma(igneous).  I spend a few hundred cycles making a couple of machines, making sure they work.  A while later, I discover that I have super heated igneous being dumped right in the centre of my colony and super heated regolith being dumped into my storage area, loaders and other equipment starts breaking left right and centre.  I then spend the next 1000+ cycles fixing and debugging stuff only to find that in order for my cooling systems to work while off-screen, is if they are completely disassembled and made larger to include the conveyor bridges due to offscreen conveyor heat exchange, but I can't do this, because I don't have the room, so this play-through is basically a write-off.

My next play through, I make things bigger, but this time, it does work slightly better, but now I have a massive amount of lag, which renders the game unplayable due to the sheer number of extra conveyors that I have had to build to account for off-screen conveyor heat exchange and these conveyors just  suck the life from my game.

Share this post


Link to post
Share on other sites
SharraShimada    681
14 hours ago, Craigjw said:

Now that they released new content in the form of automation circuit's, do you think that they will spend time fixing the newly introduced bugs or the existing bugs?

Both, because KLEI ist not "that one guy, doing everything", but many people doing different things. And someone is doomed with the task to wirte a new conveyor code. The others can do every thing else in the same time. 

Share this post


Link to post
Share on other sites
Craigjw    405

This bug has been around for over 2 years, it deserves some attention, more so than new content, as new content isn't game breaking, where as this conveyor heat exchange bug IS game breaking.  New content only adds to the workload of the bug fixers, as they want the new content fixed so that they can showcase it, which inevitably takes away effort which could be used to fix game breaking bugs.

don't get me wrong, I am all for new content, just the conveyor bug is a bigger issue.

Share this post


Link to post
Share on other sites
Saturnus    3549

Off screen conveyor behaviour is certainly one of many bugs that prevents my from doing late game set ups since when I can't rely on the game behaving properly then I'm not really enjoying making advanced set ups just to see them fail because of a bug in the game, and not something that is wrong with the set up.

Share this post


Link to post
Share on other sites
Craigjw    405

My sentiments also.  Early game is a more of a chore for me, I play to see what contraptions I can come up with late game, but this is currently borked for me, mostly due to conveyor bugs.

Share this post


Link to post
Share on other sites
bobucles    368

I don't see any legitimate reason why the internal game sim state is modified by the screen drawing process. Screen drawing should be strictly an output of the existing game state. Computers tend to be pretty good at object permanence and don't forget things once they're off screen.

There is a fog of war in ONI, and anything inside the fog of war is suspended. Maybe the glitch is related to that? Items on the conveyor may be obeying janky fog of war rules, where if they can't be seen they don't exist. Or something like that. Even so, changing the rules for what is and isn't visible is a pretty dangerous thing to do for a game that has such a high reliance on its sim physics. 

Share this post


Link to post
Share on other sites
Craigjw    405
4 hours ago, bobucles said:

I don't see any legitimate reason why the internal game sim state is modified by the screen drawing process. Screen drawing should be strictly an output of the existing game state. Computers tend to be pretty good at object permanence and don't forget things once they're off screen.

There is a fog of war in ONI, and anything inside the fog of war is suspended. Maybe the glitch is related to that? Items on the conveyor may be obeying janky fog of war rules, where if they can't be seen they don't exist. Or something like that. Even so, changing the rules for what is and isn't visible is a pretty dangerous thing to do for a game that has such a high reliance on its sim physics. 

This is a very real and legitimate bug.  Please read the bug reports, two of them are listed above, there are more relating to how the off-screen heat exchange works, but I don't know how to find them.

It's called Occlusion culling, the process where things are processed differently when off-screen, it primarily is used for decreasing rendering, but it is also used for cutting down the processing cycles consumed per frame by objects off-screen.  Instead of processing an object once every tick, it's processed once every 5 ticks instead.  I don't know how ONI handles this, it's just an example.

Ideally, things should process the same off-screen as they do on-screen, however for conveyor heat exchange, it does not.

Share this post


Link to post
Share on other sites