Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

Apostolos

Help regenerating ruins

Recommended Posts

Apostolos    2

I have a crash problem entering the ruins. It keeps saying something about fail to load file [cave1_2_4] or something.  I have a feeling I know what is happening.  First off I am making a manual backup of my 219740 folder.  If things go to hell, I am restoring the older folder and trying again.  This has worked for dozens of attempts and suddenly it is now crashing.

My first question is if this folder is the ONLY place where files are saved, stored, or referenced in any way shape of form for the game?  If not, where would any other reference exist for world saves?  Next, is there any way to force the game to just regenerate a new ruins?

I have seen one Mod reply to someone else's issue with deleting the profile file.  My thing is, deleting the world and save file is not an option. I don't care about the ruins map itself, so if there is a way to just regenerate it or lacking that a way to manually edit the world save so there is no pointer to the cave 1_2_4 file that would work as well.

Share this post


Link to post
Share on other sites
Apostolos    2

Well it has taken me a bit, but I think I finally figured this out.  So.. just fyi in case anyone else runs into this:

#1) The problem I think I ran into was that when I would copy the files in the 219740 folder, I still had the game open. (even though I was at the main screen) I am thinking this caused some corruption when I copied files back INTO said folder while the game was running.

#2) Once I figured out the corruption issue in #1, I just went to a different sink hole. After generating level 1, finding the ruins, and then generating level 2, I simply copied cave 2_2_4 and renamed the copy 1_2_4.  This made the game happy and allowed me to go down into the ruins in the first cave. I am assuming when I go back to cave 2 it will have the exact same layout but that is fine.

Share this post


Link to post
Share on other sites