Sign in to follow this  
F1Ne5TGamer

Error Occurred Please Restart Game

Recommended Posts

F1Ne5TGamer    1

So I downloaded the update and now my game says that an error has occurred and it needs to restart. I have looked at the logs, but I don't know what is causing the issue. Does anyone have some suggestions? I have like 500+ hours in this save and I would not like to lose it. 

output_log.txt

Edited by F1Ne5TGamer

Share this post


Link to post
Share on other sites
Zarquan    777
1 hour ago, F1Ne5TGamer said:

So I downloaded the update and now my game says that an error has occurred and it needs to restart. I have looked at the logs, but I don't know what is causing the issue. Does anyone have some suggestions? I have like 500+ hours in this save and I would not like to lose it. 

output_log.txt

I believe this is probably due to the latest patch breaking mods.  Finding the broken mod can be tricky.

Edited by Zarquan

Share this post


Link to post
Share on other sites
Ktoblin    5

"Rethrow as Exception: Error in MethaneGeneratorComplete.BuildingConduitEndpoints.OnSpawn"

May be that?

 

Share this post


Link to post
Share on other sites
F1Ne5TGamer    1
13 minutes ago, Ktoblin said:

"Rethrow as Exception: Error in MethaneGeneratorComplete.BuildingConduitEndpoints.OnSpawn"

May be that?

 

Ya, but I don't know what mod that is and I don't know how to find which one that is. 

Share this post


Link to post
Share on other sites
KittenIsAGeek    1,441

Do you have a mod that affects natural gas generators?  That would be my first guess.  Maybe post your save and see if someone else can load it?

Share this post


Link to post
Share on other sites
yoakenashi    489

I have also seen this issue:

[06:12:55.889] [1] [INFO] Error occurred with mods active. Disabling all mods (unless dev mods active).
NullReferenceException
  at (wrapper managed-to-native) UnityEngine.Component.get_gameObject(UnityEngine.Component)
  at UtilityNetworkManager`2[NetworkType,ItemType].AddToNetworks (System.Int32 cell, System.Object item, System.Boolean is_endpoint) [0x00091] in <cbde240e6e6140549ffbb38d5b681bb2>:0
  at Wire.OnSpawn () [0x00016] in <cbde240e6e6140549ffbb38d5b681bb2>:0
  at KMonoBehaviour.Spawn () [0x0005d] in <0074c3e353f546b9ae37fd8d309a2b1e>:0
Rethrow as Exception: Error in WireRefinedComplete.Wire.OnSpawn
  at KMonoBehaviour.Spawn () [0x000a6] in <0074c3e353f546b9ae37fd8d309a2b1e>:0
  at KMonoBehaviour.Start () [0x00008] in <0074c3e353f546b9ae37fd8d309a2b1e>:0
 
(Filename: <cbde240e6e6140549ffbb38d5b681bb2> Line: 0)

This happened when I was replacing a wire with refined wire (aka, a conductive wire) while deconstructing the wire.

Full log is attached:
output_log.txt

I think it is related to this recent change:

 

 

Edited by yoakenashi
Added full log

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this