Hello friends! Work continues on the hotfix. We've had to upgrade a few more components of the game engine in order to move forward with MacOS compatibility, as well as fixing an inconsistency introduced in the modding API by the new Unity version. If you run the game on MacOS (any version), we would really appreciate if you could give the test branch a play. Modders should try recompiling their mods against the new version (details below) as well. Thank you so much! Hotfix Changes: