Recommended Posts

noric    41

its not using the daily report numbers. It checks at a set interval and logs any active generators. Hamster wheels seem too need a consumer, maybe all generators do. You can always use a light bulb to consume. Brass tax your going to produce a lot more than 240,000. Could be worse though, look at "down the hatch" its 100x the tool tip. Is there even 10,000 T of ore on a map to refine?

Share this post


Link to post
Share on other sites
Lilalaunekuh    847
19 minutes ago, noric said:

"down the hatch" its 100x the tool tip. Is there even 10,000 T of ore on a map to refine?

Fail, just noticed re-read my output logfile:

Achieved:False, Metals Excreted: 3788.7197265625 / 10000000

=> I would need ~13 333t of metal ore to complete this.

[So I need an automated rocket to do this, or save scum the care packages for a very long time ...]

Share this post


Link to post
Share on other sites
Cairath    856
Posted (edited)

Small experiments (click the img so it gets un-squeezed)

88405e087e.png

 

a log for one achievement-check-update:

[12:11:08.845] [1] [INFO] Starting update at 08/07/2019 14:11:08. Starting AmountProduced: 7302
[12:11:08.845] [1] [INFO] Ending update at 08/07/2019 14:11:08. Ending AmountProduced: 8258

(top left)
[12:11:08.845] [1] [INFO] Building: ManualGenerator  Joules available: 0 PosX: 151.5 PosY: 180.01

(top middle)
[12:11:08.845] [1] [INFO] Building: ManualGenerator  Joules available: 0 PosX: 154.5 PosY: 180.01
[12:11:08.845] [1] [INFO] Building: PowerTransformerSmall  Joules available: 200 PosX: 156.5 PosY: 180.01

(top right)
[12:11:08.846] [1] [INFO] Building: ManualGenerator  Joules available: 0 PosX: 160.5 PosY: 180.01
[12:11:08.846] [1] [INFO] Building: PowerTransformerSmall  Joules available: 200 PosX: 162.5 PosY: 180.01

(bottom left)
[12:11:08.846] [1] [INFO] Building: ManualGenerator  Joules available: 78 PosX: 152.5 PosY: 176.01

(bottom right)
[12:11:08.846] [1] [INFO] Building: ManualGenerator  Joules available: 78 PosX: 160.5 PosY: 176.01
[12:11:08.846] [1] [INFO] Building: PowerTransformerSmall  Joules available: 200 PosX: 163.5 PosY: 176.01
[12:11:08.846] [1] [INFO] Building: PowerTransformerSmall  Joules available: 200 PosX: 165.5 PosY: 176.01

 

So it works. Buuuuuut keep in mind these are in Joules, and the achievement wants kJ. The mod that prints values is awfully wrong by a few zeros. 

Now, there comes a problem of why my 1000W transformer shows as 200J and not 1000!? This is a problem indeed - energy is handled at a different frequency than achievement updates, and while it makes sense for the energy calculations it absolutely doesn't work with the achievement progress updates.

Update times at 1x speed:

14:25:18

14:24:30

14:24:42

14:24:54

.... and every 12 seconds

 

Update times at 3x speed:

14:26:41

14:26:45

14:26:49 and so on every 4 seconds

Regardless of the speed, it's always 200J for the power transformer and this is where it gets ugly - most of the energy is unaccounted for, especially if running on the slow speed.

 

@Ipsquiggle sorry to bother you again -- but since I've spent time figuring it out maybe this will help :)

 

As for the Down the Hatch achievement it genuinely looks like someone mixed up the units and added a *1000 by accident in the Success check of the achievement.

Edited by Cairath
  • Like 1
  • Thanks 3

Share this post


Link to post
Share on other sites
badgamer123    100

for hatch achievement we need someone get a mod geyser to raining metal ore ...

37 minutes ago, Cairath said:

 

So it works. Buuuuuut keep in mind these are in Joules, and the achievement wants kJ. The mod that prints values is awfully wrong by a few zeros. 

Now, there comes a problem of why my 1000W transformer shows as 200J and not 1000!? This is a problem indeed - energy is handled at a different frequency than achievement updates, and while it makes sense for the energy calculations it absolutely doesn't work with the achievement progress updates.

 

thx for the test... in short we need to make 240000000W of energy?that a bit long but at least the thing is not bugged....we really need a in game achievement tracker klei

Share this post


Link to post
Share on other sites
Cairath    856
1 minute ago, badgamer123 said:

for hatch achievement we need someone get a mod geyser to raining metal ore ...

thx for the test... in short we need to make 240000000W of energy?that a bit long but at least the thing is not bugged....we really need a in game achievement tracker klei

Or just give them a while to fix it. I'm sure they will.

Share this post


Link to post
Share on other sites
badgamer123    100

The super man-power is doable like a achievement (i guess 300 -500 cycle with CPU solar power will do),the hatch one is surely bugged lol .

Share this post


Link to post
Share on other sites
Lilalaunekuh    847
1 hour ago, badgamer123 said:

the hatch one is surely bugged lol .

Ok, I just started to ranch smooth hatches and started to do some math with a scarry result:

Considering a 2 hatch breeding and 8 hatch working stable with full uptime and no fluctuations. [My current setup.]

=> It takes over 1 month of real life time playing on 3x game speed for my 10 smooth hatches to produce enough refined metal ...

  • Haha 2

Share this post


Link to post
Share on other sites
badgamer123    100
33 minutes ago, Lilalaunekuh said:

Ok, I just started to ranch smooth hatches and started to do some math with a scarry result:

Considering a 2 hatch breeding and 8 hatch working stable with full uptime and no fluctuations. [My current setup.]

=> It takes over 1 month of real life time playing on 3x game speed for my 10 smooth hatches to produce enough refined metal ...

rotf,that surely an achievement.

  • Haha 2

Share this post


Link to post
Share on other sites
Junksteel    635
1 hour ago, Lilalaunekuh said:

=> It takes over 1 month of real life time playing on 3x game speed for my 10 smooth hatches to produce enough refined metal ...

EZ. You just need to drop school, quit your job and get a divorce. 

Share this post


Link to post
Share on other sites
Red Shark    103
13 hours ago, Cairath said:

That's actually incorrect, and Manual Generators are counted. Everything with Generator component is, bar the explicit list of buildings excluded for the achievement. Dig deeper next time ;)

However the way the checks are done... the manual generator has to be in use at the exact moment the check is being made, and there needs to be an enabled consumer on the network (batteries do not count).

Yeah, mea culpa here -- I saw that the achievement was checking the Energy Sim's list of "Generator"s, saw that "ManualGenerator" didn't extend "Generator" and completely forgot that *most* prefabs have multiple components. (Such as FilteredStorage and Storage)

Indeed, ManualGenerator has a corresponding "Generator" component, so it should be checked. Component-based architecture. D'oh.

And then, of course, to check this I had a dupe run a manual generator hooked up to a battery and nothing else, which as your experiment proved... doesn't actually count. (Double oops!)

Digging further into the code, "joulesAvailable" is what is tracked, and this primarily gets updated from... "GenerateJoules" and "ConsumeEnergy", the former of which is only available when the generator is running, and the latter of which is used by Transformers. (Which again, your experiment shows works for this just fine)

As to the values being wrong, the energy Sim updates once every 200ms aka, 5 times a second, while the achievement is checked once every 5 seconds. So every 5 seconds, a 1/5 second snapshot of energy is added. Or in other words, we're only getting 200 of the 5000 expected joules! That's 4% of the expected value! No wonder it accrues so slowly! Not sure why Klei didn't use the Report Manager here like they did for the Calories achievements (as this IS updated

I can't explain the 78 -- it should be 80 given the Manual Generator's 400 watt rating -- but it's close enough to the expected value that I think this is possibly due to rounding?

 

And then to top everything off, I missed a "divide by 1000" so my mod is displaying joules instead of kilojoules. Will update that soon.

TL;DR - this achievement is weirdly unique, and probably would be considered bugged.

  • Like 1

Share this post


Link to post
Share on other sites
Cairath    856
1 minute ago, Red Shark said:

Not sure why Klei didn't use the Report Manager here

Because it does not save what produced that energy - at least from what I gathered from a quick peek

Share this post


Link to post
Share on other sites
In His Cups    1
Quote
  • "Oxygen Not Occluded" and "Down the Hatch" initiatives now track the correct values (they were looking for 1000x too much oxygen/metal!)

From the patch notes about an hour ago...Thank goodness.

Share this post


Link to post
Share on other sites
Red Shark    103
Posted (edited)
51 minutes ago, Cairath said:

Because it does not save what produced that energy - at least from what I gathered from a quick peek

Ah, fair enough. It's saving it with a name for the report, but you can't look up past values that way.

Edit: I've updated my Achievement Tracker mod. Should now accurately reflect Super Sustainable & have the updated values for Down the Hatch / Oxygen not Occluded.

Bonus -- it also tells you whether or not your colony is ineligible due to Debug or Sandbox mode!

https://steamcommunity.com/sharedfiles/filedetails/?id=1825510169

Edited by Red Shark
Adding postscript

Share this post


Link to post
Share on other sites

It's actually even worse -- the first schedule OnSpawn is 5s, but the interval between updates (see CheckAchievements) is 12s. Either way, it's totally broken.

Share this post


Link to post
Share on other sites
badgamer123    100
6 hours ago, Red Shark said:

Ah, fair enough. It's saving it with a name for the report, but you can't look up past values that way.

Edit: I've updated my Achievement Tracker mod. Should now accurately reflect Super Sustainable & have the updated values for Down the Hatch / Oxygen not Occluded.

Bonus -- it also tells you whether or not your colony is ineligible due to Debug or Sandbox mode!

https://steamcommunity.com/sharedfiles/filedetails/?id=1825510169

I think there is a small problem in the mod,i got the oxygen vent as soon as i update and load the save today(the mod indicated false,super sustainable still showing funny result.
maybe it only work with new game?
[05:03:12.908] [1] [INFO] Super Sustainable:
[05:03:12.908] [1] [INFO] Can Achieve:True, Energy Generated: 1406687 / 240000
[05:03:12.908] [1] [INFO] -----
[05:03:12.908] [1] [INFO] Totally Tubular:
[05:03:12.908] [1] [INFO] Achieved:False, Distance Traveled: 0 / 10000
[05:03:12.908] [1] [INFO] -----
[05:03:12.908] [1] [INFO] Oxygen Not Occluded:
[05:03:12.908] [1] [INFO] Achieved:False, Oxygen Vented: 7731.37451171875 / 1000000

Share this post


Link to post
Share on other sites
Red Shark    103
3 hours ago, badgamer123 said:

I think there is a small problem in the mod,i got the oxygen vent as soon as i update and load the save today(the mod indicated false,super sustainable still showing funny result.
maybe it only work with new game?
[05:03:12.908] [1] [INFO] Super Sustainable:
[05:03:12.908] [1] [INFO] Can Achieve:True, Energy Generated: 1406687 / 240000
[05:03:12.908] [1] [INFO] -----
[05:03:12.908] [1] [INFO] Totally Tubular:
[05:03:12.908] [1] [INFO] Achieved:False, Distance Traveled: 0 / 10000
[05:03:12.908] [1] [INFO] -----
[05:03:12.908] [1] [INFO] Oxygen Not Occluded:
[05:03:12.908] [1] [INFO] Achieved:False, Oxygen Vented: 7731.37451171875 / 1000000

Hmm. Are you sure you have the latest version of the mod? That's the old-style output format.

Oxygen Not Occluded was dropped from 100,000 to 1000, which 7731 is greater than 1000, so I would have expected it to unlock immediately.

Share this post


Link to post
Share on other sites
badgamer123    100
Posted (edited)

I load it again and save
[12:55:51.499] [1] [INFO] Carnivore:
[12:55:51.499] [1] [INFO] Achieved:True, Meats Eaten: 856075.904 / 400000
[12:55:51.499] [1] [INFO] -----
[12:55:51.499] [1] [INFO] Locavore:
[12:55:51.499] [1] [INFO] Threshold Reached:True, Calories Consumed: 1105120.128 / 400000
[12:55:51.499] [1] [INFO] -----
[12:55:51.500] [1] [INFO] Super Sustainable:
[12:55:51.500] [1] [INFO] Can Achieve:True, Energy Generated: 1448276 / 240000
[12:55:51.500] [1] [INFO] -----
[12:55:51.500] [1] [INFO] Totally Tubular:
[12:55:51.500] [1] [INFO] Achieved:False, Distance Traveled: 0 / 10000
[12:55:51.500] [1] [INFO] -----
[12:55:51.501] [1] [INFO] Oxygen Not Occluded:
[12:55:51.502] [1] [INFO] Achieved:False, Oxygen Vented: 8241.625 / 1000000
[12:55:51.502] [1] [INFO] -----
[12:55:51.503] [1] [INFO] Tune Up For What:
[12:55:51.503] [1] [INFO] Achieved:False, Tune Ups: 0 / 100
[12:55:51.503] [1] [INFO] -----
[12:55:51.504] [1] [INFO] Pulling Back The Veil:
[12:55:51.504] [1] [INFO] Achieved:False, Fog of War Pierced: 17.620849609375% / 80.0000011920929%
[12:55:51.504] [1] [INFO] -----
[12:55:51.504] [1] [INFO] Down the Hatch:
[12:55:51.504] [1] [INFO] Achieved:False, Metals Excreted: 0 / 10000000

it seem uninstall it fix the problem
after reinstall the mod
[13:02:45.217] [1] [INFO] Carnivore:
[13:02:45.217] [1] [INFO] Imperative Successful!
[13:02:45.217] [1] [INFO] Meats Eaten: 856075.904 / 400000
[13:02:45.217] [1] [INFO] -----
[13:02:45.218] [1] [INFO] Locavore:
[13:02:45.218] [1] [INFO] Imperative Successful!
[13:02:45.218] [1] [INFO] Calories Consumed: 1105120.128 / 400000
[13:02:45.218] [1] [INFO] -----
[13:02:45.218] [1] [INFO] Super Sustainable:
[13:02:45.218] [1] [INFO] Can Achieve:True, Energy Generated: 1448.675875 / 240000
[13:02:45.218] [1] [INFO] -----
[13:02:45.219] [1] [INFO] Totally Tubular:
[13:02:45.219] [1] [INFO] Eligible
[13:02:45.219] [1] [INFO] Distance Traveled: 0 / 10000
[13:02:45.219] [1] [INFO] -----
[13:02:45.220] [1] [INFO] Oxygen Not Occluded:
[13:02:45.220] [1] [INFO] Imperative Successful!
[13:02:45.220] [1] [INFO] Oxygen Vented: 8248.625 / 1000
[13:02:45.220] [1] [INFO] -----
[13:02:45.221] [1] [INFO] Finely Tuned Machine:
[13:02:45.221] [1] [INFO] Eligible
[13:02:45.221] [1] [INFO] Tune Ups: 0 / 100
[13:02:45.222] [1] [INFO] -----
[13:02:45.222] [1] [INFO] Pulling Back The Veil:
[13:02:45.222] [1] [INFO] Eligible
[13:02:45.222] [1] [INFO] Fog of War Pierced: 17.620849609375% / 80.0000011920929%
[13:02:45.222] [1] [INFO] -----
[13:02:45.223] [1] [INFO] Down the Hatch:
[13:02:45.223] [1] [INFO] Eligible
[13:02:45.223] [1] [INFO] Achieved:False, Metals Excreted: 0 / 10000

the mod updater still bugged a bit

5 hours ago, Cairath said:

@badgamer123 you could try https://steamcommunity.com/sharedfiles/filedetails/?id=1828274492 , although  sustainable power is a bit bork at the moment and shows as failed until you set up any electricity

ok it shxt I only got 1% of it with 150 cycle.........i need to find more power and something to burn.

Edited by badgamer123

Share this post


Link to post
Share on other sites
CDoroFF    73
On 07/08/2019 at 1:03 PM, Dextrome said:

I dunno... seems pretty logical to me that achievements would be disabled in debug mode lol

That seems logical for me too. lol, seems like you didnt read my comment b4 answering.

On 07/08/2019 at 1:03 PM, Dextrome said:

also they don't disable your achievements by default

But they did.The ability to use debug mode was enabled long time ago (1year or smth), how should I know that this fact prevents me from achievements gaining even if I don't use debug? And what about mod's? If i make a mod which grants 400kcal BBQ from start, will i gain Crnivore? 

 

On 07/08/2019 at 1:03 PM, Dextrome said:

it's only once you use a debug command that achievements won't work anymore for that save file (which seems fair to me). 

Wrong. Just having the debug_enabled.txt file in the game folder is enough to prevent you from achievement gaining. That is what happens to me exactly.

On 07/08/2019 at 1:03 PM, Dextrome said:

But I just disabled debug mode entirely to make sure I don't accidentally press any debug command hot keys ;)

That what I made too. But one week after launch, when (on cycle 120+) I realized, that bugged achievements still donot work for me, but work to others.

  • Like 1
  • Confused 1

Share this post


Link to post
Share on other sites
Cairath    856
9 minutes ago, CDoroFF said:

Wrong. Just having the debug_enabled.txt file in the game folder is enough to prevent you from achievement gaining. That is what happens to me exactly.

I have confirmed that just having the file does not disable your eligibility for achievements. Only actually using ANY of the debug commands or keybinds (which to be fair is easy to do by accident if you have it enabled)

  • Like 2

Share this post


Link to post
Share on other sites
Junksteel    635
7 minutes ago, CDoroFF said:

 

Wrong. Just having the debug_enabled.txt file in the game folder is enough to prevent you from achievement gaining. That is what happens to me exactly.

 

I believe this isn't wrong.

I tested it: I activated debug mode and just deactivated it right after to see if I would gain the achievment of entering oil biome for the first time. It failed.

Then I just reloaded the last save before activating debug mode. I got the achievment right away.

  • Like 1

Share this post


Link to post
Share on other sites
Cairath    856

Basically using anything debug related flips the 'debugWasUsed' flag irreversibly. 

  • Like 2

Share this post


Link to post
Share on other sites
CDoroFF    73
24 minutes ago, Junksteel said:

I believe this isn't wrong.

I tested it: I activated debug mode and just deactivated it right after to see if I would gain the achievment of entering oil biome for the first time. It failed.

Then I just reloaded the last save before activating debug mode. I got the achievment right away.

Are you talikng about steam achievemnts? Because I have received ingame achievements.

Share this post


Link to post
Share on other sites
Junksteel    635
Just now, CDoroFF said:

Are you talikng about steam achievemnts?

Yes! Steam achievments!

Share this post


Link to post
Share on other sites
CDoroFF    73
Posted (edited)
50 minutes ago, Cairath said:

Basically using anything debug related flips the 'debugWasUsed' flag irreversibly. 

Checked my savefiles with hex editor: in each file i see the following line
 debugWasUsed 03 13 00 00
In the last one, where everything works fine I have got the same line too. Moreover, this file have never been loaded on the system with debug mode enabled. May be my bugged savefile was marked at the moment when it was not actually fixed? I have strated bugged colony few minutes after release.It could be more dissapointing.

Edited by CDoroFF

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now