Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

Lexfati13

Don't Starve won't launch in Linux

Recommended Posts

Lexfati13    3

Please choose a category
[Crash]
Game doesn't start


Platform
Linux (Kubuntu 18.04.2)

Do you use mods?
no


Version Number
Unknown - game won't start

 
Issue title
 Don't starve won't launch on Linux (Ubuntu)

Steps to reproduce
1) Open steam
2)  Launch game from Steam (Select Don't Starve in Libary and click Play icon)


Describe your issue
 
*Type a detailled description what the bug is and how/when it happens:
On Linux through Steam, Don't Starve won't launch.

I've attempted:
1) Library -> Don't Starve -> Properties -> Local Files -> Verify Integrity of game files
2) Uninstalling and reinstalling
3) creating a new "Steam Library Folder" and installing to the new folder.
4) deleting ~/.klei and relaunching.  No new donotstarve directory or logfile created on relaunch.
5) running ./dontstarve from command line in install directory.  This returned error that 'libcurl-gnutls.so.4' could not be found.
6) Attempted adding installing packages via "apt-get install libcurl4-gnutls-dev:i386 libgcc1 screen" per thread:
https://steamcommunity.com/app/219740/discussions/2/41973820401347178/
This got past the missing libcurl-gnutls.so.4 file error, but the game still won't open or produce a startup log.


Searching Steam's forums, 4 other users reporting same issue on Linux (ubuntu based) since last update:
https://steamcommunity.com/app/219740/discussions/2/1768133742960620786/


Today was the first time I've attempted to start the game in several months, so I cannot personally confirm the issue is related to last update.


I cannot locate a '~/.klei/DoNotStarve/log.txt' file or a '.mdmp' in my bin directory

Share this post


Link to post
Share on other sites

I do have the same problem.

Linux Ubuntu Mate (18.04.2)

no mods

I do have a log.txt, however its content is unhelpful. It consists of a single line:

[00:00:00]: Starting up

Trying to run manually the scripts in the dont_starve directory didn't help:

$ ./dontstarve

szCmd: /bin/sh -c '"/home/patrice/.steam/steam.sh" steam://run/219740' &
Updates 0
[00:00:00]: Shutting down

Running Steam on ubuntu 18.04 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!

 

 

Share this post


Link to post
Share on other sites
SQNoname    13

Same here, Ubuntu Studio 18.04, log.txt equally empty.

Starting from the command line gives the following message:

 

./dontstarve_steam: error while loading shared libraries: libcurl-gnutls.so.4: cannot open shared object file: No such file or directory

 

Share this post


Link to post
Share on other sites
asar    1

I'm having the same error about libcurl-gnutls.so.4 missing. I tried to install the library itself but to no avail. After the installation of the library it reports the same as Joal ban Kluane mentioned above.

Share this post


Link to post
Share on other sites
Delk    1

I get the same thing. libcurl-gnutls.so.4 exists under /home/$USER/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/ (along with a 64-bit version under the corresponding directory for x86-64). I'm not sure if it's supposed to be picked up from there but apparently it's not.

Running ldd on the dontstarve_steam binary gives the following:

$ ldd dontstarve_steam 
	linux-gate.so.1 (0xf7eed000)
	libGL.so.1 => /lib/libGL.so.1 (0xf7e4e000)
	libSDL2-2.0.so.0 => ./lib32/libSDL2-2.0.so.0 (0xf7d70000)
	libcurl-gnutls.so.4 => not found
	librt.so.1 => /lib/librt.so.1 (0xf7d64000)
	libpthread.so.0 => /lib/libpthread.so.0 (0xf7d42000)
	libfmodevent.so => ./lib32/libfmodevent.so (0xf7cb5000)
	libfmodex.so => ./lib32/libfmodex.so (0xf7aff000)
	libsteam_api.so => ./lib32/libsteam_api.so (0xf7aec000)
	libstdc++.so.6 => /lib/libstdc++.so.6 (0xf7958000)
	libm.so.6 => /lib/libm.so.6 (0xf7885000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xf7865000)
	libc.so.6 => /lib/libc.so.6 (0xf76bb000)
	libGLX.so.0 => /lib/libGLX.so.0 (0xf7697000)
	libX11.so.6 => /lib/libX11.so.6 (0xf7540000)
	libXext.so.6 => /lib/libXext.so.6 (0xf752a000)
	libGLdispatch.so.0 => /lib/libGLdispatch.so.0 (0xf74c8000)
	libdl.so.2 => /lib/libdl.so.2 (0xf74c2000)
	/lib/ld-linux.so.2 (0xf7eee000)
	libfmodex-4.44.64.so => ./lib32/libfmodex-4.44.64.so (0xf730c000)
	libxcb.so.1 => /lib/libxcb.so.1 (0xf72dd000)
	libXau.so.6 => /lib/libXau.so.6 (0xf72d7000)

I'm not sure if any of this is relevant but I thought I'd add it just in case it might be.

I'm running Fedora instead of Ubuntu, which I guess isn't officially supported, but if other people running Ubuntu are seeing the same, it doesn't sound distro-specific.

Share this post


Link to post
Share on other sites
bizziboi    1,770

I'm testing a fix for this, which I assume will go live later today.

Share this post


Link to post
Share on other sites
asar    1

The game just updated and it manages to start! Thanks for the quick fix!

Share this post


Link to post
Share on other sites