Sign in to follow this  
Guy Page

Character Mod Crashing [With Log]

Recommended Posts

Guy Page    0

I was making a custom character mod for DST following the steps on this link http://dont-starve.surge.sh/

Everything was going fine until i got to the "Compiling Art" topic, I did everything he said and when I opened the game to test the mod the game crashed everytime i clicked on "Host Game" or "Mods", I dont have any other mods for DST so I know the problem comes from the one I'm making, I didn't wanna start making the mod all over again knowing that the same thing could happen and I really wanted to play with my mod.

here is the game log:

[00:00:00]:
System Memory:
    Memory Load: 50%
    Available Physical Memory: 4025m/8154m
    Available Page File: 3704m/9434m
    Available Virtual Memory: 3946m/4095m
    Available Extended Virtual Memory: 0m
[00:00:00]:
Process Memory:
    Peak Working Set Size: 31m
    Working Set Size: 31m
    Quota Peak Page Pool Usage: 264k
    Quota Page Pool Usage: 262k
    Quota Peak Non Paged Pool Usage:19k
    Quota Non Paged Pool Usage: 19k
    Page File Usage: 6m
    Peak Page File Usage: 6m
[00:00:00]: PersistRootStorage is now APP:Klei//DoNotStarveTogether/
[00:00:00]: Starting Up
[00:00:00]: Version: 305472
[00:00:00]: Current time: Sun Feb 17 17:34:42 2019

[00:00:00]: Don't Starve Together: 305472 WIN32_STEAM
[00:00:00]: Build Date: 3753
[00:00:00]: Parsing command line
[00:00:00]: Command Line Arguments:
[00:00:00]: Initializing distribution platform
[00:00:00]: Initializing Minidump handler
[00:00:00]: ....Done
[00:00:00]: Steam AppBuildID: 3503077
[00:00:00]: ....Done
[00:00:00]: PersistUserStorage is now APP:Klei//DoNotStarveTogether/
[00:00:00]: Fixing DPI
[00:00:00]: ...Done
[00:00:00]: THREAD - started 'GAClient' (892)
[00:00:00]: CurlRequestManager::ClientThread::Main()
[00:00:00]: Mounting file system databundles/klump.zip successful.
[00:00:00]: Mounting file system databundles/shaders.zip successful.
[00:00:00]: Mounting file system databundles/fonts.zip successful.
[00:00:00]: Mounting file system databundles/anim_dynamic.zip successful.
[00:00:00]: Mounting file system databundles/bigportraits.zip successful.
[00:00:00]: Mounting file system databundles/images.zip successful.
[00:00:00]: Mounting file system databundles/scripts.zip successful.
[00:00:02]: ProfileIndex:5.17
[00:00:02]: [Connect] PendingConnection::Reset(true)
[00:00:02]: Platform: 1
[00:00:02]: THREAD - started 'Ping Job Thread' (9656)
[00:00:02]: Network tick rate: U=15(2), D=0
[00:00:02]: Authorized application C:\Program Files (x86)\Steam\steamapps\common\Don't Starve Together\bin\dontstarve_steam.exe is enabled in the firewall.
[00:00:02]: WindowsFirewall - Application already authorized
[00:00:02]: THREAD - started 'StreamInput' (1380)
[00:00:02]: loaded ping_cache
[00:00:02]: Offline user ID: OU_76561198225107968
[00:00:02]: SteamID: 76561198225107968
[00:00:02]: Failed to communicate with routing cluster 'ggru'.
[00:00:02]: Failed to communicate with routing cluster 'ghel'.
[00:00:02]: HardwareStats:
  OS                        
    name                      Microsoft Windows 10 Home Single Language
    version                   10.0.17134
    architecture              64 bits
    platformSpecific          SP 0.0
  CPU                       
    numCores                  2
    features                  SSE,SSE2,SSE3,SSSE3,SSE41,SSE42,AVX
    name                      Intel(R) Core(TM) i5-3230M CPU @ 2.60GHz
    manufacturer              GenuineIntel
    clockSpeed                2601
  RAM                       
    megsOfRam                 8192
  GPU                       
    name                      NVIDIA GeForce GT 640M
    driverDate                20170501000000.000000-000
    megsOfRam                 1024
    refreshRate               59
    videoModeDescription      1366 x 768 x 4294967296 cores
    driverVersion             22.21.13.8205

[00:00:02]: cGame::InitializeOnMainThread
[00:00:02]: WindowManager::Initialize
[00:00:02]: CreateWindow: Requesting 1366,768 - 5/6/5 - -1/-1/-1 - 0
[00:00:02]: Failed to communicate with routing cluster 'iad'.
[00:00:02]: CreateEGLContext: 12 configs found
[00:00:02]:      0: 8/8/8 -  0/ 0/ 0 - 0
[00:00:02]:      1: 8/8/8 -  0/16/ 0 - 0
[00:00:02]:      2: 8/8/8 -  0/24/ 0 - 0
[00:00:02]:      3: 8/8/8 -  0/24/ 8 - 0
[00:00:02]:      4: 5/5/5 -  0/ 0/ 0 - 0
[00:00:02]:      5: 5/5/5 -  0/16/ 0 - 0
[00:00:02]:      6: 5/5/5 -  0/24/ 0 - 0
[00:00:02]:      7: 5/5/5 -  0/24/ 8 - 0
[00:00:02]:      8: 8/8/8 -  8/ 0/ 0 - 0
[00:00:02]:      9: 8/8/8 -  8/16/ 0 - 0
[00:00:02]:     10: 8/8/8 -  8/24/ 0 - 0
[00:00:02]:     11: 8/8/8 -  8/24/ 8 - 0
[00:00:02]: WindowManager::SetFullscreen(0, 1366, 768, 60)
[00:00:02]: GLInfo
[00:00:02]: ~~~~~~
[00:00:02]: GL_VENDOR: Google Inc.
[00:00:02]: GL_RENDERER: ANGLE (NVIDIA GeForce GT 640M)
[00:00:02]: GL_VERSION: OpenGL ES 2.0 (ANGLE 1.0.0.2249)
[00:00:02]: GL_SHADING_LANGUAGE_VERSION: OpenGL ES GLSL ES 1.00 (ANGLE 1.0.0.2249)
[00:00:02]: THREAD - started 'WindowsInputManager' (6700)
[00:00:02]: OpenGL extensions (19, 19):
[00:00:02]: GL_ANGLE_depth_texture
[00:00:02]: GL_ANGLE_framebuffer_blit
[00:00:02]: GL_ANGLE_framebuffer_multisample
[00:00:02]: GL_ANGLE_instanced_arrays
[00:00:02]: GL_ANGLE_pack_reverse_row_order
[00:00:02]: GL_ANGLE_texture_compression_dxt3
[00:00:02]: GL_ANGLE_texture_compression_dxt5
[00:00:02]: GL_ANGLE_texture_usage
[00:00:02]: GL_ANGLE_translated_shader_source
[00:00:02]: GL_EXT_read_format_bgra
[00:00:02]: GL_EXT_robustness
[00:00:02]: GL_EXT_texture_compression_dxt1
[00:00:02]: GL_EXT_texture_format_BGRA8888
[00:00:02]: GL_EXT_texture_storage
[00:00:02]: GL_OES_get_program_binary
[00:00:02]: GL_OES_packed_depth_stencil
[00:00:02]: GL_OES_rgb8_rgba8
[00:00:02]: GL_OES_standard_derivatives
[00:00:02]: GL_OES_texture_npot
[00:00:02]: GL_MAX_TEXTURE_SIZE = 16384
[00:00:02]: GL_MAX_TEXTURE_IMAGE_UNITS = 16
[00:00:02]: GL_MAX_RENDERBUFFER_SIZE = 16384
[00:00:02]: GL_MAX_VIEWPORT_DIMS = 16384, 16384
[00:00:02]: GL_MAX_VARYING_VECTORS = 10
[00:00:02]: GL_MAX_VERTEX_ATTRIBS = 16
[00:00:02]: GL_MAX_VERTEX_UNIFORM_VECTORS = 254
[00:00:02]: GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS = 4
[00:00:02]: GL_MAX_FRAGMENT_UNIFORM_VECTORS = 221
[00:00:02]: 4 compressed texture formats
[00:00:02]: texture format 0x83f0
[00:00:02]: texture format 0x83f1
[00:00:02]: texture format 0x83f2
[00:00:02]: texture format 0x83f3
[00:00:03]: Communications with routing cluster 'iad' established.
[00:00:04]: Ping measurement completed
[00:00:04]: Ping location: gru=46+4,scl=171+17/98+4,lim=189+18/128+4,iad=138+13,atl=149+14,ord=159+15/152+13,okc=166+16,lax=204+20/193+14,sea=207+20/201+13,lhr=242+24/210+13,fra=233+23/228+13,sgp=373+37/376+28
[00:00:04]: Renderer initialize: Okay
[00:00:05]: AnimManager initialize: Okay
[00:00:05]: Buffers initialize: Okay
[00:00:05]: cDontStarveGame::DoGameSpecificInitialize()
[00:00:05]: GameSpecific initialize: Okay
[00:00:05]: cGame::StartPlaying
[00:00:05]: LOADING LUA
[00:00:05]: DoLuaFile scripts/main.lua
[00:00:05]: DoLuaFile loading buffer scripts/main.lua
[00:00:05]:   taskgrouplist:    default    Together    
[00:00:05]:   taskgrouplist:    classic    Classic    
[00:00:05]:   taskgrouplist:    cave_default    Underground    
[00:00:05]:   taskgrouplist:    lavaarena_taskset    The Forge    
[00:00:05]:   taskgrouplist:    quagmire_taskset    The Gorge    
[00:00:05]: running main.lua
    
[00:00:05]: loaded modindex    
[00:00:05]: ModIndex: Beginning normal load sequence.
    
[00:00:06]: Event data unavailable: lavaarena_event_server/lavaarena_achievement_quest_defs
[00:00:08]: LOADING LUA SUCCESS
[00:00:08]: PlayerDeaths loaded morgue    6252    
[00:00:08]: PlayerHistory loaded player_history (v2) len:6628    
[00:00:08]: ServerPreferences loaded server_preferences    2    
[00:00:08]: bloom_enabled    true    
[00:00:08]: loaded saveindex    
[00:00:08]: OnFilesLoaded()    
[00:00:08]: OnUpdatePurchaseStateComplete    
[00:00:08]: Klump load on boot started.    
[00:00:08]: Klump files loaded:     0    
[00:00:10]:     Load FE    
[00:00:10]:     Load FE: done    
[00:00:10]: THREAD - started 'FilesExistAsyncThread' (12040)
[00:00:10]: FilesExistAsyncThread started (20447 files)...
[00:00:10]: OnLoadPermissionList: APP:Klei//DoNotStarveTogether/client_save/blocklist.txt (Failure)
[00:00:10]: OnLoadPermissionList: APP:Klei//DoNotStarveTogether/client_save/adminlist.txt (Failure)
[00:00:10]: OnLoadUserIdList: APP:Klei//DoNotStarveTogether/client_save/whitelist.txt (Failure)
[00:00:10]: [MOTD] Downloading info    
[00:00:10]: SimLuaProxy::QueryServer()
[00:00:10]: ModIndex: Load sequence finished successfully.    
[00:00:10]: Reset() returning
[00:00:13]: [MOTD] Downloading image for box1
[00:00:15]: [Steam] Auth Session Ticket requested...
[00:00:16]: [Steam] Got Auth Session Ticket
[00:00:16]: [MOTD] Done Loading.    
[00:00:17]: [200] Account Communication Success (3)
[00:00:17]: Logging in as KU_qaTCHkft
[00:00:18]: There is no active event to get the status of.
[00:00:18]: loaded inventory_cache_prod
[00:00:18]: loaded inventory_cache_prod
[00:00:20]: Getting top mod details...
[00:00:21]: unexpected end of data

If someone knows how to fix this please help me!

Edited by Guy Page

Share this post


Link to post
Share on other sites
Ultroman    695

You have just learned a valuable lesson in keeping copies of versions between larger changes (or using a version control system like Github).

When you get an issue before even starting the server, you can usually find the error in your modinfo.lua. 

[00:00:21]: unexpected end of data

...sounds like a modinfo.lua with a syntax error in it. Go over it with a keen eye, and if you can't find anything, post a zip of the mod so we can take a look.

Edited by Ultroman

Share this post


Link to post
Share on other sites
Guy Page    0
21 minutes ago, Ultroman said:

You have just learned a valuable lesson in keeping copies of versions between larger changes (or using a version control system like Github).

When you get an issue before even starting the server, you can usually find the error in your modinfo.lua. 


[00:00:21]: unexpected end of data

...sounds like a modinfo.lua with a syntax error in it. Go over it with a keen eye, and if you can't find anything, post a zip of the mod so we can take a look.

Yea xD first time doing this (clearly), but I'll never forget to save a copy again...

I couldn't find anything (probably cause i know very very little about modding) so I'll share the zip with yall!

I think it might be something with the images, modicon and/or the big portraits cause it started crashing after I messed with those guys.

guy mod.zip

Share this post


Link to post
Share on other sites
Ultroman    695

Nothing immediately stands out as wrong. I would guess that some of your XML-files for your textures have wrong references in them, or are referenced wrongly in the code. I don't know, but that's a common cause of these in-menu crashes. They even seem to be case-sensitive, so make sure you keep your capitalization (or lack thereof) consistent.

Share this post


Link to post
Share on other sites
Guy Page    0
On 18/02/2019 at 8:02 AM, Ultroman said:

Nothing immediately stands out as wrong. I would guess that some of your XML-files for your textures have wrong references in them, or are referenced wrongly in the code. I don't know, but that's a common cause of these in-menu crashes. They even seem to be case-sensitive, so make sure you keep your capitalization (or lack thereof) consistent.

so, i managed to fix the crashing + closing the game problem, I re-did all the .lua files and found out that the tags for the character were in the wrong place and fixed the names_guy.xml that had extra lines in it and then i opened the game to test out the mod and.... it crashed again, but this time its not closing the game, and then it says that the mod crashed on the mod selection screen... so ye... still tryin!

image.png.42963a979c2c0ab43223ba96548dcc3b.png

 

(edit) I checked on the game log and figured out what was making the mod crash and thought i had fixed it! but it started crashing and closing again but this time it happens on the character selection screen...

log.txt

O O F, the fight continues...

Edited by Guy Page

Share this post


Link to post
Share on other sites
Ultroman    695

Instead of posting the logs as text, just drag'n'drop them on your reply to attach the file to the reply. Much easier to scroll around in and read in our own text editors.

That you now get to character selection, sounds like your portrait XML might be wrong. If not, try taking care of these warnings. Make your images power of two sizes e.g. 128x128, 256x256, 512x512, 1024x1024, 512x1024, 1024x512 etc.

[00:00:27]: ../mods/workshop-1656703695/bigportraits/guy.tex is 560x720 but compressed textures must have power of 2 dimensions.
[00:00:27]: ../mods/workshop-1656703695/images/names_guy.tex is 624x275 but compressed textures must have power of 2 dimensions.
[00:00:27]: ../mods/workshop-1656703695/images/names_gold_guy.tex is 624x275 but compressed textures must have power of 2 dimensions.
[00:00:27]: ../mods/workshop-1656703695/bigportraits/guy_none.tex is 512x626 but compressed textures must have power of 2 dimensions.

Then compress/process the images again, making sure to change the settings so the XMLs properly "cut"/use the right part of the images.

Share this post


Link to post
Share on other sites
Guy Page    0
12 hours ago, Ultroman said:

Instead of posting the logs as text, just drag'n'drop them on your reply to attach the file to the reply. Much easier to scroll around in and read in our own text editors.

That you now get to character selection, sounds like your portrait XML might be wrong. If not, try taking care of these warnings. Make your images power of two sizes e.g. 128x128, 256x256, 512x512, 1024x1024, 512x1024, 1024x512 etc.


[00:00:27]: ../mods/workshop-1656703695/bigportraits/guy.tex is 560x720 but compressed textures must have power of 2 dimensions.
[00:00:27]: ../mods/workshop-1656703695/images/names_guy.tex is 624x275 but compressed textures must have power of 2 dimensions.
[00:00:27]: ../mods/workshop-1656703695/images/names_gold_guy.tex is 624x275 but compressed textures must have power of 2 dimensions.
[00:00:27]: ../mods/workshop-1656703695/bigportraits/guy_none.tex is 512x626 but compressed textures must have power of 2 dimensions.

Then compress/process the images again, making sure to change the settings so the XMLs properly "cut"/use the right part of the images.

Do ya know any program i could use to know the pixel coordinates? I'm having a hard time at changing the settings.

I'm using paint.net so I assume it would be better to use Photoshop for that.

Edited by Guy Page

Share this post


Link to post
Share on other sites
Ultroman    695

GIMP is a free image processing program. Try that out.

Just open your current image, and click Image and Canvas Size. Make sure the "chain" is broken, so the dimensions do not scale with each other. Change the image size in each dimension to be the first power-of-two number you find that is larger.

Then, to find the coordinates for each dimension, it'll be:

u1=0, u2=(oldSize / newSize), v1=0, v2=(oldSize / newSize)

Do the calculations and put in the numbers. That'll tell it to read from the top-left of the image to the coordinate representing the original image size.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this