Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

INTELLECT

[GAME-BREAKING] [ROG] FLINGOMATIC never works!

Recommended Posts

INTELLECT    0

This is in the Reign of Giants DLC only. I do not own shipwrecked.

This was through Steam on a Windows 10 laptop.

Steps to replicate this bug:

Load into a new world with any character. Give yourself godmode and creative mode to craft any item.

Craft the flingomatic and place it near any flammable object (tree, bush, etc.). Activate the flingomatic.

Light the flammable item on fire. Flingomatic will throw snowballs at itself and WILL NOT put the fire out!

Game will occasionally crash and exit instead when a Flingomatic is activated or tries to fire at an entity.

This started happening once the QOL update came out.

No mods were enabled, default world gen. 

Cheers

Share this post


Link to post
Share on other sites
bizziboi    1,768

Thanks for the report, I will have to investigate - not sure yet what can have caused this.

Share this post


Link to post
Share on other sites

Same issue (ROG as well). I tried submitting a bug via the game client but it failed with a message that was something along the lines of "unable to upload game data." I don't remember the exact message, but the reporting tool failed nevertheless.

Here is what I can tell you:

1) I have Steam Workshop mods installed but they are all disabled

2) I performed a "Verify Integrity of Game Files" through Steam (and the crashing still persists)

3) I started a new world, spawned in a Flingomatic to test and was able to reproduce the crash

4) The crash seems to only happen when the Flingomatic animation starts up (which I presume is when CalculateTrajectory is called)

I feel a bit uncomfortable attaching the complete log file (I don't feel like reading through the entire thing to redact potentially sensitive data), but below is the stack that appears after the crash:

[00:00:36]: scripts/mainfunctions.lua(937,1) ...starve/data/scripts/components/complexprojectile.lua:47: attempt to perform arithmetic on local 'speed' (a nil value)
LUA ERROR stack traceback:
    D:/Games/steamapps/common/dont_starve/data/scripts/components/complexprojectile.lua:47 in (method) CalculateTrajectory (Lua) <46-73>
    D:/Games/steamapps/common/dont_starve/data/scripts/components/complexprojectile.lua:99 in (method) Launch (Lua) <75-106>
    D:/Games/steamapps/common/dont_starve/data/scripts/prefabs/firesuppressor.lua:30 in (method) LaunchProjectile (Lua) <25-33>
    D:/Games/steamapps/common/dont_starve/data/scripts/stategraphs/SGfiresuppressor.lua:116 in (field) fn (Lua) <114-117>
    D:/Games/steamapps/common/dont_starve/data/scripts/stategraph.lua:492 in (method) UpdateState (Lua) <460-504>
    D:/Games/steamapps/common/dont_starve/data/scripts/stategraph.lua:531 in (method) Update (Lua) <523-551>
    D:/Games/steamapps/common/dont_starve/data/scripts/stategraph.lua:124 in (method) Update (Lua) <107-148>
    D:/Games/steamapps/common/dont_starve/data/scripts/update.lua:178 in () ? (Lua) <90-191>

If you would like the whole log file, I can send it if you have a support email.

Guess I'll need to head into the caves for now ;)

Cheers.

Share this post


Link to post
Share on other sites