10 Screenshots

About This File

  These 2 mods let you add backpack and amulet slots, increase inventory, backpacks and containers size.
  The Neat version can display custom bar badges (health, hunger, sanity), naughtiness meter and thermometer above the inventory. It has custom UI art, too.
 
  RoG and SW compatible.
 
 
  • Customization options
  What both mods have in common :
- Backpack slot : Yes/No
- Amulet slot : Yes/No
- Inventory size : Default version : 15, 20, 25, 55 / Neat version : 15, 25, 45
- Piggyback speed penalty : Yes/No
- Backpacks size : Default/Large (backpack : 10 - piggyback : 14 - Krampus sack : 20)
- Storable backpacks : Yes/No
- Containers size (chest and icebox, not chester) : Default/Large (16)
- Colored slots (chest, chester, icebox, crock pot) and custom equippable slots backgrounds.
- Corner shortcuts (pause, map, rotate) : Show/Hide
- Further zoom out without the game pushing it back to default.
 
  What's only in the Neat version :
- Custom badges : Yes/No
- Naughtiness meter : On/Off
- Thermometer : On/Off - Celsius/Fahrenheit
- Wetness value : Hover/Always show
- Clock text : Hover/Always show (for keyboard/mouse only)
 
 
  • Compatibilities
- High chance of incompatibility with mods that modify backpacks, inventory slots, equipment slots or chests.
- Neat version : Not compatible with mods that change badges (health/sanity/hunger) unless you don't use RPG HUD's cutom badges.
- Compatible with Always on Status but custom badges are turned off automatically to avoid crashes.
- If you encounter crashes, make sure your game is up to date first then try runnig this mod alone. If it works alone and crashes with another mod, it means they are not compatible. You can let me and the other mod's author know about it.
 
 
  • Playing with a controller
  When using a controller, the backpack content will be displayed in a single line underneath the inventory like in the vanilla game. However, since you can have very large backpacks, and in order to keep the UI nice and clean, the backpack line will never exceed the inventory/equipment line. Keep that in mind when customizing the options.
 
  Example : 15 slot inventory, no amulet/backpack slot : the line is composed of 15+3 = 18 slots. So a larger Krampus's sack (20 slots instead of 14) would be sized down to 18 slots aswell.
 
  Minor issue : If you disable your controller while in game, the very last (2-5) slots of your backpack may be inaccessible (Krampus sack + bigger backpacks + Neat 25 or Default 15). Just reload your save to fix that.
 
 
  • How to install this mod
  It's better to disable the Steam Cloud feature for the game. Always backup your savegames, profile and saveindex before installing a new mod or you'll be very sour if something goes wrong. They are usually located in "..\Steam\userdata\<your steam ID>\219740\remote" or "My documents\Klei\DoNotStarve\save". Backup all the files found in those folders.
 
  Extract the folder located in the archive to "...\Steam\steamapps\common\dont_starve\mods" or the equivalent if you use the standalone version. Once in game, head to the mods tab and activate the mod (the Neat version requires a restart) then configure it.
 
 
  • Quickest Q&A ever

  Q : Will you port this mod to DS Together ? 
  A : No. I won't be making any more mods. But if someone wanted to port my DS mods to DS Together, that's fine with me. 

  Q : How can I help you ? 
  A : You can give me feedback on glitches and crashes down below. If you are interested in testing RPG HUD before official releases, I created a steam group just for that. I'll put the newest files there and I would appreciate feedback. Here's the link to the group : Kiopho's Beta Testing.

 
 
  Thanks to everyone for your feedback which helps improve the mods tremendously.
  If you like the mod, show it some love and rate it. :)
  If you have any issues or suggestions, leave a comment down below.

Don't Starve Error.png


What's New in Version 2.31   See changelog

Released

V 2.1

- Added the missing "revealer" component

  • Like 24
  • Thanks 1



User Feedback



Recommended Comments

Is this compatible with Reign of Giants?(couldn't find anything...)

Also,every time I try this mo,it crashes,WHY?

 

EDIT:Now I see...so it's compatible,but how should I install it???

Share this comment


Link to comment
Share on other sites

Download, unzip, move the unzipped folder into your Game files in the MOD folder. Open game. Go into the mods section, enable RPG HUD, start a game.... enjoy!!

Share this comment


Link to comment
Share on other sites

Download, unzip, move the unzipped folder into your Game files in the MOD folder. Open game. Go into the mods section, enable RPG HUD, start a game.... enjoy!!

I've done all that,the problem is that it crashes every time...

Also,I don't have any other mods active.

Share this comment


Link to comment
Share on other sites

Ok... Make sure you don't have a folder of RPG HUD inside the folder of RPG HUD. When I unzip stuff to my desktop using WinRAR, that's usually what happens. It'll show in the game but crash.

  • Like 1

Share this comment


Link to comment
Share on other sites

Ok... Make sure you don't have a folder of RPG HUD inside the folder of RPG HUD. When I unzip stuff to my desktop using WinRAR, that's usually what happens. It'll show in the game but crash.

Alright,this is strange:

-if I use the v6.71,in the mod screen it says "Crashed"

-if I try using v6.70 or 6.60,it crashes IN THE GAME,right in the black screen...

What should I do?

 

EDIT:Maybe I should that the other mods(Infinite Tools;Too Many Items) work perfectly with my game.

Share this comment


Link to comment
Share on other sites

Are you running RoG and is it up to date? Before the latest patch the game would crash when trying to load  a fresh game with mods enabled. Make sure your up to date.

Share this comment


Link to comment
Share on other sites

Are you running RoG and is it up to date? Before the latest patch the game would crash when trying to load  a fresh game with mods enabled. Make sure your up to date.

Yeah,looks like I have the latest one(30 april,Where there's a Wilson...).

Share this comment


Link to comment
Share on other sites

That's not the latest...

Press backspace when you first start the game. The version will pop up in the bottom left corner.

Current version is 102572 - Where there's a Wilson

Share this comment


Link to comment
Share on other sites

That's not the latest...

Press backspace when you first start the game. The version will pop up in the bottom left corner.

Current version is 102572 - Where there's a Wilson

Ok so,today I got the latest version(102572),but it still crashes when I load a world...kiopho WTF?

Share this comment


Link to comment
Share on other sites

Ok so,today I got the latest version(102572),but it still crashes when I load a world...kiopho WTF?

 

Generally what makes the game crash with a mod is

1 - game/mod not up to date

2 - Incompatibility with another mod

 

Apart from that I see no reason why your game crashes. Are you sure you did everything correctly ? (put the right folder in the right place, etc)

Share this comment


Link to comment
Share on other sites

@defal... thx for the honesty, but you won't get help.

Oh,okay. And if i say, that this is a joke/prank and i have steam-version?

Or is not the case?

Share this comment


Link to comment
Share on other sites

Oh,okay. And if i say, that this is a joke/prank and i have steam-version?

Or is not the case?

 

Pirated versions are almost never up to date. That may be your problem.

I'm not gonna go off on a tangent about piracy and that jazz, but if you like the game, just pick it up. It's cheap and it's been on humble bundles/steam sales so many times. Plus, that's the best way to get it working fine.

Share this comment


Link to comment
Share on other sites

Pirated versions are almost never up to date. That may be your problem.

I'm not gonna go off on a tangent about piracy and that jazz, but if you like the game, just pick it up. It's cheap and it's been on humble bundles/steam sales so many times. Plus, that's the best way to get it working fine.

or you can update it! do it manually if its the case, simply go to the game folder and there, go to the updater folder, and then, update! it will be better if you buy the original one, but...

Share this comment


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now