10 Screenshots

About This File

  These 2 mods let you add backpack and amulet slots, increase inventory, backpacks and containers size.
  The Neat version can display custom bar badges (health, hunger, sanity), naughtiness meter and thermometer above the inventory. It has custom UI art, too.
 
  RoG and SW compatible.
 
 
  • Customization options
  What both mods have in common :
- Backpack slot : Yes/No
- Amulet slot : Yes/No
- Inventory size : Default version : 15, 20, 25, 55 / Neat version : 15, 25, 45
- Piggyback speed penalty : Yes/No
- Backpacks size : Default/Large (backpack : 10 - piggyback : 14 - Krampus sack : 20)
- Storable backpacks : Yes/No
- Containers size (chest and icebox, not chester) : Default/Large (16)
- Colored slots (chest, chester, icebox, crock pot) and custom equippable slots backgrounds.
- Corner shortcuts (pause, map, rotate) : Show/Hide
- Further zoom out without the game pushing it back to default.
 
  What's only in the Neat version :
- Custom badges : Yes/No
- Naughtiness meter : On/Off
- Thermometer : On/Off - Celsius/Fahrenheit
- Wetness value : Hover/Always show
- Clock text : Hover/Always show (for keyboard/mouse only)
 
 
  • Compatibilities
- High chance of incompatibility with mods that modify backpacks, inventory slots, equipment slots or chests.
- Neat version : Not compatible with mods that change badges (health/sanity/hunger) unless you don't use RPG HUD's cutom badges.
- Compatible with Always on Status but custom badges are turned off automatically to avoid crashes.
- If you encounter crashes, make sure your game is up to date first then try runnig this mod alone. If it works alone and crashes with another mod, it means they are not compatible. You can let me and the other mod's author know about it.
 
 
  • Playing with a controller
  When using a controller, the backpack content will be displayed in a single line underneath the inventory like in the vanilla game. However, since you can have very large backpacks, and in order to keep the UI nice and clean, the backpack line will never exceed the inventory/equipment line. Keep that in mind when customizing the options.
 
  Example : 15 slot inventory, no amulet/backpack slot : the line is composed of 15+3 = 18 slots. So a larger Krampus's sack (20 slots instead of 14) would be sized down to 18 slots aswell.
 
  Minor issue : If you disable your controller while in game, the very last (2-5) slots of your backpack may be inaccessible (Krampus sack + bigger backpacks + Neat 25 or Default 15). Just reload your save to fix that.
 
 
  • How to install this mod
  It's better to disable the Steam Cloud feature for the game. Always backup your savegames, profile and saveindex before installing a new mod or you'll be very sour if something goes wrong. They are usually located in "..\Steam\userdata\<your steam ID>\219740\remote" or "My documents\Klei\DoNotStarve\save". Backup all the files found in those folders.
 
  Extract the folder located in the archive to "...\Steam\steamapps\common\dont_starve\mods" or the equivalent if you use the standalone version. Once in game, head to the mods tab and activate the mod (the Neat version requires a restart) then configure it.
 
 
  • Quickest Q&A ever

  Q : Will you port this mod to DS Together ? 
  A : No. I won't be making any more mods. But if someone wanted to port my DS mods to DS Together, that's fine with me. 

  Q : How can I help you ? 
  A : You can give me feedback on glitches and crashes down below. If you are interested in testing RPG HUD before official releases, I created a steam group just for that. I'll put the newest files there and I would appreciate feedback. Here's the link to the group : Kiopho's Beta Testing.

 
 
  Thanks to everyone for your feedback which helps improve the mods tremendously.
  If you like the mod, show it some love and rate it. :)
  If you have any issues or suggestions, leave a comment down below.

Don't Starve Error.png


What's New in Version 2.31   See changelog

Released

V 2.1

- Added the missing "revealer" component

  • Like 24
  • Thanks 1



User Feedback



Recommended Comments

@NabellaLyn777 @ talmatityaho What versions of the game and mod are you using ? What other mods were running at the same time ?

Share this comment


Link to comment
Share on other sites

How can i fix with crash :(!!!!!

 

Help me help you : version, circumstances, does it crash when it's the only mod active, etc ?

Share this comment


Link to comment
Share on other sites

Pretty hard,i mean i try to install it but it says it need to restart game,and i'm using no-steam don't starve,i restart the game and nothing happens,game opens and game still saying need to restart

Share this comment


Link to comment
Share on other sites

Pretty hard,i mean i try to install it but it says it need to restart game,and i'm using no-steam don't starve,i restart the game and nothing happens,game opens and game still saying need to restart

All you need to do is make sure you updated your game to the latest version. The neat versions require restarting the game but not the others.

Share this comment


Link to comment
Share on other sites

Can someone help me?

It does not seem to work. I enable the neat 45 one. When I exit the game the mod is disabled. I kept trying and trying.

Now it won't even let me enable it. Plus nothing is coming up on the log. :(

I am using non-steam version and I am 100% sure I have the February update with all the hotfixes.

I also tried the normal 55 but it also doesn't work.

Hope you can help. PLZ!!!!!!!!!!!!!!!!! I love this mod.

Share this comment


Link to comment
Share on other sites

forgot to mention.

I do activate a lot and I mean a LOT of other mods.

If that is the problem i am sorry for wasting your time.

Share this comment


Link to comment
Share on other sites

forgot to mention.

I do activate a lot and I mean a LOT of other mods.

If that is the problem i am sorry for wasting your time.

 

First, try it on its own with no other mods running and report back.

Share this comment


Link to comment
Share on other sites

It crashes for me and it's the only one in there, I even removed the screecher mod. My game is All's well that Maxwell version. So it only works with some games and not with others?

Share this comment


Link to comment
Share on other sites

oh no I mean it says its out of date, it works perfectly fine it just scared me once when it crashed the game but that was my fault though I use other mods but plz take your time I didn't mean to make you feel rushed or anything :(

Share this comment


Link to comment
Share on other sites

It crashes for me and it's the only one in there, I even removed the screecher mod. My game is All's well that Maxwell version. So it only works with some games and not with others?

 

Make sure you have the latest build for the game : 98986. At least that's my build (Steam) but I believe both stand alone and steam versions are the same.

 

 

oh no I mean it says its out of date, it works perfectly fine it just scared me once when it crashed the game but that was my fault though I use other mods but plz take your time I didn't mean to make you feel rushed or anything  :(

 

No biggy mate, you did nothing wrong there.

Share this comment


Link to comment
Share on other sites

I have tried it without any mods as well but it still does not seem to work

plz help

(sorry for late response)

Share this comment


Link to comment
Share on other sites

Guys, game version, other mods running, crash report, etc. All these can help me help you.

Share this comment


Link to comment
Share on other sites

ups..sorry my bad, i just change API version to 4 and that solve my crash problem

thanks kiopho for amazing mod..^_^

Share this comment


Link to comment
Share on other sites

ups..sorry my bad, i just change API version to 4 and that solve my crash problem

thanks kiopho for amazing mod..^_^

That's good news :) Have fun !

Share this comment


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now