10 Screenshots

About This File

  These 2 mods let you add backpack and amulet slots, increase inventory, backpacks and containers size.
  The Neat version can display custom bar badges (health, hunger, sanity), naughtiness meter and thermometer above the inventory. It has custom UI art, too.
 
  RoG and SW compatible.
 
 
  • Customization options
  What both mods have in common :
- Backpack slot : Yes/No
- Amulet slot : Yes/No
- Inventory size : Default version : 15, 20, 25, 55 / Neat version : 15, 25, 45
- Piggyback speed penalty : Yes/No
- Backpacks size : Default/Large (backpack : 10 - piggyback : 14 - Krampus sack : 20)
- Storable backpacks : Yes/No
- Containers size (chest and icebox, not chester) : Default/Large (16)
- Colored slots (chest, chester, icebox, crock pot) and custom equippable slots backgrounds.
- Corner shortcuts (pause, map, rotate) : Show/Hide
- Further zoom out without the game pushing it back to default.
 
  What's only in the Neat version :
- Custom badges : Yes/No
- Naughtiness meter : On/Off
- Thermometer : On/Off - Celsius/Fahrenheit
- Wetness value : Hover/Always show
- Clock text : Hover/Always show (for keyboard/mouse only)
 
 
  • Compatibilities
- High chance of incompatibility with mods that modify backpacks, inventory slots, equipment slots or chests.
- Neat version : Not compatible with mods that change badges (health/sanity/hunger) unless you don't use RPG HUD's cutom badges.
- Compatible with Always on Status but custom badges are turned off automatically to avoid crashes.
- If you encounter crashes, make sure your game is up to date first then try runnig this mod alone. If it works alone and crashes with another mod, it means they are not compatible. You can let me and the other mod's author know about it.
 
 
  • Playing with a controller
  When using a controller, the backpack content will be displayed in a single line underneath the inventory like in the vanilla game. However, since you can have very large backpacks, and in order to keep the UI nice and clean, the backpack line will never exceed the inventory/equipment line. Keep that in mind when customizing the options.
 
  Example : 15 slot inventory, no amulet/backpack slot : the line is composed of 15+3 = 18 slots. So a larger Krampus's sack (20 slots instead of 14) would be sized down to 18 slots aswell.
 
  Minor issue : If you disable your controller while in game, the very last (2-5) slots of your backpack may be inaccessible (Krampus sack + bigger backpacks + Neat 25 or Default 15). Just reload your save to fix that.
 
 
  • How to install this mod
  It's better to disable the Steam Cloud feature for the game. Always backup your savegames, profile and saveindex before installing a new mod or you'll be very sour if something goes wrong. They are usually located in "..\Steam\userdata\<your steam ID>\219740\remote" or "My documents\Klei\DoNotStarve\save". Backup all the files found in those folders.
 
  Extract the folder located in the archive to "...\Steam\steamapps\common\dont_starve\mods" or the equivalent if you use the standalone version. Once in game, head to the mods tab and activate the mod (the Neat version requires a restart) then configure it.
 
 
  • Quickest Q&A ever

  Q : Will you port this mod to DS Together ? 
  A : No. I won't be making any more mods. But if someone wanted to port my DS mods to DS Together, that's fine with me. 

  Q : How can I help you ? 
  A : You can give me feedback on glitches and crashes down below. If you are interested in testing RPG HUD before official releases, I created a steam group just for that. I'll put the newest files there and I would appreciate feedback. Here's the link to the group : Kiopho's Beta Testing.

 
 
  Thanks to everyone for your feedback which helps improve the mods tremendously.
  If you like the mod, show it some love and rate it. :)
  If you have any issues or suggestions, leave a comment down below.

Don't Starve Error.png


What's New in Version 2.31   See changelog

Released

V 2.1

- Added the missing "revealer" component

  • Like 24
  • Thanks 1



User Feedback



Recommended Comments

Okay, here's my report on RPG HUD 11 NEAT.

 

Two major problems is that highlighting in the crafting menu to differentiate between items you can craft, items you can't craft, and fully unlocked items is broken.

 

Additionally, I can't see the Boat Durability.

 

I'm working on updating the mod.

Share this comment


Link to comment
Share on other sites

I can't download the new version 1.23. Is it just me or you did something to the file?

 

When I use v1.1 I can't see boat durability. When using inspect on the boat, the health bar is too big and there seem to be no slot to attach things for the boat (I'm using armored boat)

 

Is there anyway to fix this manually?

Share this comment


Link to comment
Share on other sites

Not sure what's going on, i've tried reinstalling the game multiple times, even not using the latest "hang ten" update, and no matter what i do i ALWAYS get a crash as soon as i pick something up on a new game of regular Don't Starve when using the controller. RPG HUD is the ONLY mod i have installed, and it appears to not do this if i play with KB+M but i'm so used to controller that it's nearly unplayable with keyboard for me now. Your update says it fixed controller compatibility but apparently it didn't?  Please help, thanks.

 

ERROR message:  

 

/mods/rpg hud/scripts/widgets/inventorybar.lua:870: variable 'NORMAL_TEXT_COLOR' is not declared

LUA ERROR stack traceback:

=[C] in function 'error'

...scripts/strict.lua(23,1)

.../data/.../mods/rpg hud/scripts/widgets/inventorybar.lua(870,1) in function 'UpdateCursorText'

.../data/.../mods/rpg hud/scripts/widgets/inventorybar.lua(1116,1) in function 'UpdateCursor'

.../data/.../mods/rpg hud/scri

 

then it ends.

 

 

EDIT: My friend had the GOG version rather than steam like i do so we logged into his GOG account and installed DS/RoG to my computer in a different spot. It gave a crash right after i would activate RPG HUD not even letting me start the game. I then overwrote my steam version files with shipwrecked onto this GOG versions /data/ folder, and it lets me play but does the same problem as before, any time i play with controller active it either crashes randomly after 30 seconds to a minute of playing no matter what, or will crash upon me picking a flower/flint/berry etc.. showing the same "NORMAL_TEXT_COLOR" error as before.

 

 

The weird thing is that i don't get this error when i play Shipwrecked, although i do have trouble with the "crockpot" glitch that happens when using a controller, and i noticed that when i have "always on status" and RPG HUD both active it crashes upon changing from controller to keyboard (the exact opposite of the above glitch/crash) but that seems to fix when i turned off 'always on status' mod, so i only run with RPG HUD now since it's the only mod i consider 100% necessary to enjoy the game.

Share this comment


Link to comment
Share on other sites

@Darkdeals That's very peculiar. I'll investigate that. Thanks for the feedback.

 

Try this version. It's the latest update, but I haven't really had the time to test it properly. So let's help each other out, if you don't mind. Everything should be OK in SW, RoG and vanilla with both controller and KB/M.

Share this comment


Link to comment
Share on other sites

@Darkdeals That's very peculiar. I'll investigate that. Thanks for the feedback.

 

Try this version. It's the latest update, but I haven't really had the time to test it properly. So let's help each other out, if you don't mind. Everything should be OK in SW, RoG and vanilla with both controller and KB/M.

 

 

That works just fine, for some reason only this new "RPG HUD NEAT 1.4" works though, i was using the newest normal (non NEAT) version (1.32 iirc?) and it wouldn't work.  I do prefer the options of the normal version to the NEAT one like having 20 inventory rather than just 15 or 25, and being able to modify chests in non vanilla etc.. but at least i got the mod to work in some version.  Thanks :)

Share this comment


Link to comment
Share on other sites

I also have the GoG version (Where There's a Wilson) and haven't had any luck getting this to work.  I've tried Regular, Neat, and the Beta to no avail.  They just say "Crashed" in the mod menu with no feedback of any sort.  Is there something really obvious I'm missing here?

Share this comment


Link to comment
Share on other sites

Okay, a quick update, if it helps.  Turns out part of the problem was the GoG version installer is out-of-date, using Klei's built-in updater fixed that.

 

I'm still getting an error when I try to load this though, both with the 2.02/2.03 release and the beta you linked to a few posts back.  But now at least it gives me an error log I can pass on.  Here you go;

 

scripts/modindex.lua(395,1) Could not load mod_config_data/modconfiguration_RPG HUD Neat    
scripts/mods.lua(170,1) Loading mod: RPG HUD Neat    
scripts/mods.lua(197,1) Mod: RPG HUD Neat    Loading modworldgenmain.lua    
scripts/mods.lua(205,1) Mod: RPG HUD Neat      Mod had no modworldgenmain.lua. Skipping.    
scripts/mods.lua(197,1) Mod: RPG HUD Neat    Loading modmain.lua    
scripts/mods.lua(211,1) Mod: RPG HUD Neat      Error loading mod!
...s/Don't Starve/data/../mods/RPG HUD Neat/modmain.lua:1392: variable 'CAPY_DLC' is not declared
LUA ERROR stack traceback:
        =[C] in function 'error'
        C:/GOG Games/Don't Starve/data/scripts/strict.lua(23,1)
        C:/GOG Games/Don't Starve/data/../mods/RPG HUD Neat/modmain.lua(1392,1) in main chunk
        =[C] in function 'xpcall'
        C:/GOG Games/Don't Starve/data/scripts/util.lua(439,1) in function 'RunInEnvironment'
        C:/GOG Games/Don't Starve/data/scripts/mods.lua(208,1) in function 'InitializeModMain'
        C:/GOG Games/Don't Starve/data/scripts/mods.lua(189,1) in function 'LoadMods'
        scripts/main.lua(229,1) in function 'ModSafeStartup'
        scripts/main.lua(274,1)
        =[C] in function 'SetPersistentString'
        C:/GOG Games/Don't Starve/data/scripts/mainfunctions.lua(18,1) in function 'SavePersistentString'
        C:/GOG Games/Don't Starve/data/scripts/modindex.lua(76,1)
        =[C] in function 'GetPersistentString'
        C:/GOG Games/Don't Starve/data/scripts/modindex.lua(63,1) in function 'BeginStartupSequence'
        scripts/main.lua(273,1) in function 'callback'
        C:/GOG Games/Don't Starve/data/scripts/modindex.lua(331,1)
        =[C] in function 'GetPersistentString'
        C:/GOG Games/Don't Starve/data/scripts/modindex.lua(311,1) in function 'Load'
        scripts/main.lua(272,1) in main chunk

 

I hope this helps you out, if not let me know and I'll try to get the right info for you/ go away and stop bugging you :)

Share this comment


Link to comment
Share on other sites

any chances to have it for DST?

 

Unfortunately, no. I lack the knowledge and the time. But someone else might, you never know.

Share this comment


Link to comment
Share on other sites

thanks for the answer kiopho and I really enjoy your mod excellent work, would you consider on doing an autocatch boomerang of your own? it seems klei broke each one that it is in the forum, if you dont mind of course. :D

Share this comment


Link to comment
Share on other sites

I can't download the file.

It will automatically logout when I try to download.

 

That's a problem with the site. Check with a moderator.

 

 

 

thanks for the answer kiopho and I really enjoy your mod excellent work, would you consider on doing an autocatch boomerang of your own? it seems klei broke each one that it is in the forum, if you dont mind of course. :grin:

 

I'm sure they'll eventually update those mods. I don't plan on making new mods anymore ; too much work and not enough time :(

Share this comment


Link to comment
Share on other sites

Thanks for answering again :D sadly to read that yeah I imagine how takes making mods and then supporting then well thanks a lot again for this great mod ^^

Share this comment


Link to comment
Share on other sites

Well I finally got this working again in the Standalone/GoG version of Don't Starve.  Apparently these versions are out-of date and get confused by the Shipwrecked DLC check.

 

With the help of this post;

 

http://forums.kleientertainment.com/topic/60709-mods-crashing-variable-capy-dlc-is-not-declared/

 

I was able to dummy the checks out and get it working.  If anyone else running these versions wants to get this working, the files that need editing are:

modmain.lua

customhealthbadge.lua

ntbadge.lua

 

modmain and customhealth have multiple checks, and be careful not to nuke the RoG checks at the same time.

Share this comment


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now