Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

Null1314

My server ping (Not dedicated) is showing as ???

Recommended Posts

Null1314    1

I've read other threads about this being a problem for people, I opened the port in windows firewall, as well as port forwarding it through my netgear router. I've also set everything that has to do with don't starve to "Run as administrator". Anything else I can do? I'd really rather not play by myself because nobody sees my server when they filter them by ping. Because nobody wants to join a server at which they assume they will have bad connection in.
 

Share this post


Link to post
Share on other sites
adjax    0

Are you sure that the settings are correct? You can look and check the settings on this site 192.168.1.1 Or try to update them. I always check settings here. I was helped many times. 

Share this post


Link to post
Share on other sites
Null1314    1

No I really don't think im using a dedicated ip, and im not hosting a dedicated server. I did also already check if it was my firewall that was blocking the ping from showing too and that wasn't it. I really don't know any other ways to fix this as i've seen more then one admins already try to help with this problem in the past on the forums. It'd be better for everyone if this problem was fixed because more then half of the hosted servers always have the "???" ping, so less people play with eachother.

Share this post


Link to post
Share on other sites
brbrmensch    417
13 hours ago, Null1314 said:

No I really don't think im using a dedicated ip, and im not hosting a dedicated server.

that's not related, you either have dedicated ip (that you can get from provider if you pay extra or by default if it's not greedy one) and both dedicated server hosted on your pc and server you launch in game will have visible ping or not and any server would have ???

 

ps the difference between dedicated and in-game launched servers are basically in servers' dependency in your game, you can even launch dedicated server of your in-game hosted world by starting nullrenderer with right parameters

Share this post


Link to post
Share on other sites
brbrmensch    417
1 hour ago, Null1314 said:

Well no I don't have a dedicated IP. What were you gonna suggest if I did have a dedicated IP?

to host a nice server

Share this post


Link to post
Share on other sites
jbeetle    1,764

From what I've read in the past about this issue, it can be because your server is using Klei's "punch through" process (sort of forcing a port forward) rather than having it legitimately port forwarded. It makes it easier for personal servers to show up in the server list (and for others to join), but also isn't able to guess the ping accurately enough to display.

Maybe @ImDaMisterL knows someone who can better explain it.

  • Like 1

Share this post


Link to post
Share on other sites
Null1314    1
2 hours ago, brbrmensch said:

to host a nice server

Ok i'm not asking how to host a "nice" server im asking about the "???" ping issue, there are dedicated IPs that have the same issue apparently.

Share this post


Link to post
Share on other sites
Null1314    1
50 minutes ago, jbeetle said:

From what I've read in the past about this issue, it can be because your server is using Klei's "punch through" process (sort of forcing a port forward) rather than having it legitimately port forwarded. It makes it easier for personal servers to show up in the server list (and for others to join), but also isn't able to guess the ping accurately enough to display.

Maybe @ImDaMisterL knows someone who can better explain it.

If it is supposed to make it easier for personal servers, then at the same time it makes it harder because only a limited amount of servers are even looked at usually due to only their ping actually being shown.

Share this post


Link to post
Share on other sites
jbeetle    1,764
1 hour ago, Null1314 said:

If it is supposed to make it easier for personal servers, then at the same time it makes it harder because only a limited amount of servers are even looked at usually due to only their ping actually being shown.

I don't disagree, but I do like that hamachi isn't required like many other indie games with multiplayer.

  • Like 1

Share this post


Link to post
Share on other sites
brbrmensch    417
On 3/20/2017 at 8:26 PM, Null1314 said:

Well no I don't have a dedicated IP

 

On 3/20/2017 at 11:47 PM, Null1314 said:

im asking about the "???" ping issue, there are dedicated IPs that have the same issue apparently

 

On 3/15/2017 at 3:56 AM, Null1314 said:

I've read other threads about this being a problem for people, I opened the port in windows firewall, as well as port forwarding it through my netgear router.

dude, you did fine, that (and a dedicated ip, of course) should be enough for ping being visible

On 3/20/2017 at 11:48 PM, Null1314 said:

If it is supposed to make it easier for personal servers, then at the same time it makes it harder because only a limited amount of servers are even looked at usually due to only their ping actually being shown.

if you make some observation, you'll find that is not how klei do, as i can see, they make game easy for edit and read (part of game is open), the game is configurable (via mods and even console) and servers are as well easily to manipulate with, you only need to be familiar with configuration files and some knowledge about setting network, and cmon, you did everything (of course, if you did that correct, which i believe you did because you did something a few people did - you read other threads)

Share this post


Link to post
Share on other sites
Null1314    1

So basically the vast majority of servers are unplayable for other people due to different things such as the server's: High ping or ping unknown, mods, the day the server is in(most people would want to start near the start of the server i'd guess), world edits, whether it has caves or not(which most don't), game mode type, and even the amount of players that are in it. As you can see there are just so many things that go into whether a player will join a server besides even if your ping is shown or not, which leads me to believe it is why there are so few players in multiplayer(without password servers). It just sucks because even when a server is dedicated, you still have all those other things to decide on for whether you want to play or not. Stuff like steam groups are just so dead so even those don't help much, and i'm not trying to have don't starve together as a job so im not gonna constantly join some dedicated teamspeak group or whatever just to play with people.

Share this post


Link to post
Share on other sites
brbrmensch    417

i'd rather go to server with ??? than to one with extra equip slots

but yes, you either have a party to play daily-weekly so you can at least live for some years or you play on publics till deerclops and leave, that's how time works. if you play for more than a year at once, you may have some issues please help me

  • Like 2

Share this post


Link to post
Share on other sites
Picklesaurus    51

I have the same problem with my Dedicated server, it always appears as "???", even though people can join it normally and , when near my region, there is no lag. @cezarica , port forwarding may fix his issue, but in my case it didn't ;/. Any idea on what else could i try or what is "blocking" the ping from being shown(sent/received)? 

Share this post


Link to post
Share on other sites
cezarica    253

On my router I port forward the following ports:

- master_port from the [SHARD] section inside cluster.ini, in my case is 11001

- server_port from the [NETWORK] section inside Master/server.ini, in my case is 11002

- server_port from the [NETWORK] section inside Caves/server.ini, in my case is 11003

And on the machine that is running the DST servers i have a firewall rule to accept the above mentioned ports, in my case 11002 and 11003, and ports 27018 and 27019 (even tough aren't port forwarded from the router).

What is funny is that the UDP port 10999 isn't port forwarded by the router and also isn't accepted by the machine firewall and it works, I mean it shows my server ping! So i guess you should try with port forwarding the two ports defined in server.ini in Master and Caves and make sure the machine that is running the DST servers accept them in the firewall.

 

Share this post


Link to post
Share on other sites