UPRiSER

[Don't Starve Together] Connection to Klei failed!

130 posts in this topic

Ok after I went deeper into the problem I found out my computer opens a port (ex. 58772) every time to connect to 104.154.85.165 which seems to be the server that is called Klei's server in the in-game message. netstat command shows every time I press the "Play!" button a connection is trying to establish but it remains in SYN_SENT status which means packet is being sent by my computer but there is no response from the server, although server is currently running and I have stable ping of 200ms to it. (high but stable, no packet loss or anything)

Share this post


Link to post
Share on other sites

I also tried to remove all mods, unsubscribe from them, delete mods folder, but no change, then I removed the game completely,deleted Klei folder in Documents folder and reinstalled the game but again no change...

This is so strange I cant think of any other possibilities or potential issue on my computer to block the connection, I believe this might not be a client side problem.

Share this post


Link to post
Share on other sites

Ok here's the solution, I can login simply using a VPN. why the hell Klei would restrict my access to the server?!?!?! :o

Share this post


Link to post
Share on other sites
On 10/5/2016 at 5:34 AM, ScottHansen said:

Hi, sorry for all the trouble logging in. We are not intentionally blocking you. Could you please try and connect again without the VPN and then post your log file?

Hello, thanks for your reply.

Here is the log file.

client_log.txt

 

Edited by UPRiSER

Share this post


Link to post
Share on other sites

hi

same problem here. but mine is sometimes i can login and most of the times cant. and there is a funny point that i can easily connect with proxy/vpn like this friend.

2 people like this

Share this post


Link to post
Share on other sites

Yep, i have same problem too, i buy Don't Starve Together to play with my friend and we have same connection problem, tried start game as Administrator, tried disabling Firewall, Antivirus, nothing helps. :(

2 people like this

Share this post


Link to post
Share on other sites

@darkhero @Refrectos and anyone else having this issue, could you please attach a log file when you are experiencing this issue, also if you could let us know what country you are in it would help (or pm me if you don't want to post your country)

4 people like this

Share this post


Link to post
Share on other sites
On 10/6/2016 at 9:04 PM, ScottHansen said:

@darkhero @Refrectos and anyone else having this issue, could you please attach a log file when you are experiencing this issue, also if you could let us know what country you are in it would help (or pm me if you don't want to post your country)

hi

here, this is my log file. and im from iran.

client_log.txt

1 person likes this

Share this post


Link to post
Share on other sites

@darkhero Thanks for the info.

We have identified the issue, hopefully it will be resolved by the end of the week.

4 people like this

Share this post


Link to post
Share on other sites
2 hours ago, ScottHansen said:

@darkhero @Refrectos and anyone else having this issue, could you please attach a log file when you are experiencing this issue, also if you could let us know what country you are in it would help (or pm me if you don't want to post your country)

Hello, i'm from Russia, Sevastopol. Here is my log file

client_log.txt

2 people like this

Share this post


Link to post
Share on other sites
On 08.10.2016 at 8:42 PM, ScottHansen said:

Thanks for the info, we'll continue working on this

Dear @ScottHansen

The issue is resolved for me.

Thank you for your great support. I appreciate it.


 

2016.jpg

2 people like this

Share this post


Link to post
Share on other sites

If you're still having problems, please send me what IP login.kleientertainment.com resolves to for you. You can do this with "ping login.kleientertainment.com" from a command line.

3 people like this

Share this post


Link to post
Share on other sites
1 hour ago, kapam6ojiuk said:

does not work,I did as you wrote,but it gives something strange.How can I find out differently?

You need to do that outside of the game interface, if you are a Windows user, type CMD in the search programs area, or look for the command prompt. It looks like a tiny DOS interface.
Over there you need to type ping login.kleientertainment.com and you will get a reply with the IP number Nome needs.

Share this post


Link to post
Share on other sites
16 minutes ago, kapam6ojiuk said:

 

104.154.85.165

 

23 hours ago, nome said:

If you're still having problems, please send me what IP login.kleientertainment.com resolves to for you. You can do this with "ping login.kleientertainment.com" from a command line.

 

Share this post


Link to post
Share on other sites

OK, that means you're still hitting a google cloud services IP instead of an amazon IP - so either you've got the old version cached, or the GeoDNS change I made didn't affect you.

  • Can you get to the google search engine or gmail?
  • Can you give me your IP address? A site like whatsmyip.net is a good way to get this.
1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now