Diabu

[Server Admin] Associate your server with a steam group

16 posts in this topic

You need to be the administrator or an officer of the Steam group.

1. Connect to Steam and go to your group page, then click on the "Edit group profile" link

 
Go_To_Group_Profile.png
 
 
You'll find the Steam ID of your group :
 
Group_Id.png

2. Edit cluster.ini file and add the following lines in the [steam] section :

[steam]
steam_group_id = YourGroupID
steam_group_admins = true
steam_group_only = true

Setting steam_group_admins to true will automatically make administrators (but not moderators) in your steam group administrators on your servers as well.

Setting steam_group_only to true will only allow members of the specified group to connect to your server. If you set it to false, your server will be open to everyone (unless you specify a password) but it will appear in the top of the server list for members of the group.

Edited by Ipsquiggle
updated to correct .ini
4 people like this

Share this post


Link to post
Share on other sites

I built a steam group, and then my friend added up, the configuration is such that
 

--------------------------------------------

[network]
steam_group_id = 9331684
steam_group_only = true

--------------------------------------------

But I and my friends have no access to the server.
This log is:

 

-------------------------------------------

[03:51:46]: New incoming connection 180.102.220.3|40531 GUID: 180144006414707933
[03:51:46]: ValidateGameSessionToken token: EYWnwxwnJeucDpfOX/x7+aSpEsNv+RuJ for: 180144006414707933
[03:51:56]: SendHandShakeServerListing
[03:51:56]: [Error] SendUserConnectAndAuthenticate failed for steamid '76561198194044582'
[03:51:56]: CloseConnectionWithReason: ID_DST_GAME_SESSION_AUTH_FAILED
[03:52:02]: New incoming connection 180.102.220.3|40512 GUID: 779122756871998014
[03:52:02]: ValidateGameSessionToken token: HTmZNeIuaf8Nxbw2UjKZQSaYYQMFcxws for: 779122756871998014
[03:52:03]: SendHandShakeServerListing
[03:52:03]: [Error] SendUserConnectAndAuthenticate failed for steamid '76561198194044582'
[03:52:03]: CloseConnectionWithReason: ID_DST_GAME_SESSION_AUTH_FAILED
[04:24:00]: New incoming connection 60.180.19.148|6388 GUID: 1044835712239828091
[04:24:00]: ValidateGameSessionToken token: rw^eyJVc2VySUQiOiJLVV80cnFVWU9pSCIsIkdhbWUiOiJEb250U3RhcnZlVG9nZXRoZXIiLCJQdXJwb3NlIjoiR2FtZVNlc3Npb24ifQ==^rfUvDatOZCsIx4TVGhS8MVACtc1p+uhF for: 1044835712239828091
[04:24:03]: SendHandShakeServerListing
[04:24:04]: [Error] SendUserConnectAndAuthenticate failed for steamid '76561198170773561'
[04:24:04]: CloseConnectionWithReason: ID_DST_GAME_SESSION_AUTH_FAILED

 

---------------------------

any bug or my config wrong?

 

 

Share this post


Link to post
Share on other sites

Hi @blambin

Judging from your log : 

[Error] SendUserConnectAndAuthenticate failed for steamid '76561198194044582'

Your server is not able to connect to Steam servers to check if the player is in your group or not.
Can you send me a full log by PM ?

Thanks
 

Share this post


Link to post
Share on other sites
[Error] SendUserConnectAndAuthenticate failed for steamid

 

Even if

steam_group_only = false

It happens only for first user. But all fine, user joins the server.

Edited by Maris

Share this post


Link to post
Share on other sites

Even if

steam_group_only = false

​It happens only for first user. But all fine, user joins the server.

A Dedicated server will always try to tell to Steam that you joined it. This allows your friends to join from the Steam friend list. But if that fails, you'll still be able to connect.

When the server is configured as Group only, it needs to be sure that you belongs to the group. So if this call fails, you are kicked. As steam denied your authentication, the server cannot know if it should accept you or not.

 

2 people like this

Share this post


Link to post
Share on other sites

And there is "friends only" status for some reason.

7591824.png

[STEAM]DISABLECLOUD = true[MISC]CONSOLE_ENABLED = trueautocompiler_enabled = false[network]default_server_name = [RUS!] Hardcore Server.;default_server_name = [RUS!] Challenge;default_server_name = [RUS!] Hardcore Server.;default_server_description = Sorry, maintenance.;default_server_description = Just don't be a noob.default_server_description = asd;default_server_description = 16:00-1:00 (msk) weekendgame_mode = wildernessmax_players = 22pvp = trueserver_port = 11001server_password = enable_snapshots = falseenable_vote_kick = falseenable_autosaver = falsetick_rate = 15connection_timeout = 5000server_save_slot = 1pause_when_empty = falsesteam_authentication_port = 11011steam_master_server_port = 11021steam_group_id = 6858012steam_group_only = false[account]

Share this post


Link to post
Share on other sites

Hi @Maris

In the last patch, we change "Friends hosted" behavior  to be "One of your friend is playing on this server" so I suppose that was the case.




Concerning the steam_group_only setting, you can make it works right now by editing steam_appid.txt in the dedicated /bin folder, and replace its content with the following:

322330

Then, you just have to restart your server.
 

 

Share this post


Link to post
Share on other sites

Not working for me, it just sits on the Deerclops loading screen:- 

 

Cant connect at all (with Steam auth on or off) since changing the BIN file as shown above. Once I delete the Steam file in /Bin it works as normal (with steam auth off).

 

 

79 (Wormhole Marks)    Registering prefabs   

 [00:00:03]: Mod: workshop-362175979 (Wormhole Marks)     Registering default mod prefab    

[00:00:03]: Mod: workshop-364255295 (Auto ReTrap)    Registering prefabs    [00:00:03]: Mod: workshop-364255295 (Auto ReTrap)     Registering default mod prefab    

[00:00:03]:     LOAD BE    [00:00:04]:     LOAD BE: done    

[00:00:04]: Deserialize world session from session/09C00062104BC333/0000000001    

[00:00:04]: Save file is at version nil    [00:00:04]:     Upgrading to 1...    

[00:00:04]: Converting summer to autumn:   

 [00:00:04]: Begin Session: 09C00062104BC333

[00:00:04]: saving to server_temp/server_save    

[00:00:04]: MiniMapComponent::AddAtlas( minimap/minimap_data.xml )

[00:00:04]: MiniMapComponent::AddAtlas( ../mods/workshop-362175979/images/mark_1.xml )

[00:00:04]: MiniMapComponent::AddAtlas( ../mods/workshop-362175979/images/mark_2.xml )

[00:00:04]: MiniMapComponent::AddAtlas( ../mods/workshop-362175979/images/mark_3.xml )

[00:00:04]: MiniMapComponent::AddAtlas( ../mods/workshop-362175979/images/mark_4.xml )

[00:00:04]: MiniMapComponent::AddAtlas( ../mods/workshop-362175979/images/mark_5.xml )

[00:00:04]: MiniMapComponent::AddAtlas( ../mods/workshop-362175979/images/mark_6.xml )

[00:00:04]: MiniMapComponent::AddAtlas( ../mods/workshop-362175979/images/mark_7.xml )

[00:00:04]: MiniMapComponent::AddAtlas( ../mods/workshop-362175979/images/mark_8.xml )

[00:00:04]: MiniMapComponent::AddAtlas( ../mods/workshop-362175979/images/mark_9.xml )

[00:00:04]: MiniMapComponent::AddAtlas( ../mods/workshop-362175979/images/mark_10.xml )

[00:00:04]: MiniMapComponent::AddAtlas( ../mods/workshop-362175979/images/mark_11.xml )

[00:00:04]: MiniMapComponent::AddAtlas( ../mods/workshop-362175979/images/mark_12.xml )

[00:00:05]: Loading Nav Grid    

[00:00:05]: OVERRIDE: setting    season_start    to    autumn    

[00:00:07]: Reconstructing topology    [00:00:07]:     ...Sorting points    

[00:00:07]:     ...Sorting edges    [00:00:07]:     ...Connecting nodes    

[00:00:07]:     ...Validating connections   

 [00:00:07]:     ...Housekeeping    [00:00:07]:     ...Done!    

[00:00:07]: 1 uploads added to server. From server_temp

[00:00:07]: Telling Client our new session identifier: 09C00062104BC333

[00:00:07]: ModIndex: Load sequence finished successfully.    

[00:00:07]: Reset() returning

[00:00:07]: [Warning] SteamGameServer_Init Failed

[00:00:07]: Your server will still start, but some Steam functionality may be missing

.[00:00:07]: Steam ports can be configured through command line by adding:[

00:00:07]: -steam_authentication_port 12345 -steam_master_server_port 12346

[00:00:07]: or through settings.ini, under the [network] heading[00:00:07]: steam_authentication_port = 12345

[00:00:07]: steam_master_server_port = 12346

[00:00:07]: SetLobbyGameServer 0OnNewConnection mostRecentExternalPort first time set to 1134

[00:00:43]: New incoming connection 86.5.141.211|60242 GUID: 535928362079442365

[00:00:43]: ValidateGameSessionToken token: SIhb3xnhrynWf2k/zUXeu8dyGJ7xl/fN for: 535928362079442365

[00:00:43]: SendHandShakeServerListing

 

Edited by Kuldiin

Share this post


Link to post
Share on other sites

Hi @Kuldiin

As you can see in your log, your server cannot connect to Steam servers. So if you server is group_only, no one will be able to connect.
 

[Warning] SteamGameServer_Init Failed[00:00:07]: Your server will still start, but some Steam functionality may be missing.[00:00:07]: Steam ports can be configured through command line by adding:[00:00:07]: -steam_authentication_port 12345 -steam_master_server_port 12346[00:00:07]: or through settings.ini, under the [network] heading[00:00:07]: steam_authentication_port = 12345[00:00:07]: steam_master_server_port = 12346

To make it works, you have to be sure that both of the steam ports are opened, defaults are 8766 and 27016. You can also change these port to other, as explained in the log.

Please try and tell me if it's still failing ;)

 

Share this post


Link to post
Share on other sites

The yesterday update should have fixed the steam_appid.txt file for dedicated server. You don't have to manually edit it anymore.

If you're still experiencing issue with steam features, feel free to PM me

Share this post


Link to post
Share on other sites

Hi @Kuldiin

As you can see in your log, your server cannot connect to Steam servers. So if you server is group_only, no one will be able to connect.

 

[Warning] SteamGameServer_Init Failed[00:00:07]: Your server will still start, but some Steam functionality may be missing.[00:00:07]: Steam ports can be configured through command line by adding:[00:00:07]: -steam_authentication_port 12345 -steam_master_server_port 12346[00:00:07]: or through settings.ini, under the [network] heading[00:00:07]: steam_authentication_port = 12345[00:00:07]: steam_master_server_port = 12346

To make it works, you have to be sure that both of the steam ports are opened, defaults are 8766 and 27016. You can also change these port to other, as explained in the log.

Please try and tell me if it's still failing ;)

 

 

 

Thank you.

I passed this information to my host (Citadel Servers) who got in touch with you at the time to resolve it.

 

Thanks again :)

Share this post


Link to post
Share on other sites

I get this error:

	Master: [00:00:14]: [Steam] SteamGameServer_Init(8768, 11002, 27018)
	[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
	

Share this post


Link to post
Share on other sites

i think this is outdated because in setting.ini there is no network option, there is a steam one though, and i tried both that and editing the cluster file and nothing worked to put my steam group on.

1 person likes this

Share this post


Link to post
Share on other sites

The file changed to cluster.ini and:

[STEAM]
steam_group_id = xxxx
steam_group_only = false

 

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now