smooth-landing

Jump to content

  • Log In with Google Log In with Steam      Sign In   
  • Create Account

Photo
- - - - -

Don't Starve: Steam Alpha - Terrible Framerate?


  • Please log in to reply
11 replies to this topic

#1 tribes33

    tribes33
  • Junior Member



  • 9 posts

Posted 09 November 2012 - 03:29 PM

I just bought the game from Steam, I was really excited for it since the Chrome version ran really smooth for me.
But I downloaded the game and immediately when I started the world, I got terrible framerate, about 10FPS.
Is there any way to fix this? Or is it just a problem with the Steam version, I'm really annoyed that I can't play the game..

#2 JoeW

    JoeW
  • Not Kevin


  • 2611 posts

Posted 09 November 2012 - 03:41 PM

Hey there,

We aren't aware of any issues currently that would cause you directly to have a decreased framerate in steam over chrome. Have you updated your drivers and directX? What are your hardware specs?

#3 tribes33

    tribes33
  • Junior Member



  • 9 posts

Posted 09 November 2012 - 03:50 PM

Hey,
I have a Intel Dual Core 1.5GHz with Intel HD Graphics (3000, I think) with 4GB of RAM, I have DirectX 11 on my computer. But I still don't get how the Steam version has such low framerate, the Chrome version is working really smooth but when I play it through Steam, I can't play at all, changing resolutions doesn't change anything.

#4 Excess

    Excess
  • Burns Things



  • 1444 posts

Posted 09 November 2012 - 03:56 PM

Are your graphics drivers up to date?
Don't Starve Controls (learn how to get around)
How to move with [Z][Q][S][D] (on an Azerty keyboard)
All you wanna know about multiplayer (but where too lazy to look for)

#5 tribes33

    tribes33
  • Junior Member



  • 9 posts

Posted 09 November 2012 - 03:58 PM

Are your graphics drivers up to date?


I'm pretty sure they are, I did download a driver update a couple weeks ago and it said that all my drivers are up to date.

#6 GDK

    GDK
  • Member



  • 97 posts

Posted 09 November 2012 - 05:55 PM

Have you tired changing the resolution and see if it workds better?
If it is the case (as it is for me) don't go any further , it's comes from your PC.

#7 Bogpad

    Bogpad
  • Senior Member



  • 558 posts

Posted 10 November 2012 - 03:08 AM

I have the problem on my laptop aswell, on my normal gaming PC everything runs smooth as silk, so I am relatively sure that it is indeed nothing on the games side, but a computer issue.

#8 tribes33

    tribes33
  • Junior Member



  • 9 posts

Posted 10 November 2012 - 04:48 AM

Changing the resolution does nothing, I guess I kinda wasted my money on the steam version now since I can't play it on a laptop..

#9 Finallink

    Finallink
  • Junior Member



  • 1 posts

Posted 19 November 2012 - 10:55 AM

Solved! I was having the same issue. One computer was running it smoothly while the other was at an extremely low FPS.

To solve, i went into the nvidia control panel > manage 3d settings > program settings. Since it is a steam game, you probably will have to add Don't Starve to the program list. To add it, the Default path for the game is C:\Program Files (x86)\Steam\steamapps\common\dont_starve\bin. In "bin" You should see a file called dontstarve_steam.

From there, on the "specify settings for this program" in the nvidia control panel. I turned on triple buffering and vertical sync.

I havent tested this extensively but so far the game has been running smoothly. Hope this helps!

Cheers

#10 mtlmike175

    mtlmike175
  • Junior Member



  • 8 posts

Posted 19 November 2012 - 01:16 PM

Solved! I was having the same issue. One computer was running it smoothly while the other was at an extremely low FPS.

To solve, i went into the nvidia control panel > manage 3d settings > program settings. Since it is a steam game, you probably will have to add Don't Starve to the program list. To add it, the Default path for the game is C:\Program Files (x86)\Steam\steamapps\common\dont_starve\bin. In "bin" You should see a file called dontstarve_steam.

From there, on the "specify settings for this program" in the nvidia control panel. I turned on triple buffering and vertical sync.

I havent tested this extensively but so far the game has been running smoothly. Hope this helps!

Cheers

OMGOSH Finallink you are my hero! Works for me!

#11 tribes33

    tribes33
  • Junior Member



  • 9 posts

Posted 27 November 2012 - 02:42 PM

Hey um, the newest update just added more settings and you can turn off Bloom and my game works smoothly now.

#12 SonicMooseman

    SonicMooseman
  • Junior Member



  • 1 posts

Posted 03 December 2012 - 07:53 PM

I need help here. I am having the microstuttering problem. I can't use the NVIDIA control panel either because I have an Intel Graphics HD Family card. Any help would be much appreciated.