smooth-landing

Jump to content

  • Log In with Google Log In with Steam      Sign In   
  • Create Account

Photo
- - - - -

Problems with Tutorials (Darts) - mark of the ninja

darts freeze steam tutorial windows 7

  • Please log in to reply
8 replies to this topic

#1 srolemberg

    srolemberg
  • Junior Member



  • 4 posts

Posted 03 March 2013 - 08:03 AM

Hello, recently bought the game 'Mark Of The Ninja' through Steam and would like to congratulate the team at Klei entertainment for the excellent work.However, I started playing the game so I downloaded the platform.Right at the beginning, specifically the part where the game teaches you how to use the Darts, the game just hangs and does not recognize the commands.The problem starts right after the 'B' button is pressed (to acquire the weapon).Then the game asks to aim at 2 of 3 targets with the 'Y' and then immediately calls the 'LT' is also pressed.But from there the game does not recognize the command 'LT' and only respond to commands to clear aim or a target.By pressing 'Start' the game enters the main menu and return to the character fires the darts. But they are frozen on the screen right next to it.By pressing 'Start' again, the darts move a little more and I end up repeating this process (if it were a movie 'Stop Motion') and when the darts hit the target the character does not respond to any other command.I have attached the images in my Photobucket album and am sending my system settings.http://s32.beta.phot...rk_Of_The_Ninja[ATTACH]4223[/ATTACH]
Spoiler

Attached Files



#2 Nels

    Nels
  • Super Moderator


  • 31 posts

Posted 03 March 2013 - 09:34 PM

Are you playing on a controller or mouse and keyboard? If it's a controller, is it a Microsoft 360 controller or another brand?

#3 srolemberg

    srolemberg
  • Junior Member



  • 4 posts

Posted 03 March 2013 - 11:33 PM

Microsoft 360 controller (wired).

#4 srolemberg

    srolemberg
  • Junior Member



  • 4 posts

Posted 20 March 2013 - 05:06 AM

= (I tried a few things but the problem still persists. Anyone have any idea what might be happening?I do not want to play on the keyboard.

#5 Brook

    Brook
  • Code Ninja


  • 92 posts

Posted 20 March 2013 - 09:41 AM

= (I tried a few things but the problem still persists. Anyone have any idea what might be happening?I do not want to play on the keyboard.

Hi srolemberg,Just to be clear, it sounds to me as though the game is behaving as if the LT is always being held down even when it is not?One thing you can try, when you get to this point in the game, is unplug your controller. Does the game resume working normally? If this is the case it sounds to me like there is some issue with your specific controller, perhaps the sensitivity on the trigger is a little wonky. We have tested the game extensively with Microsoft Xbox 360 controllers and haven't run into this specific problem, but they do occasionally break or wear out and cause similar types of issues.

#6 srolemberg

    srolemberg
  • Junior Member



  • 4 posts

Posted 20 March 2013 - 12:10 PM

Yes Removing the controller the game back to normal.But, I have other games that use the standard for XBOX 360 Controller (the new DMC, Max Payne 3, Castle Crashers, Big Picture on the platform Steam, Crysis 2, Sleeping Dogs, ...) and they work very well (and all these screen shots were taken with the default shortcut Big Picture).Anyway, I still have some solutions even decide to format my system (Windows 7, for 2 years I do not do this).Hope you can solve this. I really liked the game, even on the keyboard.=)

#7 Maximus Dexius

    Maximus Dexius
  • Junior Member

  • 6 posts

Posted 08 September 2013 - 07:51 PM

Hello all,

 

Ok I have exactly the very same issue exactly, and I also use a Wired XBOX 360 Controller, can anyone please help with a solution to this.

 

To ellaborate on this mine also has the following issues not to confuse the situation but mine is exactly the same.

 

http://forums.kleien...ly-please-help/

 

Thanks guys....please any answers to help here as I love this game but cannot play it in its current state

 

Many thanks in advance.......



#8 oIovoIo

    oIovoIo
  • Junior Member

  • 1 posts

Posted 11 September 2013 - 09:53 PM

I can confirm having a similar problem (playing with wireless Xbox360 controller in both my Windows7 and Linux Ubuntu 12.04 boots). Both the RT and the LT behave as if they are pressed down (I always defaulted to running, and once I got the darts, I could no longer play with the controller without having time be frozen). 

 

The controller is near brand new (has about a month's moderate use) and I have had no problem with this on any other game (and I've tried it out on just about every game released through humble bundle with controller support, so that's a lot of games.....) Possibly because the RT and LT are supposed to behave like a toggle in game, but the 360 triggers are designed for input based on a sliding value, not a toggle switch. Is it possible to remap the these to other buttons (e.g. the analog stick toggles)? That would be a good enough work around for me. 

 

 

Anyway, I love the games Klei Entertainment puts out, you guys do some really great work. Not having the controller work has been a bit of a disappointment, especially since gamepad support makes such a big difference for how much I enjoy a game... :( Here's hoping there's a solution!



#9 Wade

    Wade
  • Super Moderator


  • 5564 posts

Posted 12 September 2013 - 11:49 AM

We're making a couple of tweaks and fixes to the code which we hope will address this issue, but we need to make sure that the changes doesn't break anything else in controller functionality.

 

We hope to have an updated version available in the next couple of days to address this.







Also tagged with one or more of these keywords: darts, freeze, steam, tutorial, windows 7